1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

100000000 error mails per minut

Discussion in 'Plesk Expand Distributed Services Topics (Mail, DNS, Databases)' started by jovana, Aug 10, 2007.

  1. jovana

    jovana Regular Pleskian

    25
    57%
    Joined:
    May 31, 2006
    Messages:
    114
    Likes Received:
    0
    Location:
    Haarlem
    Please help me. within 5 minuts expand is generating 6000 e-mail error's about an element was unlocked forcedly...

    Code:
    Hello, Default Administrator.
    Element #372 on table cdns_zone_instance was unlocked forcedly. Element old state was set at  to "updating". New state is "updating".
    
    If I try to disable it in expand, it gives this error:

    Code:
    PROBLEM REPORT FOR ACTION #330672
    ==================
    
    ACTION INPUT
    -------------
    <?xml version="1.0"?>
    <packet version="2.2.0.46">
        <set>
            <filter>
                <ev_class>expand_element_unlock_forced</ev_class>
                <person_class>admin</person_class>
            </filter>
            <values>
                <enabled>false</enabled>
                <subject>Element was unlocked forcedly</subject>
                <body>Hello, <@greeting>.
    Element #<@element_id> on table <@table_name> was unlocked forcedly. Element old state was set at <@element_locked_at> to "<@element_old_state>". New state is "<@element_new_state>".</body>
            </values>
        </set>
    </packet>
    
    ACTION OUTPUT
    -------------
    
    
    ACTION LOG:
    --------------
    Aug 10 2007 14:57:03 [:30510] ERR: Error tuning notification event handler configuration. [XML] Cannot parse packet - invalid XML or DOM error. Fatal Error at file '', line 0, column 0: An exception occurred! Type:XMLPlatformException, Message:Could not read data from file.
    
    ACTION ERROR:
    --------------
    General failure:
    [XML] Cannot parse packet - invalid XML or DOM error. Fatal Error at file '', line 0, column 0: An exception occurred! Type:XMLPlatformException, Message:Could not read data from file.
    
    TASKMAN OUTPUT:
    --------------
    <?xml version="1.0" encoding="UTF-8" standalone="no"?>
    <packet version="0.1.1.0">
        <result>
            <status>error</status>
            <errtxt>Action executed with errors</errtxt>
        </result>
    </packet>
    ==================
    End of the Report
    
    How to get rid of this problem?
     
  2. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    You can disable mail sending via running
    /usr/local/expand/sbin/expandmysql tool and then executing an SQL command:
    update ev_handler_map set enabled_def='false', enabled='false' where ev_class_id='expand_element_unlock_forced' and handler_id='expand_notif';
     
  3. jovana

    jovana Regular Pleskian

    25
    57%
    Joined:
    May 31, 2006
    Messages:
    114
    Likes Received:
    0
    Location:
    Haarlem
    Thanks for the quick reply, but it seems like sending e-mail is still enabled....
     
  4. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    Hmm. Try that one:
    update ev_class set enabled ='false',
    enabled_def='false' where id='expand_element_unlock_forced';
     
  5. jovana

    jovana Regular Pleskian

    25
    57%
    Joined:
    May 31, 2006
    Messages:
    114
    Likes Received:
    0
    Location:
    Haarlem
    Okay, done (see output)

    Code:
    mysql> select * from ev_class where id='expand_element_unlock_forced';
    +------------------------------+-------------------------------+-------------+---------+
    | id                           | title                         | enabled_def | enabled |
    +------------------------------+-------------------------------+-------------+---------+
    | expand_element_unlock_forced | Element was unlocked forcedly | false       | false   |
    +------------------------------+-------------------------------+-------------+---------+
    1 row in set (0.00 sec)
    
    But in the expand panel it is still green, but expand is not sending e-mail enmore (thank god!).

    thanks for your help.
     
  6. MarkF

    MarkF Guest

    0
     
    Hi,

    We are also experiencing this problem now after our server was accidentally rebooted.
    We have run the commands above in order to stop the mails from coming, but how do we find out where the problem is and how to fix it?
     
Loading...