1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

401 Unauthorised Error

Discussion in 'Plesk for Windows - 8.x and Older' started by nandu_n, Nov 8, 2005.

  1. nandu_n

    nandu_n Guest

    0
     
    I purchased a new Windows VPS from a provider but I'm unable to access the pages after uploading the files.

    The PLESK default page works fine but not the ASP.NET pages.

    I'm getting the following error message

    Unauthorized
    Access is denied due to invalid credentials.

    I checked the IIS default pages and
    Can anybody help me as to how to fix this?

    Regards,
    Nandu
     
  2. JackL

    JackL Guest

    0
     
    Here are some steps you can follow (It assumes that you have ASP.NET extension allowed in IIS mmc Web services extensions and your ASP.NET works -- you can check event logs for possible errors):

    1. Try Plesk Reconfigurator (Start->All Programs-SWsoft->Plesk Reconfigurator-> Repair Plesk installation->check File Security)
    2. If above step has not helped:
    Start->Run->cmd
    cd %plesk_dir%
    websrvmng --remove-vhost --vhost-name=your_domain_name_which_doesn't_works
    ________________________________________
    check for errors if they are present post their description here
    ________________________________________
    websrvmng --reconfigure-vhost --vhost-name=your_domain_name_which_doesn't_works
    ________________________________________
    check for errors if they are present post their description here
    ________________________________________
    3. If above steps haven't helped:
    a).In IIS mmc right click domain -> Click Properties->Click Directory Security Tab->Click Change
    b).Ensure that anonymous access is selected
    c). Ensure that IUSR_domain_user account is selected for access
    d). Ensure that Windows integrated authentications is selected

    4).
    a).Click Start-> My Computer
    b). type %plesk_vhosts%->click enter
    c). Right click domain-> Click Sharing and Security-> Click Security Tab-> Click Advanced
    d). Ensure following ACL schema is applied:
    (Note: Domain user is an account you've created for domain user to access ftp)
    _________________________________________
    Administrator Full Control not inherited for this folder,and subfolders and files
    System Full Control not inherited for this folder,and subfolders and files
    Domain user Read not inherited for files only
    Domain user Read and Execute not inherited for this folder,and subfolders
    __________________________________________
    e) Double click domain-> Right click httpdocs-> Click Sharing and Security-> Click Security Tab-> Click Advanced
    f). Ensure following ACL schema is applied:
    __________________________________________
    Administrator Full Control not inherited for this folder,and subfolders and files
    System Full Control not inherited for this folder,and subfolders and files
    Domain user Full Control not inherited for subfolders and files
    Domain User Special not inherited for this folder only (will be detailed later)
    Plesk IIS WP USER (Machine\IWAM_application_pool) Read not inherited for files only
    Plesk IIS WP USER (Machine\IWAM_application_pool) Read and Execute not inherited for this folder,and subfolders
    Plesk IIS USER (Machine\IUSR_domain_user) Read not inherited for files only
    Plesk IIS USER (Machine\IUSR_domain_user) Read and Execute not inherited for this folder,and subfolders
    FPSE_xxxxx(Machine\FPSE_xxxxx) Read not inherited for files only
    FPSE_xxxxx(Machine\FPSE_xxxxx) Read and Execute not inherited for this folder,and subfolders
    _________________________________________

    (Note: the last two permissions present only if you have MS Front Page allowed for domain)
    _________________________________________
    Domain User special permissions set to allow
    Traverse folder/execute files
    List Folder/ Read Data
    Read Attributes
    Read Extended Attributes
    Create Files/Write Data
    Create Folders/Append Data
    Read Permissions
    __________________________________________
    5. If above two steps in addition to previous steps have not helped:
    a). Right click My Computer->Click Manage
    b) Double Click Local Users and Groups
    c) Click Users->In right pane right-click IUSR_domain user->Click reset password->type desired password ->click OK
    6. If above steps have not helped.
    a).Backup Domain using Plesk backup (Start->All Programs-SWsoft->Plesk backup->Ensure only that one domain checked-> Click Start) Ensure domain successfully backed up!!!!!
    ________________________________________
    check for errors if they are present post their description here
    ________________________________________
    b).Remove domain from Plesk (If you have external SQL databases ensure you know db user password, also write down any DSN created for domain)
    c). Restore domain from backup (Start->All Programs-SWsoft->Plesk restore-> select backup for domain->select by domains option-> Click next-> Ensure domain binded to right IP-> click next-> Ensure Keep current key option selected-> If you have MSSQL database enter user login and password-> Click Start
    d) Restart IIS
    7. If above steps haven't helped apply to SWsoft Inc.,:)

    John S.G.
     
  3. JackL

    JackL Guest

    0
     
    One more step

    The sub-authentication component, Iissuba.dll, is not enabled by default in IIS 6.0. In earlier versions, Iissuba.dll allowed IIS to manage passwords on anonymous accounts, which created a potential security risk. In IIS 6.0, you can use sub-authentication to manage passwords for anonymous accounts by meeting the following requirements:

    For applications which you assign anonymous access, the worker process runs as LocalSystem.
    The sub-authentication component, Iissuba.dll, is registered.
    The AnonymousPasswordSynch metabase property is enabled (set to true).

    John S.G.:)
     
  4. mehmett

    mehmett New Pleskian

    19
    35%
    Joined:
    Aug 21, 2009
    Messages:
    6
    Likes Received:
    0
    my friends have a problem. When you change the site via ftp password plesk panel "Access is denied due to invalid credentials." gives error. ftp user name or change the panel gives the same error, but reconfig did not solve the problem. My respect for you would be happy to help.
     
  5. dim_s@

    dim_s@ Basic Pleskian

    23
    23%
    Joined:
    Oct 30, 2008
    Messages:
    25
    Likes Received:
    0
    Location:
    UA
    When I run plesk reconfigurator on My Windows 2008 R2 Plesk 9.5.0 I recive the following error


    Faulting application name: reconfigurator.exe, version: 9.500.3718.21777, time stamp: 0x4b934242
    Faulting module name: psaobsolete.dll, version: 9.500.0.0, time stamp: 0x4b934bb9
    Exception code: 0xc0000409
    Fault offset: 0x00330e5b
    Faulting process id: 0x1554
    Faulting application start time: 0x01caedc7374d1da0
    Faulting application path: C:\Program Files (x86)\Parallels\Plesk\admin\bin\reconfigurator.exe
    Faulting module path: C:\Program Files (x86)\Parallels\Plesk\admin\bin\psaobsolete.dll
    Report Id: 7d44f300-59ba-11df-af73-00e08178c4ab
     
Loading...