1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

7.0.3 doesn't recognize ClamWin installation.

Discussion in 'Plesk for Windows - 8.x and Older' started by blemming, Dec 29, 2004.

  1. blemming

    blemming Guest

    0
     
    I installed the Windows distribution of clamAV (Version 0.37.3) from www.clamwin.net as the 7.0.3 installation notes said to do. However, Pleask is not recognizing the install.

    In the "Defaults Components" section is still reads:
    ClamAV (not installed)

    I have restarted Plesk and done a full reboot on the system. Still no luck.

    Any suggestions?
     
  2. blemming

    blemming Guest

    0
     
  3. cbtrussell

    cbtrussell Guest

    0
     
    Does the virus scanning actually work though? We've got ClamAV recognized and selected in Plesk, but emails are not being scanned with MailEnable Pro.

    The eicar test sig goes through every time.

    Brandon
     
  4. globalmcs

    globalmcs Regular Pleskian

    25
    57%
    Joined:
    Nov 23, 2004
    Messages:
    106
    Likes Received:
    0
  5. cbtrussell

    cbtrussell Guest

    0
     
    Thanks for the reply. I actually had that thread bookmarked already, it was very useful. I was ultimately able to get

    "Command line scanner returned: 1"

    from MailEnable, but it's not scanning inbound mail. I don't get it! :(

    Brandon
     
  6. blemming

    blemming Guest

    0
     
    I am using the standard edition of mailenable that ships with plesk. Once I uninstalled the clamWin.net distribution and installed the distribution from:

    http://www.sosdg.org/clamav-win32/index.php

    Everything has worked fine and inbound mail is scanned.
     
  7. globalmcs

    globalmcs Regular Pleskian

    25
    57%
    Joined:
    Nov 23, 2004
    Messages:
    106
    Likes Received:
    0
    Just checking, in MailEnable Pro go to the MTA Properties, Anti-virus/Filters and double check some of this setting

    * Check - Enable anti-virus/filter support
    * ClamWin Status Enable
    * Check - Enable selected anti-virus/filter

    Under the Tab Anti-Virus/Filters there is "Options..." Make sure you have the right path to the "clamscan.exe" and that there is a something in the Temp Directory Path Field.

    After all that Stop and Start the MTA, if you want some Print Screen let me know where I cant send them to you.
     
  8. aracnet

    aracnet Guest

    0
     
    Could you please explain how to do settings ?
     
  9. cbtrussell

    cbtrussell Guest

    0
     
    Just FYI, in the latest MailEnable, the AntiVirus filters options are located under Server > Filters > MailEnable Message Filters

    Attached is a screenshot of my setup. It seems OK to me. What I don't understand is why I get a successful result when I press the TEST button but MailEnable doesn't seem to be calling ClamAV when a new message comes through.

    You can see from the second screenshot that pickup events are enabled. I'm baffled. And pulling my hair out!! :)

    Brandon

    PS - for some reason the attachment didn't get posted.
     
  10. globalmcs

    globalmcs Regular Pleskian

    25
    57%
    Joined:
    Nov 23, 2004
    Messages:
    106
    Likes Received:
    0
    I just updated my Mailenable Pro to 1.54 restarted the server and now I cant get to it . I'll check it out later and see if I can get some screenshots for you.

    Before in Pro 1.52 you had to go to Server> Agents>MTA Properties> and Enable the Antivirus
     
  11. aracnet

    aracnet Guest

    0
     
    Please someone explain me please :

    1) How can Plesk 7.0.3 comes with ClamAv antivirus support if it is coming with ME standart. Because in the ME site it says antivirus support is for ME Pro and lAdvanced not for standart?

    2) If it is working with ME standart some once can do it?

    3) Do we have to buy ME Pro too to get Antivirus support?

    4) How much does it cost you Plesk+Ativirus cost you monthly?
     
  12. cbtrussell

    cbtrussell Guest

    0
     
    Found it - you have to stop the DrWeb service and start ClamAV service in

    Server > Service Management

    Pretty obvious now (I guess) :rolleyes:
     
  13. cbtrussell

    cbtrussell Guest

    0
     
    MailEnable Manager > servers > localhost > Filters > MailEnable Message Filter
     
  14. cbtrussell

    cbtrussell Guest

    0
     
    1 - I believe you can only use ClamAV with ME Pro.

    2 - See #1

    3 - See #1 (but ME Pro comes with a long free trial)

    4 - ClamAV is free for unlimited mailboxes. Be sure to use the SOSDG port here, NOT ClamWin
    http://www.sosdg.org/clamav-win32/index.php

    It's also important that you take the default path of c:\clamav-devel or else the AV won't work.

    Brandon
     
  15. gmoody

    gmoody Guest

    0
     
    The standard version of mailenable included with Plesk WILL scan messages with ClamAV installed and set as default within plesk. I have just spent some time configuring my servers in this configuration. You do not need to upgrade to Mailenable Pro for this to work. Mailenable standard allows for one pickup event in the MTA. Plesk has an ,exe file which I assume is compiled with support for both Dr. Web and ClamAV.
     
  16. brundle

    brundle Guest

    0
     
    Once the ClamAV version from SOSDG was installed and the clamd process runnning, how would one get MailEnable Standard / Plesk to use it to check mail?

    Does anyone know how to get the ClamAV service that is installed by the Plesk 7.03 update to work with this install of ClamAV? Is there some way to tie them together? Is it documented by Plesk somewhere?
     
  17. gmoody

    gmoody Guest

    0
     
    If ClamAV is installed properly it will be detected by Plesk. In the Plesk control panel under "server" you should have an icon for component defaults. Within the component defaults You should now be able to select ClamAV instead of Dr. Plesk. Once this is enabled ClamAV will be scanning all mail.
     
  18. flyby

    flyby Guest

    0
     
    but i try and clamav uses 100%cpu and makes errors in event log all the time.
     
  19. gmoody

    gmoody Guest

    0
     
    It would seem that if you do not purchase and install the Spamassassin module, the ClamAV service will exhibit the problems you are describing. Plesk support has also confirmed that Spamassassin does NOT work correctly on 7.0.3. So, right now you have 2 options, either buy the spamassassin add-on to get ClamAV to work (but spam will NOT be tagged) or don;t use ClamAV.
     
  20. flyby

    flyby Guest

    0
     
    Cool, dos dr.web works?
    I think i only have 8-10 pop3 account the the moment.
    I have Spamassassin module.
     
Loading...