1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

7.5.1 to 7.5.2 Failed

Discussion in 'Plesk for Linux - 8.x and Older' started by jpwdesigns, Feb 12, 2005.

  1. jpwdesigns

    jpwdesigns Guest

    0
     
    Don't know what happened. update log file is shown at bottom. the update failed and now I cant start plesk. it says:

    [root@*****root]# service psa start
    ===> Reading /etc/psa/psa.conf ...
    Starting psa-spamassassin service: [ OK ]
    Syntax error on line 213 of /usr/local/psa/admin/conf/httpsd.conf:
    Cannot load /usr/local/psa/admin/libexec/mod_info.so into server: /usr/local/psa/admin/libexec/mod_info.so: undefined symbol: top_module
    /usr/local/psa/admin/bin/httpsdctl start: httpd could not be started
    Starting Plesk: [FAILED]

    Any ideas?




    END OF UPDATE LOG:


    ERROR while trying to mysql datadir not found
    Check the error reason(see log file: /tmp/psa_7.5.2_FedoraCore_2_build75050128.11_upgrade.log), fix and try again

    Aborting...

    error: %post(psa-7.5.2-fc2.build75050128.11) scriptlet failed, exit status 1
    ===> Reading /etc/psa/psa.conf ...
    ===> Checking database
    ===> Reading /etc/psa/psa.conf ...
    ===> Setting up file owners
    ===> Installing database
    ===> Registering module
    ===> Reading /etc/psa/psa.conf ...
    ===> Setting up file owners
    ===> Installing database
    ===> Installing configuration files
    ===> Registering services
    ===> Registering module
    ===> Reading /etc/psa/psa.conf ...
    ===> Checking database
    ===> Checking kernel support for TUN/TAP
    ===> Reading /etc/psa/psa.conf ...
    ===> Setting up file owners
    ===> Installing database
    ===> Installing configuration files
    ===> Registering service
    ===> Registering module
    ===> Reading /etc/psa/psa.conf ...
    ===> Setting up file owners
    ===> Installing database
    ===> Installing configuration files
    ===> Registering module
    ===> Reading /etc/psa/psa.conf ...
    ===> Reading /etc/psa/psa.conf ...
    ===> Reading /etc/psa/psa.conf ...
    ===> Reading /etc/psa/psa.conf ...

    ----- end of output -----
    ===> Autoinstaller: stopped logging at Sat Feb 12 14:18:07 2005

    ***** end of log file *****
     
  2. gigcity

    gigcity Guest

    0
     
    Did you get an answer to this issue? I am having the same problem and am interested in how you resolved this issue.
     
  3. jpwdesigns

    jpwdesigns Guest

    0
     
    None yet. I actually commented out the mod_info from the httpds.conf file and got psa to start but the control panel never worked.

    You don't by any chance have a 1and1 fedora core root server do you?

    I suspect the problem has something to do with the hda1 getting full from the psa updater downloads into /root. Whenever hda1 gets full mysql starts to give table error 28, which is a "no disk space" error even though mysql is located on a different partition.

    Right now I am trying to get 4psa.com to take a look.
     
  4. gigcity

    gigcity Guest

    0
     
    I do have a 1and1 server (my in house server is the one that actually has the upgrade issue).

    I moved the rpm's on the 1and1 server and my in house server to avoid the issue that you mentioned.

    Strangely enough - the Plesk license ran out on the 1and1 server. 1and1 has been recommending hosing the box. I read here that I should just do an RPM update. Do you know what version of Plesk is on the 1and1 root server? Do I need a Plesk license in hand to do such an update?
     
Loading...