1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

7.5.3 OSCommerce more problems! - file(): URL file-access is disabled

Discussion in 'Plesk for Linux - 8.x and Older' started by djround, Jun 8, 2005.

  1. djround

    djround Guest

    0
     
    Hi All,

    Ive got a brand new 7.5.3 with just a few domains installed. I've just upgraded to this latest version and now OS Commerce is misbehaving... Ive already posted and had resolved the first issue concerning Warning: file_exists(): for more info on that solution follow:

    http://forum.plesk.com/showthread.php?s=&threadid=24657

    However my problem is this.. FINALLY got OSCommerce working, logged into the backend admin account, went into Localization -> Currencies and clicked update currencies.

    13 errors reported including the following:
    Warning: file(): URL file-access is disabled in the server configuration
    Warning: file(http://www.oanda.com/convert/fxdaily?
    Warning: implode(): Bad arguments.
    Warning: file(): URL file-access is disabled in the server configuration
    Warning: file(http://www.xe.net/ucc/convert.cgi?Amount=1&From=USD&To=USD): failed to open stream: no suitable wrapper could be found in

    etc... etc... etc...

    HEELLLPPPPP :)
     
  2. hardweb

    hardweb Guest

    0
     
    Make sure that you have register_globals enabled in /etc/php.ini and restart apache.
     
  3. perlboy

    perlboy Guest

    0
     
    Err,

    You mean url_fopens don't you? ;)

    Personally, I make default policy:

    safe_mode On
    register_globals Off
    allow_url_fopen Off

    Then manually enable it on a domain by domain basis.

    Stuart
     
Loading...