1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

7.5.3 ypdate apache problem

Discussion in 'Plesk for Linux - 8.x and Older' started by stewartrose, Aug 18, 2005.

  1. stewartrose

    stewartrose Guest

    0
     
    Good morning Team,
    I have just upgraded from 751 to 753 now my sites do not show up, I located the problem to the httpd not working, though doing a ps ax it appears to have some child processes running, if you goto the sites via https no problem, if you go via http dead, if you look at process table you see:
    14493 ? S 0:00 /usr/sbin/httpd
    14494 ? S 0:00 /usr/sbin/httpd

    if you look at the logs when you startup httpd this is what you get, any ideas please.....
    [Thu Aug 18 03:41:13 2005] [warn] child process 14491 still did not exit, sending a SIGTERM
    [Thu Aug 18 03:41:13 2005] [warn] child process 14492 still did not exit, sending a SIGTERM
    [Thu Aug 18 03:41:13 2005] [warn] child process 14493 still did not exit, sending a SIGTERM
    [Thu Aug 18 03:41:13 2005] [warn] child process 14494 still did not exit, sending a SIGTERM
    [Thu Aug 18 03:41:13 2005] [warn] child process 14495 still did not exit, sending a SIGTERM
    [Thu Aug 18 03:41:13 2005] [warn] child process 14496 still did not exit, sending a SIGTERM
    [Thu Aug 18 03:41:13 2005] [warn] child process 14497 still did not exit, sending a SIGTERM
    [Thu Aug 18 03:41:13 2005] [warn] child process 14498 still did not exit, sending a SIGTERM
    [Thu Aug 18 03:41:13 2005] [warn] child process 14510 still did not exit, sending a SIGTERM
    [Thu Aug 18 03:41:13 2005] [warn] child process 14491 still did not exit, sending a SIGTERM
    [Thu Aug 18 03:41:13 2005] [warn] child process 14492 still did not exit, sending a SIGTERM
    [Thu Aug 18 03:41:13 2005] [warn] child process 14493 still did not exit, sending a SIGTERM
    [Thu Aug 18 03:41:13 2005] [warn] child process 14494 still did not exit, sending a SIGTERM
    [Thu Aug 18 03:41:13 2005] [warn] child process 14495 still did not exit, sending a SIGTERM
    [Thu Aug 18 03:41:13 2005] [warn] child process 14496 still did not exit, sending a SIGTERM
    [Thu Aug 18 03:41:13 2005] [warn] child process 14497 still did not exit, sending a SIGTERM
    [Thu Aug 18 03:41:13 2005] [warn] child process 14498 still did not exit, sending a SIGTERM
    [Thu Aug 18 03:41:13 2005] [warn] child process 14510 still did not exit, sending a SIGTERM
    [Thu Aug 18 03:32:04 2005] [warn-phpd] Failed to register functions (pid 14482)
    [Thu Aug 18 03:32:04 2005] [warn-phpd] Failed to register functions (pid 14482)
    [Thu Aug 18 03:32:04 2005] [warn-phpd] Failed to register functions (pid 14482)
    [Thu Aug 18 03:32:04 2005] [warn-phpd] Failed to register functions (pid 14482)
    [Thu Aug 18 03:32:04 2005] [warn-phpd] Failed to register functions (pid 14482)
    [Thu Aug 18 03:32:04 2005] [warn-phpd] Failed to register functions (pid 14482)
    [Thu Aug 18 03:32:04 2005] [warn-phpd] Failed to register functions (pid 14482)
    [Thu Aug 18 03:32:04 2005] [warn-phpd] Failed to register functions (pid 14482)
    [Thu Aug 18 03:32:04 2005] [warn-phpd] Failed to register functions (pid 14482)
    [Thu Aug 18 03:41:14 2005] [notice] caught SIGTERM, shutting down
    [Thu Aug 18 03:41:18 2005] [notice] LDAP: Built with OpenLDAP LDAP SDK
    [Thu Aug 18 03:41:18 2005] [notice] LDAP: SSL support unavailable
    [Thu Aug 18 03:41:18 2005] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Thu Aug 18 03:41:18 2005] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
    [Thu Aug 18 03:41:18 2005] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
    [Thu Aug 18 03:41:18 2005] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
    [Thu Aug 18 03:41:19 2005] [notice] Digest: generating secret for digest authentication ...
    [Thu Aug 18 03:41:19 2005] [notice] Digest: done
    [Thu Aug 18 03:41:19 2005] [notice] LDAP: Built with OpenLDAP LDAP SDK
    [Thu Aug 18 03:41:19 2005] [notice] LDAP: SSL support unavailable
    PHP Warning: Function registration failed - duplicate name - __ex in Unknown on line 0
    PHP Warning: Function registration failed - duplicate name - ioncube_file_is_encoded in Unknown on line 0
    PHP Warning: Function registration failed - duplicate name - ioncube_file_info in Unknown on line 0
    PHP Warning: Function registration failed - duplicate name - ioncube_file_properties in Unknown on line 0
    PHP Warning: Function registration failed - duplicate name - ioncube_file_not_permissioned in Unknown on line 0
    PHP Warning: Function registration failed - duplicate name - ioncube_loader_version in Unknown on line 0
    PHP Warning: ionCube Loader: Unable to register functions, unable to load in Unknown on line 0
    [Thu Aug 18 03:41:19 2005] [notice] mod_python: Creating 32 session mutexes based on 150 max processes and 0 max threads.
    [Thu Aug 18 03:41:19 2005] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
    [Thu Aug 18 03:41:19 2005] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
    [Thu Aug 18 03:41:19 2005] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
    [Thu Aug 18 03:41:19 2005] [notice] Apache/2.0.51 (Fedora) configured -- resuming normal operations

    Best regards from Alan
     
  2. hardweb

    hardweb Guest

    0
     
    It looks that apache started fine. You may use an old version of ioncube encoder which breaks things, but in this case the non-PHP sites must work.
     
  3. stewartrose

    stewartrose Guest

    0
     
    Ioncube

    Hi, well you gave me the pointer, and the other pointer was in the logs it was a duplicate entry one in php.ini, and there happens to be an ioncube.ini to, so I remmed out one and it all works now...

    Thanks for the help. Alan
     
Loading...