1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

8.0 to 8.01 and Webmail now dead... Auth_imp: Required IMAP extension not found.

Discussion in 'Plesk for Linux - 8.x and Older' started by WebDork, Aug 2, 2006.

  1. WebDork

    WebDork Guest

    0
     
    Anyone able to give me any help on solving the following please ?

    Logging into webmail now gives:

    A fatal error has occurred
    Auth_imp: Required IMAP extension not found.
    Details have been logged for the administrator.

    [root@angusserver1 ~]# tail -f /var/log/psa-horde/psa-horde.log

    Aug 01 08:00:27 HORDE [emergency] [imp] Auth_imp: Required IMAP extension not found. [on line 44 of "/usr/share/psa-horde/imp/lib/Auth/imp.php"]
    Aug 01 12:31:51 HORDE [emergency] [imp] Auth_imp: Required IMAP extension not found. [on line 44 of "/usr/share/psa-horde/imp/lib/Auth/imp.php"]
    Aug 01 22:19:24 HORDE [emergency] [imp] Auth_imp: Required IMAP extension not found. [on line 44 of "/usr/share/psa-horde/imp/lib/Auth/imp.php"]
    Aug 01 23:55:17 HORDE [emergency] [imp] Auth_imp: Required IMAP extension not found. [on line 44 of "/usr/share/psa-horde/imp/lib/Auth/imp.php"]
    Aug 02 00:02:38 HORDE [emergency] [imp] Auth_imp: Required IMAP extension not found. [on line 44 of "/usr/share/psa-horde/imp/lib/Auth/imp.php"]
    Aug 02 05:59:57 HORDE [emergency] [imp] Auth_imp: Required IMAP extension not found. [on line 44 of "/usr/share/psa-horde/imp/lib/Auth/imp.php"]
    Aug 02 12:36:25 HORDE [emergency] [imp] Auth_imp: Required IMAP extension not found. [on line 44 of "/usr/share/psa-horde/imp/lib/Auth/imp.php"]
    Aug 02 23:03:28 HORDE [emergency] [imp] Auth_imp: Required IMAP extension not found. [on line 44 of "/usr/share/psa-horde/imp/lib/Auth/imp.php"]
    Aug 02 23:53:35 HORDE [emergency] [imp] Auth_imp: Required IMAP extension not found. [on line 44 of "/usr/share/psa-horde/imp/lib/Auth/imp.php"]

    Line 44 is basically this function:

    function Auth_imp($params = array())
    {
    if (!Util::extensionExists('imap')) {
    Horde::fatal(PEAR::raiseError(_("Auth_imp: Required IMAP extension not found.")), __FILE__, __LINE__);
    }
    }
     
  2. dirty@

    dirty@ Guest

    0
     
    if we talk about redhats then open webmail.domain.com/horde/test.php?mode=phpinfo

    check for options
    - Configuration File (php.ini) Path (should be /etc/php.ini)
    - Scan this dir for additional .ini files (should be /etc/php.d)
    - additional .ini files parsed (should be many various .ini files in /etc/php.d/)

    If you see that some option value is incorrect or not all .ini files are listed, then simply make a copy of files , remove originals and move copies back, for example:

    cp -Rp /etc/php.ini /etc/php.ini.new
    cp -Rp /etc/php.d /etc/php.d.new
    rm -rf /etc/php.ini /etc/php.d
    mv /etc/php.d.new /etc/php.d
    mv /etc/php.ini.new /etc/php.ini

    then restart apache.. it will help.
     
  3. dfgd

    dfgd New Pleskian

    19
     
    Joined:
    Aug 6, 2009
    Messages:
    2
    Likes Received:
    0
    Plesk 8.6 Auth_imp: Required IMAP extension not found

    If you get error message especially once you login to webmail, or from the log file below, there is a way to fix it.

    [root@vps109 init.d]# tail -n 5 /var/log/psa-horde/psa-horde.log
    Aug 06 13:00:51 HORDE [emergency] [imp] Auth_imp: Required IMAP extension not found. [on line 44 of "/usr/share/psa-horde/imp/lib/Auth/imp.php"]

    Login to Plesk control panel. Go to Plesk updater. Update related or all available Plesk components. It fix the issue.
     
  4. Eugene Kerner

    Eugene Kerner Guest

    0
     
    Its in php.ini

    Open php.ini and make sure the imap extension module is loaded: -

    extension=php_imap.dll

    If the line is preceded by a semi-colen (;) then remove the semi-colen.

    You may also need to set you extension_dir in php.ini, the one Im looking at says: -

    extension_dir = "c:/php/ext"

    You may need to restart your server after changes to php.ini .

    Rgds,
    Eugene.
     
Loading...