1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

8.0 to 8.2 Upgrade Failure - cannot connect to MySQL

Discussion in 'Plesk for Linux - 8.x and Older' started by DanielKeith, Sep 11, 2007.

  1. DanielKeith

    DanielKeith Guest

    0
     
    I have Plesk running on FC2. I went to Updater and click "install" for the default-checked items to upgrade from 8.0 or 8.1 (not sure). I received the log of the upgrade via email. Subject line: "Plesk autoupdate success report." However, now when I go to any of the websites on that server, I get a SiteBuilder dialog instead of the actual website. When I attempt to access Plesk (via browser), I get the following message:

    ERROR: PleskFatalException
    Components::componentUpdate() failed: Unable to exec utility packagemng: packagemng: Unable to connect to Plesk Database: Client does not support authentication protocol requested by server; consider upgrading MySQL client
    packagemng: Unable to connect to the mysql database

    0: /usr/local/psa/admin/auto_prepend/auth.php3:508

    I went back and looked at the log that was emailed to me. I noticed the following: Trying to stop BIND server... done
    dnsmng: Unable to connect to Plesk Database: Client does not support authentication protocol requested by server; consider upgrading MySQL client

    After that point in the log, the "Client does not support authentication protocol..." message appears over and over and over again.

    I desperately need to get these sites back up and running. Is there a way to fix this quickly? Or, is there a way to roll back the installation so that everything will work properly. Any help would be greatly appreciated!!

    -Daniel Keith
     
Loading...