1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

A few 7.5.1 problems ...

Discussion in 'Plesk for Linux - 8.x and Older' started by lvalics, Jan 8, 2005.

  1. lvalics

    lvalics Silver Pleskian Plesk Guru

    36
    43%
    Joined:
    Jun 20, 2003
    Messages:
    965
    Likes Received:
    32
    Location:
    Romania
    After some time, I observed some anomalies on PLESK 7.5.1.

    I create a DB and after I wanna see in PLESK phpMyAdmin, I get:
    SHOW DATABASES LIKE 'testdb'
    MySQL said: Documentation
    #1227 - Access denied. You need the SHOW DATABASES privilege for this operation

    It was created with PLESK so is strange.
    Only thing is that is MySQL 4.
    If I delete and recreate, than will be ok :-(

    An another sad thing is when I try to delete domain or create sometimes is stuck PLESK and nothing will happen and I cannot do anything until I not restart the server (or prbabbly some process need to be killed, but I cannot kill psaservmng ...

    Any ideea?
     
  2. lvalics

    lvalics Silver Pleskian Plesk Guru

    36
    43%
    Joined:
    Jun 20, 2003
    Messages:
    965
    Likes Received:
    32
    Location:
    Romania
    For first problem I find the solution, database name was wih _ underscore and even if PLESK accepted, not worked. So not use databas_like_this ...
     
  3. JLChafardet

    JLChafardet Regular Pleskian

    26
    57%
    Joined:
    Feb 20, 2004
    Messages:
    379
    Likes Received:
    0
    Location:
    Caracas - Venezuela
    Adding this to:
    /usr/local/psa/admin/htdocs/domains/databases/phpMyAdmin/config.inc.php

    solves the issue.

    $db_name = str_replace("_","\_", $db_name);

    cd /usr/local/psa/admin/htdocs/domains/databases/phpMyAdmin
    vi config.inc.php
    /You can disable
    Press I down the line that says
    // You can disable a server config entry by setting host to ''.

    and paste that line.

    save and exit.

    problem solved :)
     
Loading...