1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

A newer version of this product is already installed

Discussion in 'Plesk for Windows - 8.x and Older' started by tomoiaga, Dec 27, 2007.

  1. tomoiaga

    tomoiaga Guest

    0
     
    I've had issues with Plesk since I first installed it, everytime I try to update or modify it something goes wrong. I may be an idiot, but this is too much.

    The error I got this time with 8.3 was "A newer version of this product is already installed"


    Looking at Event Viewer I found this:

    Product: MySQL Connector/ODBC 3.51 -- A newer version of this product is already installed.

    I mean C'MON!! I installed that connector manually some time ago, why the update breaks because of that ? I'm sorry guys, I don't expect any help, I'm just very dissapointed.
     
  2. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Hello tomoiaga,

    Thank you for the report.
    We will investigate this scenario as soon as possible.
     
  3. tomoiaga

    tomoiaga Guest

    0
     
    Thank you!
     
  4. tomoiaga

    tomoiaga Guest

    0
     
    Oh well, removed the ODBC connector and tryed again. Guess what ?
    Plesk is down, webmail was down also, I had to fix it manually.
    The 8.3 update did not finished correctly and it tryed to do a rollback. Of course a lot of modifications it did were not rolled back so now I have a nonfunctional Plesk.

    Thank you SWSoft!!
     
  5. tomoiaga

    tomoiaga Guest

    0
     
    PHP Startup: Unable to load dynamic library '\Plesk\admin\modules\php_curl.dll' - Access is denied.

    What user should have access to load this dll ?
    psaadm already has access.
    I gived IIS_WPG access also.
    Please advise
     
  6. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Hello tomoiaga,

    unfortunately we cannot reproduce these issues in our lab.

    Regarding php_curl.dll - please comment it in %plesk_dir\admin\php.ini%
     
  7. JackL

    JackL Guest

    0
     
    Try to check permissions for %systemroot%\system32\libeay32.dll and ssleay32.dll (must be for psaadm and psacln at least rea, read and exacute)

    john S.G.
     
  8. prueba2387

    prueba2387 Guest

    0
     
    Hi:

    Same problem, "A newer version of this product is already installed", but that's not true because my current Plesk version is v8.2.0_build20070705.17

    Here's also what the log file shows:

    MSI (c) (84:8C) [10:50:37:093]: Final Patch Application Order:
    MSI (c) (84:8C) [10:50:37:093]: Other Patches:
    MSI (c) (84:8C) [10:50:37:093]: Unknown\Absent: {E519C933-1DC6-4B48-BE09-B13F02A41A9F} -
    Another version of this product is already installed. Installation of this version cannot continue. To configure or remove the existing version of this product, use Add/Remove Programs on the Control Panel.
    {E195DC26-A6B4-4E13-B8E9-D61B43997DDD}
    MSI (c) (84:8C) [10:50:37:125]: Product: Plesk 8.3 for Microsoft Windows -- Configuration failed.

    May be that {E519C933-1DC6-4B48-BE09-B13F02A41A9F} is missing, but have no idea of what it might be.


    More info, Event Viewer also reports the MySQL ODBC thing:

    Product: MySQL Connector/ODBC 3.51 -- A newer version of this product is already installed.

    In my opinion, this kind of scenarios should be foreseen to prevent such crashes.
     
  9. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Please try to uninstall MySQL Connector/ODBC 3.51 before Plesk upgrading.
     
Loading...