1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

add www. to my domain

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Oliver Devoogdt, Dec 15, 2009.

  1. Oliver Devoogdt

    Oliver Devoogdt Guest

    0
     
    Hi,


    I have a domain in plesk, but it can only be reached via test123.co.uk, it should also be accessible via www.test123.co.uk
    I've added www in DNS as the CNAME of the main domain, but now I am reaching the default webpage.
    Help, what to do now ?

    And yes I have CLI access. 9.2.1 on CentOS


    Oliver
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,547
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    Select this domain in list and click 'Modify' button. Then in Preferences select Switch On for WWW Prefix.
     
  3. Ken Granger

    Ken Granger Guest

    0
     
    Same Problem

    I'm experiencing the exact same problem. I have several domains with this problem. The www. box is checked for the domain properties, however only domain.com is accessable. I do have a cname for www.domain.com pointing to domain.com for each of the domains in question.

    When typing domain.com I see the correct index page, when typing www.domain.com I see the default plesk page.

    This is driving me and my clients nuts... I "Switched On" the www prefix under Modify Domain with no success.
     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,547
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    Did you tried to rebuild websettings with "websrvmng -v -a" after adding www prefix?
     
  5. Satoriya

    Satoriya Guest

    0
     
    Try to deactivate and then activate again 'www' checkbox for domain under
    Plesk CP > Domains > domain.tld > Rename domain
     
  6. divisionx

    divisionx New Pleskian

    22
    57%
    Joined:
    Jun 27, 2005
    Messages:
    15
    Likes Received:
    0
    Same problem: Plesk 9.2.3 CentOS 4

    The problem is firstly that www prefix is not ticked by default when you add a new domain. In older versions of Plesk it was. Why was this changed?

    When some clients add new domains they forget to tick www, or miss this www tick box, and then we can never seem to access these domains web sites as www.domain.tld, only as domain.tld leading to a total waste of time for everyone concerned.

    The only solution we have found is to delete the domains in question and start again making sure www prefix is ticked.

    Just so you can be sure we've tried various solutions:

    In Plesk after the domain was set-up without www. prefix ticked we went to domain -> DNS settings -> Restore defaults -> and ticked the www. prefix thinking this would fix it: No effect

    We have added it as a CNAME, ran websrvmng -v -a, restarted httpd: No effect

    We edited the httpd.include associated with the domain, added www. by hand, ran websrvmng -v -a, restarted httpd: No effect

    Please fix this!
     
  7. Brandon Gordon

    Brandon Gordon Guest

    0
     
    You can run this command from the server console to enable it manually. "C:\Program Files\Parallels\Plesk\admin\bin\domain.exe -u singledomain.com -www true"

    This doesn't solve the problem with it being disabled by default, though. The GUI steps from IgorG above also worked for me.

    This has been a problem for at least a year now. Does Parallels instead to fix it or is it "by design"? We need an option to set this in a domain template. It's that simple.
     
Loading...