1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

adding new IP to Plesk VEID fails

Discussion in 'Plesk Expand 2.2 Troubleshooting Issues' started by oinkie, Jul 4, 2008.

  1. oinkie

    oinkie Guest

    0
     
    Hi,

    I am trying to add an IP from Plesk Expand 2.2.1 to a Plesk server (Virtuozzo VM) running Plesk 8.3 on CentOS 4.6.

    Right now the Plesk server only has two IP's assigned to it: the non-public management IP and the public/shared IP which all domains use. Now a customer wants SSL, for which I want to add another exclusive IP.
    After creating a new IP Range for that server, which worked fine, I am now trying to actually assign an IP out of that pool to the Plesk server from the Expand interface. Then the process hangs for hours displaying "In Progress". Funnily enough, Expand already shows the new IP in the Plesk servers IP pool , but when I look on the server directly, it's not there...neither in the Plesk Admin interface nor via SSH/ifconfig.

    I am currently not sure why this is happening. Does anybody have suggestions?
     
  2. Bers

    Bers Basic Pleskian Staff Member

    23
    70%
    Joined:
    Jul 31, 2001
    Messages:
    73
    Likes Received:
    0
    Hello,

    Did you register the virtuozzo hardware node in the Plesk Expand? Was the Plesk server assigned to the hardware node in Plesk Expand?
     
  3. oinkie

    oinkie Guest

    0
     
    Hi Sergey,

    thank you for your reply. Yes, the Virtuozzo host is registered in Plesk Expand under "Virtuozzo HWN" and the VM's on it are "assigned".

    Anywhere I can look to give you more details?

    Or as interim "solution"...if I were to add the IP manually to the VEID via vzctl from the VZ host, will Plesk Expand pick up on that?

    Oinkie
     
  4. Bers

    Bers Basic Pleskian Staff Member

    23
    70%
    Joined:
    Jul 31, 2001
    Messages:
    73
    Likes Received:
    0
    Yes, it will.

    After you'd added the IP manually make sure what it appears under Plesk CP, then IP will appear in the Plesk Expand.

    But if it's not, you should go to the Plesk server page in the Expand CP, press Reload button, check Server IP addresses checkbox in the Other data area and finally press Ok button. Plesk Expand will reload IP addresses of the Plesk server.
     
  5. oinkie

    oinkie Guest

    0
     
    Thank you, Sergey, for the suggestions. I will try that. Of course, it doesn't solve the fundamental issue why Expand can't add the IP to the Plesk server. How does this work below the surface anyway...how does Expand try to set up the IP? Perhaps this will help me identify the problem.
     
  6. oinkie

    oinkie Guest

    0
     
    Turns out, it was an SSH problem from Expand to the VEID (although it worked fine from Expands root shell). Reimporting the Expand keys to the VEID did the trick apparently.

    Thanx for all the good and fast suggestions!

    Oinkie
     
Loading...