1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

All sites have register_globals off?

Discussion in 'Plesk for Linux - 8.x and Older' started by DennisCitus, Feb 14, 2005.

  1. DennisCitus

    DennisCitus Guest

    0
     
    Dear Plesk Administrators,

    I've recently installed a new server, but there's occuring a problem when creating a new domain in Plesk...

    Register_global seems to be set at 'Off', while it should be On.

    register_globals is set at On in /etc/php.ini. phpinfo.php says:
    Directive Local Value Master Value
    register_globals Off On

    So the local value for every domain is Off and the master value in php.ini is On.

    There are no .htaccess'es.

    See for example this newly createn domain
    httpd.include:
    Code:
    # ATTENTION!
    # DO NOT MODIFY THIS FILE OR ANY PART OF IT. THIS CAN RESULT IN IMPROPER PLESK
    # FUNCTIONING OR FAILURE, CAUSE DAMAGE AND LOSS OF DATA. IF YOU REQUIRE CUSTOM
    # MODIFICATIONS TO BE APPLIED TO THE CONFIGURATION, PLEASE, PERFORM THEM IN THE
    # FOLLOWING FILE(S):
    # /home/httpd/vhosts/citus.nl/conf/vhost.conf
    # /home/httpd/vhosts/citus.nl/subdomains/<subdomain-name>/conf/vhost.conf
    
    <VirtualHost 82.192.84.140:80>
            ServerName   citus.nl:80
            ServerAlias  [url]www.citus.nl[/url]
            UseCanonicalName Off
            DocumentRoot /home/httpd/vhosts/citus.nl/httpdocs
            CustomLog  /home/httpd/vhosts/citus.nl/statistics/logs/access_log combined
            ErrorLog   /home/httpd/vhosts/citus.nl/statistics/logs/error_log
    <IfModule mod_userdir.c>
            UserDir /home/httpd/vhosts/citus.nl/web_users
    </IfModule>
            <IfModule mod_ssl.c>
                    SSLEngine off
            </IfModule>
            <Directory /home/httpd/vhosts/citus.nl/httpdocs>
            <IfModule sapi_apache2.c>
                    php_admin_flag engine on
                    php_admin_value open_basedir "/home/httpd/vhosts/citus.nl/httpdocs:/tmp"
            </IfModule>
                    Options -Includes -ExecCGI
            </Directory>
            <Directory /home/httpd/vhosts/citus.nl/web_users>
            <IfModule sapi_apache2.c>
                    AddType text/plain .php .php4 .php3 .phtml
                    php_admin_flag engine off
            </IfModule>
            </Directory>
    </VirtualHost>
    Code:
    [root@server06 conf]# cat httpd.include | grep citus.nl
    ServerName server06.citus.nl
    ServerAdmin [email]info@citus.nl[/email]
    Include /home/httpd/vhosts/citus.nl/conf/httpd.include
    [root@server06 conf]#
    Also try http://babelfish.altavista.com for http://www.webhostingtalk.nl/showthread.php?s=&threadid=64762 (Dutch to English)

    Nowhere to be found it gives register_globals in any httpd configuration file. Only php_admin_value safe_mode etc...
     
  2. eilko

    eilko Regular Pleskian

    28
    73%
    Joined:
    Aug 1, 2001
    Messages:
    468
    Likes Received:
    4
    Location:
    Enschede, Netherlands
    have you checked /home/httpd/vhosts/citus.nl/conf/vhost.conf
    so php directives?
     
  3. DennisCitus

    DennisCitus Guest

    0
     
    Thanks for your reply.

    I forgot to mention it in my post, but it did not excist.
    Code:
    [root@server06 root]# ls /home/httpd/vhosts/citus.nl/conf
    httpd.include
    [root@server06 root]#
     
  4. DennisCitus

    DennisCitus Guest

    0
     
  5. eilko

    eilko Regular Pleskian

    28
    73%
    Joined:
    Aug 1, 2001
    Messages:
    468
    Likes Received:
    4
    Location:
    Enschede, Netherlands
  6. DennisCitus

    DennisCitus Guest

    0
     
    Yes, I did.

    Citus.nl is not actually running on this server. It was just a test-domain on server06.citus.nl (82.192.84.140)
     
Loading...