1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Anyone having same issue with Spam Assissan?

Discussion in 'Plesk for Linux - 8.x and Older' started by CBiLL, Jan 11, 2005.

  1. CBiLL

    CBiLL Guest

    0
     
    I didn't notice until several client started to complain that spam email had increase after the 7.5.1 upgrade so I looked into my email header and I can see Spam Assassin hits in every emails I get but after doing some checking I found out that whoever use "Delete" option instead of marking email with ***SPAM*** in the email spam filter, Spam Assassin will ignore those emails and will not appear in the email header ..

    I been using mark email with spam but whoever use "delete" option will not get checked by spam assassin and the email header will show no hits or being checked by spam assassin .. almost like selecting "delete" in spam filter completely bypass the email around spam filter ..


    A bug??? Does anyone have the simlar issue? Just wanted to check before I go further and look into my server to make sure it not something that came with 7.5.1 upgrade ..







    Here what the message source look like when your using mark ***SPAM***

    (this came from an test email that is not a spam so it's score below the hit score)

    Return-Path: <xxxx@xxxxxxxx.com>
    Delivered-To: 1-xxxxx@xxxxxxx.com
    Received: (qmail 31489 invoked from network); 11 Jan 2005 16:41:22 -0000
    Received: from localhost.epconline.net (HELO localhost) (127.0.0.1)
    by localhost.epconline.net with SMTP; 11 Jan 2005 16:41:22 -0000
    Received: from adsl-67-66-236-90.dsl.stlsmo.swbell.net (adsl-67-66-236-90.dsl.stlsmo.swbell.net [67.66.236.90])
    by xxxxxx.xxxxxxxxxx.com (IMP) with HTTP
    for <xxxxxxxx@xxxxxxxxx.com@xxxxxxxxxx>; Tue, 11 Jan 2005 10:41:22 -0600
    Message-ID: <1105461682.41e401b226b45@xxxxxx.xxxxxx.com>
    Date: Tue, 11 Jan 2005 10:41:22 -0600
    From: xxxxxxx@xxxxxxxx.com
    To: xxxxxxx@xxxxxxxx.com
    Subject: test with spam mark selected
    MIME-Version: 1.0
    Content-Type: text/plain; charset=ISO-8859-1
    Content-Transfer-Encoding: 8bit
    User-Agent: Internet Messaging Program (IMP) 3.2.3
    X-Originating-IP: 67.66.236.90
    X-Spam-Checker-Version: SpamAssassin 2.63 (2004-01-11) on ns1.xxxxxxxxxx.com
    X-Spam-Level: **
    X-Spam-Status: No, hits=2.9 required=4.0 tests=NO_REAL_NAME,RCVD_IN_DYNABLOCK,
    RCVD_IN_SORBS autolearn=no version=2.63



    You can see above in the header that spam assassin checked the email before sending it to the inbox on the server giving an score result to the email it checked ..






    Now I select "Delete" all spam in the spam filter and send another test email to the same address as above ..






    Return-Path: <xxxxxx@xxxxxxxxx.com>
    Delivered-To: 1-xxxxxxxxx@xxxxxx.com
    Received: (qmail 30333 invoked from network); 11 Jan 2005 16:31:07 -0000
    Received: from localhost.epconline.net (HELO localhost) (127.0.0.1)
    by localhost.epconline.net with SMTP; 11 Jan 2005 16:31:07 -0000
    Received: from adsl-67-66-236-90.dsl.stlsmo.swbell.net (adsl-67-66-236-90.dsl.stlsmo.swbell.net [67.66.236.90])
    by xxxxxxx.xxxxxxx.com (IMP) with HTTP
    for <xxxxxxxx@xxxxxxxx.com@localhost>; Tue, 11 Jan 2005 10:31:07 -0600
    Message-ID: <1105461067.41e3ff4bca4a1@xxxxxx.xxxxxxx.com>
    Date: Tue, 11 Jan 2005 10:31:07 -0600
    From: xxxxxxxx@xxxxxxx.com
    To: xxxxxx@xxxxxxxx.com
    Subject: test with delete spam selected
    MIME-Version: 1.0
    Content-Type: text/plain; charset=ISO-8859-1
    Content-Transfer-Encoding: 8bit
    User-Agent: Internet Messaging Program (IMP) 3.2.3
    X-Originating-IP: 67.66.236.90


    Now with the "delete" option selected .. spam assassin no longer check and score each emails and let it go directly to the inbox .. No Spam scores or stamp by spam assassin in the email header above at all ..





    Spam Assassin stop filtering emails that had been selected "Delete spam" in that email account spam filter ..

    I also notice that you can't turn and off spam filter anymore in email account preference .. only way to turn off and on the spam filter for emails account is to delete the email address and recreate it with or without spam filter ..

    I wonder if version 7.5.1 broke it and got the on/off spam filter bounded to "delete" button ..



    Bill
     
  2. Heywood

    Heywood Guest

    0
     
    Spamassassin configuration is seriously broken in Plesk 7.5 reloaded: if you have an account set up for Spam Filtering (as selected at the bottom of the "Mailbox management" screen), it should have a .qmail file in /var/qmail/mailnames/domain/username/.qmail with one of the following contents:

    If spam is to be deleted:
    | /usr/local/psa/bin/psa-spamc -f -u user@domain.tld -U /tmp/spamd_light.sock -c || exit 99
    ./Maildir/

    If spam is to be left in inbox:
    | if [ -z "$SA" ]; then export SA=1; /usr/local/psa/bin/psa-spamc -f -u user@domain.tld -U /tmp/spamd_light.sock > spamcheck$$; /var/qmail/bin/qmail-local "$USER" "$HOME" "$LOCAL" "" "" "$HOST" "$SENDER" "$DEFAULT" < spamcheck$$; retval=$?; rm -f spamcheck$$; [ $retval = 0 ] && exit 9
    9; exit $?; fi
    ./Maildir/


    If the "Use Server Settings" checkbox is checked, the text "spamd_light.sock" is replaced with "spamd_full.sock". That's what's supposed to happen. It's worth noting that this checkbox means "Use BOTH server and personal settings," not "Override the settings below with the server-wide settings."

    HOWEVER: Plesk 7.5 Reloaded gets this SERIOUSLY wrong: If you switch from "store in mailbox" to "delete", it always writes the .qmail file as if "server wide settings" was not checked. If you uncheck "server wide settings", click on the "Set" button, check "server wide settings", and click on the "Set" button again, the .qmail file will be written correctly. There are some conditions under which clicking on the "Delete" radio button doesn't produce the correct file (it leaves it as "leave in mailbox"). The opposite situation is almost certainly true also.

    There are also problems with the spamassassin configuration not being set up properly in .qmail when its main switch (which is on the mailbox screen) is turned "on".

    The only way to confirm that the cofiguration is right is to look in the .qmail files. The user interface (and the mySQL database) always shows the correct selections-- these just aren't correctly translated into .qmail file contents.

    I suspect (but haven't tested) that the mchk utility fixes all these problems, which is probably why they haven't bothered to fix the user interface-- but where does that leave those of us that expect our end users to configure their own spam filtering?

    This would be easy to fix by running a script similar to mchk in response to a "spamassassin_config_changed" event via the event manager. BUT THERE IS NO EVENT ASSOCIATED WITH SPAMASSASSIN CONFIG CHANGES. Only mailname changes, and spamassassin changes don't count as mailname changes. AND mailname_old isn't provided to the event handler for "mailname changed" (another bug). So we're up sheep creek without a paddle.

    Pretty much all you can do is run a cron job every minute that runs mchk (or something similar).

    When will SW-Soft fix this bug-ridden mess?!?!?!

    P.S. Don't get me started on the quality of a design that confitionally calls qmail-send from within a .qmail file...
     
  3. CBiLL

    CBiLL Guest

    0
     
    I knew it! ..

    Thanks and at least I know it wasn't just me ..

    I hope they fix it in the next version asap .. Clients are complaining about it.

    At least I am not pulling out my hair over it anymore ..

    Thanks for the explaination and details ..

    Bill
     
  4. sammykona

    sammykona Guest

    0
     
    ****, I knew there was something wrong. We have spamassassin setup for personal settings only (server wide is unchecked)
    We have a customer who does NOT want spamassassin, it isn't checked for any of his POP accounts and I even added his domain to the ignore list under the spamassassin config.
    After all this .. his email still gets filtered!

    What should be in his .qmail file so spamassassin can stop bothering him?
     
  5. justyxxxx

    justyxxxx Guest

    0
     
    I'm not sure if this relates directly to your problem, but customers of mine have chosen the option to Delete messages. I have my server set up to NOT SCAN server-wide. Anyway, they say that it tags the emails but doesn't delete. And so what I do is go in, put an additional star and save the change (basically just do something that requires a change to the current settings). Then, I set it to delete and save the change. Then, at least on my server, it starts deleting properly.
     
  6. GTI-NJ

    GTI-NJ Guest

    0
     
    Heywood, do you have what would go in the user_prefs file as well (assuming the user chooses to delete mail identified as spam)?
     
  7. Jllynch

    Jllynch Regular Pleskian

    28
     
    Joined:
    Nov 11, 2003
    Messages:
    242
    Likes Received:
    0
    Has anyone had any further progress on this or heard anymore back from SWsoft? Any idea when this might be fixed so we can actualy upgrade to 7.5.2?

    Justin
     
  8. jprince

    jprince Guest

    0
     
    Hello,

    FreeBSD distribution appears to work fine.
    .qmail file gets updated correctly when account
    changes are made. Email is deleted when
    instructed to do so.

    I am assuming you are using a "Linux" distro..
    Are they all the same ?

    Cheers.
     
  9. Jllynch

    Jllynch Regular Pleskian

    28
     
    Joined:
    Nov 11, 2003
    Messages:
    242
    Likes Received:
    0
    Yeah we are testing it on Redhat 9 and are getting these problems.
     
  10. CBiLL

    CBiLL Guest

    0
     
    Yeah I heard back from support ..

    Something to that effect "We'll forward this to our programmers"

    Bill
     
  11. irzyxel

    irzyxel Guest

    0
     
    bah, should read the forum before updating

    same problem here, rh9

    mchk seems to fix it for now, but dont forget to run a consistency restore if you use 4psa total domains, cause mchk will reset your rcpthosts file and alike !
     
  12. alex042

    alex042 Guest

    0
     
    We seem to be having an issue related to this and it was just brought to my attention. Spamassassin seems to be doing different filtering on mail depending on the smtp server. i.e. , a customer from domain1.com sends smtp mail to a customer on domain2.com on the same server. If customer from domain1.com uses mail.domain1.com on that server to send mail to someone else on that same server, spamassassin adds a spam score to that customers mail, in this case 2.6 for having a dynamic ip. But if the customer from domain1.com sends mail through and external smtp server, say mail.domainx.com, then spamassassin doesn't pick up the dynamic ip and doesn't tag the mail with it. Is this all part of the same issue here?

    How do we resolve this? I have a reseller who's having this problem sending mail to his customers and it's getting a little frustrating because the server tends to delete the messages because it thinks they're spam. I've been able to verify this with my own accounts so it's not just his ip block but something with spamassassin.
     
  13. insel

    insel Guest

    0
     
    It's an issue with spamassassin < 3.0.2.

    See http://wiki.apache.org/spamassassin/DynablockIssues for a workarround. (How many hits are given for RCVD_IN_DYNABLOCK can be taken from /usr/share/spamassassin/50_scores.cf)

    Don't forget to reload your spamassassin (SA) configuration after including a rule within the global config of SA.
     
  14. Jllynch

    Jllynch Regular Pleskian

    28
     
    Joined:
    Nov 11, 2003
    Messages:
    242
    Likes Received:
    0
    Have people had success with the info above this post?
     
  15. alex042

    alex042 Guest

    0
     
    Which one? The one right before yours? Yes, we dropped 2 points off of the DYNABLOCK setting which lowered things enough for at least a temporary fix until we can get spamassassin upgraded. It was actually pretty easy, just lower the scoring and restart spamassassin.
     
  16. Whistler

    Whistler Guest

    0
     
    I can confirm that the problem (and solution) written by Heywood also exists on my FreeBSD Plesk 7.1.6 (and 7.1.7) setup.

    Annoying - but yes, it actually helps unchecking the server wide settings and checking it again to enable SA correctly.

    After doing that - it also tags the parsed mails. .-)
     
  17. kpolillo

    kpolillo Guest

    0
     
    All my user_prefs files ended up empty after upgrade from 7.1.x to 7.5. I was able to fix this by going into the spamassasin prefs for each mail user, changing all the prefrences to something different. ie. if "hits required for spam" is set to 7, change it to 6, "modify subject by" is set to ****SPAM**** change to something else as well. Hit set, then change it all back to what you want and hit set again. Once I did this plesk re-wrote the .qmail and user_prefs files with the correct settings. Hope this works for you as well.
     
  18. ioda006

    ioda006 Guest

    0
     
    I'm on plesk 7.5.3 and this still seems to be a problem. Any word on if it's getting fixed anytime soon?
     
  19. jprince

    jprince Guest

    0
     
    Hello,
    Thought I would add this, from support.

     
  20. Jllynch

    Jllynch Regular Pleskian

    28
     
    Joined:
    Nov 11, 2003
    Messages:
    242
    Likes Received:
    0
    Thanks for posting that. I wish Plesk would post such info themselves. It is much easier for them to do that then all us nondevelopers who don't have the source code scratching our heads for months when it seems they are well aware of exactly what the issue it.
     
Loading...