1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Anyone seen this before ?

Discussion in 'Plesk for Linux - 8.x and Older' started by uhoh, Apr 12, 2005.

  1. uhoh

    uhoh Guest

    0
     
    FreeBSD server
    Trying to update to 7.5 from 7.0.x

    heres what I get:

    # sh psa_v7.5.2_build75050202.12_os_FreeBSD_4.9_i386.sh
    psa_v7.5.2_build75050202.12_os_FreeBSD_4.9_i386.sh: cannot create : directory nonexistent


    Anyone know where I should start looking?

    My server needs updated badly.
     
  2. hardweb

    hardweb Guest

    0
     
    Try:

    sh -x psa_v7.5.2_build75050202.12_os_FreeBSD_4.9_i386.sh

    and you will see the cause the problem.
     
  3. uhoh

    uhoh Guest

    0
     
    # sh -x psa_v7.5.2_build75050202.12_os_FreeBSD_4.9_i386.sh
    + param_1=
    + can_uninstall=1
    + do_upgrade=0
    + backup_required=1
    + fp_upgrade_required=1
    + interactive_allowed=1
    + service_failures_ignoring=0
    + check_autoinstaller_installation_mode
    + local pid
    + [ x = x ]
    + PPID_STORED=95751
    + getppid 95751
    + ps+ sed -o 1d;s/[[:space:]]*//g ppid
    -p 95751
    + GPPID_STORED=95748
    + getppid 95748
    + ps+ sed -o 1d;s/[[:space:]]*//g ppid
    -p 95748
    + GGPPID_STORED=95747
    + ps+ grep -o -q command autoinstaller -p
    95751
    + ps+ grep -o -q command autoinstaller -p
    95748
    + ps+ grep -o -q command autoinstaller -p
    95747
    + test_for_root
    + id
    + my_id=uid=0(root) gid=0(wheel) groups=0(wheel), 2(kmem), 3(sys), 4(tty), 5(operator), 20(staff), 31(guest)
    + product_conf
    + initial_conf
    + DEMO_VERSION=no
    + PRODNAME=psa
    + PRODUCT_NAME=Plesk
    + product_full=Plesk
    + PRODUCT_FULL_NAME=Plesk
    + product_etc=/etc/psa
    + prod_conf_t=/etc/psa/psa.conf
    + prodkey=/etc/psa/psa.key
    + minimal_changes=
    + MYSQL_VERS=4.1.7
    + POSTGRESQL_VERS=7.4.6
    + EXTERNAL_PACKAGES=expat libiconv
    + EXTERNAL_PACKAGES_DIR=tmp/packages
    + PERL5LIB=/usr/local/psa/lib/perl5/site_perl/5.005
    + export PERL5LIB
    + product_bs=Plesk
    + support_email=support@sw-soft.com
    + sales_email=sales@sw-soft.com
    + product_version=7.5.2
    + product_db_version=0752
    + product_build=75050202.12
    + conceived_os_vendor=FreeBSD
    + conceived_os_version=4.9
    + osrels=
    + known_product_versions=71 75
    + prev_product=plesk
    + prev_clients_group=pleskcln
    + mm_mailgroup=110
    + [ Xno = Xyes ]
    + PRODUCT_DEFAULT_PASSWORD=setup
    + pwd
    + my_name_0=/usr/home/setups/psa/PSA_7.5.2/Standard
    + [ 0 -ne 0 ]
    + basename psa_v7.5.2_build75050202.12_os_FreeBSD_4.9_i386.sh
    + my_name_1=psa_v7.5.2_build75050202.12_os_FreeBSD_4.9_i386.sh
    + echo+ sed psa_v7.5.2_build75050202.12_os_FreeBSD_4.9_i386.sh -e
    s/^\.\///
    + my_name_2=psa_v7.5.2_build75050202.12_os_FreeBSD_4.9_i386.sh
    + echo+ egrep psa_v7.5.2_build75050202.12_os_FreeBSD_4.9_i386.sh ^/

    + my_name=/usr/home/setups/psa/PSA_7.5.2/Standard/psa_v7.5.2_build75050202.12_os_FreeBSD_4.9_i386.sh
    + product_default_conf
    + PRODUCT_ROOT_D=/usr/local/psa
    + PRODUCT_RC_D=/usr/local/psa/rc.d
    + HTTPD_VHOSTS_D=/usr/local/psa/home/vhosts
    + HTTPD_CONF_D=/usr/local/psa/apache/conf
    + HTTPD_BIN_D=/usr/local/psa/apache/bin
    + QMAIL_ROOT_D=/usr/local/psa/qmail
    + QMAIL_MAILNAMES_D=/usr/local/psa/qmail/mailnames
    + RBLSMTPD=/usr/local/psa/qmail/bin/rblsmtpd
    + COURIER_IMAP_ROOT_D=/usr/local/psa/courier-imap
    + FTPD_CONF=/usr/local/psa/ftpd/etc/proftpd.conf
    + FTPD_CONF_INC=/usr/local/psa/ftpd/etc/proftpd.include
    + FTPD_BIN_D=/usr/local/psa/ftpd/bin
    + FTPD_VAR_D=/usr/local/psa/ftpd/var
    + OPENSSL=/usr/local/psa/admin/bin/openssl
    + NAMED_RUN_ROOT_D=/usr/local/psa/named/run-root
    + WEB_STAT=/usr/local/psa/webalizer/bin/webalizer
    + LOGROTATE=/usr/local/psa/logrotate/sbin/logrotate
    + MYSQL_VAR_D=/usr/local/psa/mysql/var
    + MYSQL_BIN_D=/usr/local/psa/mysql/bin
    + PGSQL_DATA_D=/usr/local/psa/postgresql/data
    + PGSQL_BIN_D=/usr/local/psa/postgresql/bin
    + DUMP_D=/usr/local/psa/var/dumps
    + MAILMAN_ROOT_D=/usr/local/psa/mailman
    + MAILMAN_VAR_D=/usr/local/psa/mailman
    + CATALINA_HOME=/usr/local/psa/tomcat4
    + MIGRATION_STORAGE_D=/usr/local/psa/PMM/archives
    + DRWEB_ROOT_D=/usr/local/drweb
    + DRWEB_ETC_D=/usr/local/etc/drweb
    + APACHE_ROOT=/usr/local/psa/apache
    + TRUE_BIN=/usr/local/psa/qmail/bin/true
    + rpm_suexec_bin=/usr/sbin/psa-suexec
    + MYSQL_SOCKETS=/var/lib/mysql/mysql.sock /tmp/mysql.sock /var/run/mysqld/mysqld.sock
    + parse_tomcat_conf
    + T4_CF=/etc/tomcat4/tomcat4.conf
    + [ -r /etc/tomcat4/tomcat4.conf ]
    + set_local_params
    + set_common_params
    + PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin
    + LANG=C
    + export PATH LANG
    + umask 022
    + ulimit -n 65535
    + K_HUP=/bin/kill -HUP
    + K_KILL=/bin/kill -KILL
    + K_TERM=/bin/kill -TERM
    + K_USR2=/bin/kill -USR2
    + users_created=
    + groups_created=
    + certificate_file=/usr/local/psa/etc/httpsd.pem
    + product=psa
    + START_SH=/usr/local/psa/rc.d/psa
    + clients_group=psacln
    + clients_GID=10001
    + services_group=psaserv
    + services_GID=10003
    + pop_user=popuser
    + pop_UID=110
    + pop_group=popuser
    + pop_GID=110
    + date +%m.%d;%H:%M
    + product_suff=saved_by_psa.04.14;12:29
    + product_suffo=saved_by_psa
    + common_var=0
    + services=/etc/services
    + fstab=/etc/fstab
    + mtab=/etc/mtab
    + xinetd_conf=/etc/xinetd.conf
    + xinetd_dir=/etc/xinetd.d
    + inetd_conf=/etc/inetd.conf
    + syslog_conf=/etc/syslog.conf
    + get_hostname=hostname
    + get_domainname=domainname
    + vza_file=/var/vzagent
    + PREV_PRODUCT_ROOT_D=/usr/local/plesk
    + tar=tar
    + crontab=/usr/bin/crontab
    + uname -a
    + TARGET_OS=FreeBSD 4.9-STABLE
    + unsp_ptf
    + ptf=
    + p_echo
    + echo
    psa_v7.5.2_build75050202.12_os_FreeBSD_4.9_i386.sh: cannot create : directory nonexistent
     
  4. uhoh

    uhoh Guest

    0
     
    I stil dont see a cause, am I over looking it?
     
  5. ice51

    ice51 Guest

    0
     
    I didn't know you could upgrade from 7.0.x to 7.5 without going through 7.1.x first?
     
  6. hardweb

    hardweb Guest

    0
     
    If you try to upgrade from Plesk 7 to Plesk 7.5, you must first go through Plesk 7.1.
     
Loading...