1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

anyone used psa autoinstaller?

Discussion in 'Plesk for Linux - 8.x and Older' started by redblue, May 1, 2006.

  1. redblue

    redblue Guest

    0
     
    Hello,

    Just curious if anyone has run the "psa_installer_v2.0.0_build75050908.11_os_RedHat_7.3_i686" script on their server?

    The script displayed the following:

    Can someone please explain what are these packages? And why are there newer versions of them on the server?

    Plesk support says I need to
    Does this mean Plesk 7.5.3 and 7.5.4 now requires Postgre SQL in order to run? I never have Postgre SQL on my server before for the previous Plesk 7.5 version. Where can I find detailed instructions on how to run this autoinstaller?
     
  2. faris

    faris Guest

    0
     
    WHen you run the auto-installer, at one point it will ask you what Plesk components you want to install. One of these is postgresql.

    In order for this package to work with plesk, you need a package called php-pgsql (this is essentially an interface between php and postgresql)

    On your system you have a version of php which is newer than the "stock" version of php that Plesk knows about.

    The version of php and php-pgsql must be the same. And you don't have php-pgsql installed on your system.

    Plesk notices this and tries to install php-pgsql but since it has the wrong version it can't do so (that's the :

    Installing php-pgsql-4.3.10-0.i386.rpm
    error: failed dependencies:
    php = 4.3.10-0 is needed by php-pgsql-4.3.10-0

    which is saying "I can't install php-pgsql-4.3.10-0 because you need php = 4.3.10-0 installed". It does not tell you that this is because you have php-4.3.11-mecca1 installed -- you are somehow supposed to magically know this)

    So, what do you do?

    Well, the simplest thing would be to UNCHECK the postgresql component when given the list of things that you want Plesk to install in the first few pages of the installer. You should untick other things you don't want too. For example the Countrstrike server, Tomcat, Coldfusion, PPWSE, and basically all components that your key does not support and also those you simply don't want.

    This will help things go more smoothly.

    Faris.
     
  3. redblue

    redblue Guest

    0
     
    Hello,

    Thanks for the reply. However, when I tried to deselect PosgreSQL support, Plesk says
    A more detailed capture is as follow:
    Does this mean I have to rollback my PHP to 4.3.10-0 so when Plesk install its PosgreSQL it'd be of the same version? Because when I select "yes" to deselect them all as prompted above, it also deslects 1. [*] Base packages of Plesk. If the base packages of Plesk is deselected also, that'd mean there's no upgrade to Plesk?

    Thanks
     
  4. eilko

    eilko Regular Pleskian

    28
    73%
    Joined:
    Aug 1, 2001
    Messages:
    468
    Likes Received:
    4
    Location:
    Enschede, Netherlands
    just install the php-pgsql RPM from your own php version and you're done. Its name is probably php-pgsql-4.3.11-mecca1.rpm
     
  5. faris

    faris Guest

    0
     
    Yes, its OK. You just need to do exactly as eilko says and all should be well.

    I'm very surprised about the postgress support being required by the base packages of Plesk thing though. That's strange. But it if needs it there's no way around it other than to make sure that the package eilko mentions is installed.

    Faris.
     
  6. redblue

    redblue Guest

    0
     
    Hello,

    Yeah SWSoft says if I install the PosgreSQL of the same version as my PHP, then it'd be fine. But I don't know how to do this. I have to install the RPM of this PosgreSQL, right? If so, what command should I issue to find and install it?
     
  7. faris

    faris Guest

    0
     
    You are on Redhat 7.3?

    I think you can do it by using:

    up2date php-pgsql

    BUT, I don't know where you got the original unusual version of php which is what is causing the problem, so it may be that up2dat isn't set to look in the right place for it, so be careful.

    I would suggest contacting the technical support department for the company that provided your server (or set it up).

    Faris.
     
  8. redblue

    redblue Guest

    0
     
    Hello,

    It says bash: up2date: command not found
    But isn't it like "rpm -install <packagename>" or something along that line?
    Any idea of where the posgreSQL install files maybe stored at?

    I tried searching for php-pgsql-4.3.11-mecca1.rpm by typing "locate php-pgsql-4.3.11-mecca1.rpm" but it returns nothing. So it must be of another filename. However, I don't know how to do the search with an incomplete filename (ie php-pgsql-4.3.11*)
     
  9. faris

    faris Guest

    0
     
    up2date is a program that actually downloads the required application onto your server (and installs it) while rpm is the program that installs already downloaded applications. up2date is a standard application on the redhat platform and used to download things from the RedHat Network. However, given that you are on 7.3, which is VERY old in the grand scheme of things, and no further updates are available for it from the RedHat network, I suspect you might have been switched to yum. So try

    yum list updates to see if it shows anything, and if it does, try

    yum install php-pgsql

    As a side note, where on earth did you find a new server running RH7.3? Everybody I've come accross has switched to Centos or RH Enterprise 3 or 4.

    Faris.
     
  10. redblue

    redblue Guest

    0
     
    Hello,

    I see. The server was actually started a year ago. Maybe back then 7.3 was the latest release.

    I tried the command "yum" but it didn't work.
    I also just realized I shouldn't be using the php-pgsql-4.3.11-2.8.i386.rpm I downloaded because I'm using a i686 processor.
    I was told that Fedcora Core is the latest Linux release? And it requires a 64 bit processor to run. But I still see some Fedora Core compiled for the ix86. Can you please clarify a bit? Also, how do I update it to the latest version? Afterall, it's not as simple as running an update program like in Windows.
     
  11. faris

    faris Guest

    0
     
    It isn't possible to upgrade your OS without starting from scratch (i.e. formatting and starting again) (well, I'm sure it is, but it is generally not advisable).

    I'm afraid this is now beyond my ability to offer suggestions -- with any luck someone else will come along and say "all you need to do is XYZ - simple!"

    But for me, I'd contact your server's suppliers for advise on upgrading things. They may have a a simple mechanism that uses something different to yum or up2date.

    Faris.
     
  12. faris

    faris Guest

    0
     
    oh, one thing though -- don't worry about i386/i686 -- it doesn't matter. i386 just means it will work on i386 atchitecture - you'll have lots and lots of packages installed that are "i386".

    Faris.
     
  13. redblue

    redblue Guest

    0
     
    Hello,

    Okay then. If i386 or i686 doesn't matter, let me ask you this. After I tried to "rpm -i php-pgsql-4.3.11-2.8.i386.RPM" it says I need libc.so.6, libpq.so.3, and php. It also says this on http://rpmfind.net/linux/RPM/fedora/updates/3/i386/php-pgsql-4.3.11-2.8.i386.html.

    But when I click on the "libc.so.6" link, it returns a lot of links. Which one should I choose? They all have libc.so.6 but I'm not sure how to choose among them. For example, both glibc-ptt-2.3.5-10.i686.html and glibc-2.4.90-3.i686.html seem suitable. And then there's also the question of should I choose glibc-2.4.90-3.i686.html or glibc-2.3.6-3.i686.html? How do I know which one would work with the version of php I have?
     
Loading...