1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Apache 2.2 Install

Discussion in 'Plesk for Linux - 8.x and Older' started by jakeh, Jun 29, 2006.

  1. jakeh

    jakeh Guest

    0
     
    Has anyone donoe this? The plesk FAQ says the apache version doesnt matter but then there are tons of dependency issues when you try and install the RPM?

    Any suggestions would be great.

    Thanks
    Jake
     
  2. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    I advise you to stick with your distribution's version of apache. I don't think there is a distribution with apache 2.2 yet that is supported by Plesk. What rpm were you trying to install? You can't just install FC5's apache 2.2 on an older version for instance. Do you really need apache 2.2?
     
  3. random52k

    random52k Guest

    0
     
    I'd also like to know how to upgrade to apache 2.2.

    I'm trying to get ruby on rails to run with mongrel and mod_proxy_balancer, but apache 2.2 is required. I've tried downloading the official apache 2.2 rpm from apache.org and installing it, but I get the following error:

    error: Failed dependencies:
    httpd-mmn = 20020903 is needed by (installed) mod_perl-1.99_16-4.i386
    httpd-mmn = 20020903 is needed by (installed) mod_ssl-2.0.52-22.ent.i386
    httpd-mmn = 20020903 is needed by (installed) php-4.3.9-3.12.i386
    httpd-mmn = 20020903 is needed by (installed) mod_python-3.1.3-5.1.i386
    httpd = 2.0.52-22.ent is needed by (installed) httpd-suexec-2.0.52-22.ent.i386
    httpd = 2.0.52-22.ent is needed by (installed) mod_ssl-2.0.52-22.ent.i386
    httpd = 2.0.52 is needed by (installed) httpd-devel-2.0.52-22.ent.i386

    Unfortunately, I can't remove any of these packages, since plesk depends on them, and I'm afraid of removing and readding plesk after upgrading apache, since I'm not sure if that will work..

    In the plesk faq, it states:

    "There should not be any problems if you update Apache because Plesk
    uses its own Apache for Control Panel and the Apache which serves users
    websites is a part of the operating system distributive and can be updated
    freely. After Apache RPM installation you have to replace default
    Apache /usr/sbin/suexec with the Plesk one"

    Although from what I've seen so far, it looks like plesk is tied into the version of apache that's installed, and it's rather difficult to separate them. I may just end up compiling apache from source, but then I'll have two copies of apache installed, and I wanted to avoid this.. I also wanted to still allow plesk to configure apache.

    If anyone has any advice, please let me know! Thanks,
     
  4. random52k

    random52k Guest

    0
     
    well, I gave up on plesk and installed apache 2.2 from source and all is working fine, although of course now I can't configure apache via plesk, but I guess that'll have to do until they come out with an update or someone figures out how to upgrade to apache 2.2.
     
  5. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    Plesk won't release an update. You'll have to wait for a distribution carrying apache 2.2 that's supported by Plesk (none that I know of currently).
     
Loading...