1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Apache User

Discussion in 'Plesk for Linux - 8.x and Older' started by buchibabu_ghen, Nov 7, 2005.

  1. buchibabu_ghen

    buchibabu_ghen Guest

    0
     
    Hi,

    We are using plesk 7.5.4. Under what user the httpd daemon should run plesk? my server is running as apache user.

    Regards,
    Buchibabu
     
  2. ShadowMan@

    ShadowMan@ Guest

    0
     
    Under most OS's it should be running as user 'apache' (at least the Redhat flavor distros)
     
  3. buchibabu_ghen

    buchibabu_ghen Guest

    0
     
    thanks.

    But when we create new site from the control panel it is not giving proper permissions to the httpdosc folder it seems. We are getting forbidden errors while opening the site from the browser.

    what is the ownership and permissions of the files and directories and its subdirectories situated under vhosts directory.

    Thanks in Advance,
    Buchibabu
     
  4. ShadowMan@

    ShadowMan@ Guest

    0
     
    The UID should be the same as the ftpuser you defined for the domain. The GID should be 'psacln' or 'psaserv' for some, root : root for others. Here is a 'ls -al' of a test domain I created:
    Code:
    # ls -al
    total 80
    drwxr-xr-x   20 root     root         4096 Aug 26 03:11 .
    drwxr-xr-x   12 root     root         4096 Oct 23 23:31 ..
    drwxr-x---    5 ftpuser psaserv      4096 Aug 26 03:11 anon_ftp
    drwxr-xr-x    2 root     root         4096 Aug 26 03:11 bin
    drwxr-x---    2 ftpuser psaserv      4096 Aug 26 03:11 cgi-bin
    drwxr-x---    2 root     psaserv      4096 Oct 19 14:43 conf
    drwxr-xr-x    2 root     psaserv      4096 Aug 26 03:11 error_docs
    drwxr-xr-x    2 root     root         4096 Aug 26 03:11 etc
    drwxr-x---    5 ftpuser psaserv      4096 Oct 16 20:20 httpdocs
    drwxr-x---    4 ftpuser psaserv      4096 Aug 26 03:11 httpsdocs
    drwxr-xr-x    2 root     root         4096 Aug 26 03:11 lib
    drwxr-x---    2 root     psaserv      4096 Aug 26 03:11 pd
    drwx------    2 ftpuser root         4096 Aug 26 03:11 private
    drwx------    2 root     root         4096 Aug 26 03:11 .ssh
    dr-xr-x---    8 root     psaserv      4096 Oct  9 20:33 statistics
    drwxr-xr-x    3 root     psaserv      4096 Aug 26 03:11 subdomains
    drwxrwxrwt    2 root     root         4096 Aug 26 03:11 tmp
    drwxr-xr-x    5 root     root         4096 Aug 26 03:11 usr
    drwxr-xr-x    3 root     root         4096 Aug 26 03:11 var
    drwxr-xr-x    2 root     psaserv      4096 Aug 26 03:11 web_users
    
    And the domain directory shows:
    
    drwxr-xr-x   20 root     root         4096 Aug 26 03:11 testexpire.com
    
    I am able to browse fine to this test domain from outside the test server (from Win2K PC) no forbidden errors.
     
  5. buchibabu_ghen

    buchibabu_ghen Guest

    0
     
    Thanks..

    The permissions are set same for me also when i create a new domain. The GID for htttpdcos is showing psaserv. For all the directories and subdirectores under httpdocs it is showing GID as psacln. is it correct or some thing wrong?

    --Buchibabu
     
  6. ShadowMan@

    ShadowMan@ Guest

    0
     
    Under the httpdocs, GID 'psacln' is correct. Have you uploaded an index.html file to the httpdocs? If you uploaded an index.htm then try renaming it to index.html

    The basic Plesk config for Apache does not put index.htm in the DirectoryIndex directive (httpd.conf), so until that is reconfigured, then you have to use .html file extensions.
     
  7. buchibabu_ghen

    buchibabu_ghen Guest

    0
     
    I think it is not the problem with the index file. When i run the following command, the default page is coming with out any problem.

    chmod 755 httpdocs -R

    --Buchibabu
     
  8. ShadowMan@

    ShadowMan@ Guest

    0
     
    Glad to hear your problem is fixed. The only thing I would worry about is setting all files to 755, should only need a minimum of 644 to be readable. Ah, but I guess the dirs would be 755....
     
Loading...