1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

ART/CentOS YUM strange errors:

Discussion in 'Plesk for Linux - 8.x and Older' started by admin0, Nov 3, 2005.

  1. admin0

    admin0 Guest

    0
     
    Hi,

    I have a CentOS 3.5 server with PSA 7.5.4 Reloaded. I am trying to update all packages via ART. yum update gives these errors:


    [root@core etc]# yum update
    Gathering header information file(s) from server(s)
    Server: Atomic Rocket Turtle - 3 - Atomic PSA-Compatible RPMS
    Server: Atomic Rocket Turtle - 3 - Atomic PSA App Vault RPMS
    Server: Atomic Rocket Turtle - 3 - Base OS RPMS mirror
    Server: Atomic Rocket Turtle - 3 - SW-Soft PSA 7.5 RPMS
    Server: Atomic Rocket Turtle - 3 - OS Update RPMS mirror
    Finding updated packages
    Downloading needed headers
    Resolving dependencies
    .Package psa-fileserver needs librpm-4.2.so, this is not available.
    Package psa-fileserver needs librpmdb-4.2.so, this is not available.
    Package psa-fileserver needs librpmio-4.2.so, this is not available.
    Package redhat-config-mouse needs /usr/bin/python2.2, this is not available.
    Package redhat-config-keyboard needs /usr/bin/python2.2, this is not available.
    Package redhat-config-language needs /usr/bin/python2.2, this is not available.
    Package redhat-config-kickstart needs /usr/bin/python2.2, this is not available.
    Package redhat-config-rootpassword needs /usr/bin/python2.2, this is not available.
    Package redhat-config-soundcard needs /usr/bin/python2.2, this is not available.
    Package redhat-config-nfs needs /usr/bin/python2.2, this is not available.
    Package redhat-config-users needs /usr/bin/python2.2, this is not available.
    Package redhat-config-date needs /usr/bin/python2.2, this is not available.
    Package rh-postgresql-server needs libcom_err.so.3, this is not available.
    Package wget needs libcom_err.so.3, this is not available.



    Any clues?


    Cheers,
    :D
     
  2. PhilM

    PhilM Guest

    0
     
    Actually I have the same problem on the same version of CentOS but with different dependencies. It looks like you really need python2. I had not used ART's (very well maintained by the way -thanks art) respository until I needed to get spam assassin updated. I ended up compiling spamassassin using MCPAN but I would like to use ART's repository. Part of the problem is that the packages need a newer version of glibc than is available on the main Centos sites.
    The newest version of glibc available on the centos sites is 2.3.2-95.33 but the packages in ART's repository need 2.3.4.
    My updates also fail with

    Package psa-selinux needs selinux-policy-strict-sources, this is not available.
    Package psa-selinux needs selinux-policy-targeted-sources, this is not available.
    Package psa-api-rpc needs psa-agent = 1.3.5-75050830.11, this is not available.
     
Loading...