1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

ASP Issues

Discussion in 'Plesk for Windows - 8.x and Older' started by networkthinking, Nov 16, 2005.

  1. networkthinking

    networkthinking Guest

    0
     
    Hello,
    We have a couple of ASP sites on a new Windows 2003 Server box with Plesk 7.5.4. These started crashing and we had to put the sites into application pools. Any reason we need to do this?

    Here is the error...
    Server Error in '/' Application.
    --------------------------------------------------------------------------------

    Server cannot access application directory 'D:\inetpub\vhosts\demosite.com\httpdocs\'. The directory does not exist or is not accessible because of security settings.
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Web.HttpException: Server cannot access application directory 'D:\inetpub\vhosts\2k5details.com\httpdocs\'. The directory does not exist or is not accessible because of security settings.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [HttpException (0x80004005): Server cannot access application directory 'D:\inetpub\vhosts\2k5details.com\httpdocs\'. The directory does not exist or is not accessible because of security settings.]
    System.Web.HttpRuntime.EnsureAccessToApplicationDirectory() +72
    System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +263

    [HttpException (0x80004005): ASP.NET Initialization Error]
    System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +964
    System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +128




    --------------------------------------------------------------------------------
    Version Information: Microsoft .NET Framework Version:1.1.4322.573; ASP.NET Version:1.1.4322.573
     
  2. jbuts

    jbuts Guest

    0
     
    It seems like the "Network service" user doesn't have permissions on "D:\inetpub\vhosts\demosite.com\httpdocs" folder. The ASP.NET process uses this account for working in system.
     
  3. networkthinking

    networkthinking Guest

    0
     
    The problem is that the site(s) were working fine (3 of them) and then they just went down with the error. The only to fix that I found was to put them in separate application pools. Not sure what this did or why.

    Any ideas?

    Thanks,
    Wally
     
Loading...