1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Auto installation problem on RHEL4

Discussion in 'Plesk for Linux - 8.x and Older' started by Adam1234, Mar 25, 2007.

  1. Adam1234

    Adam1234 Guest

    0
     
    Hi,

    Having problem during autinstallation process of plesk 8.1.0.

    - psa_installer_v3.1.0_build061201.02_os_RedHat_el4_i386
    - psa-8.1.0-rhel4.build81070224.19.i586.rpm.tar.gz

    Here is the following Linux environment before PLESK installation:

    Red Hat Enterprise Linux ES (v. 4 for 32-bit x86)
    PHP 5.1.6
    mysql Ver 14.12 Distrib 5.0.27

    Here is the following problem with MySQL in autoinstaller log file

    ===> Installing rbash
    Checking that /bin/rbash registered as login shell...
    /bin/rbash
    /bin/rbash is already registered as login shell

    /var/tmp/rpm-tmp.4939: line 11044: /etc/init.d/mysqld: No such file or directory
    Trying to start MySQL server... /var/tmp/rpm-tmp.4939: line 10890: /etc/init.d/mysqld: No such file or directory

    ERROR while trying to start MySQL server

    Aborting...

    STOP psa-8.1.0-rhel4.build81061129.22 installing AT Sun Mar 25 05:41:20 IST 2007
    ----------------------------------------------------------

    MySQL 5.0.27 is started and root password Null

    Auto installation is trying to start mysqld again from
    /etc/init.d/mysqld which in fact is running from
    /usr/sbin/mysqld

    Where I can force or do changes to point autoinstaller to right MySQL path - if this is the case ?

    Also during the installation I noticed some warnings:

    package MySQL-devel-standard-5.0.27-0.rhel4.i386 conflict with package mysql-4.1.20-1.RHEL4.1.i386
    packages conflict by files detected: package MySQL-devel-standard-5.0.27-0.rhel4.i386 conflict with package mysql-devel-4.1.20-1.RHEL4.1.i386
    package MySQL-server-standard-5.0.27-0.rhel4.i386 conflict with package mysql-4.1.20-1.RHEL4.1.i386
    package MySQL-server-standard-5.0.27-0.rhel4.i386 conflict with package mysql-server-4.1.20-1.RHEL4.1.i386
    packages conflict by files detected: package krb5-devel-1.3.4-33.i386 conflict with package krb5-server-1.3.4-27.i386
    packages conflict by files detected: package php-pear-1:1.4.9-1.2.centos.noarch conflict with package php-4.3.9-3.18.i386
    packages conflict by files detected: package MySQL-client-standard-5.0.27-0.rhel4.i386 conflict with package mysql-4.1.20-1.RHEL4.1.i386
    packages conflict by files detected: package python-2.3.4-14.3.i386 conflict with package python-devel-2.3.4-14.2.i386

    MySQL 5.0.27 and php 5.1.6 are not distrubuted via RHN channels so they were installed separately before Plesk installation.

    Did any of you come across with the same problem ?
     
  2. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    How were they installed? As you can see in the error message, Plesk looks for files like /etc/init.d/mysqld (to restart mysqld). My guess is that your MySQL (and PHP?) installs have files in different places than the standard locations. That will probably not play nice with Plesk.
     
  3. Adam1234

    Adam1234 Guest

    0
     
    I rebuilt rpm database and checked packages, some of the were installed some of them not. I will try to remove them.

    It looks like the only solution will be to setup PLESK on clean box and then do necessary updates like PHP or MySQL unless sb had the same problem and know how to sort this out.
     
Loading...