1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

autoinstaller plesk 8.1

Discussion in 'Plesk for Linux - 8.x and Older' started by josesanchez, Apr 23, 2007.

  1. josesanchez

    josesanchez Guest

    0
     
    I´m trying to install plesk 8.1 in a debian 3.1 and it´s the first time i do this.

    I´ve downloaded the autoinstaller from the plesk website and when I execute it there´s a problem when it try to get to http://autoinstall.plesk.com/debian/sitebuilder_3.0.1/dists/sarge/all/binary-i386/packages.gz it says forbidden.

    I´ve tried also install by the .deb packages but there´s a lot of problem of dependeces with the packages.
    If anyone can help me, it will by perfect.

    Excuse my english, I´m from spain.
     
  2. tglawe

    tglawe Guest

    0
     
    Check this Thread.

    Just a manual installation works until SWsoft will solve their problems.
     
  3. josesanchez

    josesanchez Guest

    0
     
    when did this probles start?

    What can i do?
     
  4. tglawe

    tglawe Guest

    0
     
    Download the tar.gz Debian Packages from there.

    Here you'll find the Release Notes for a manual Installation.
     
  5. josesanchez

    josesanchez Guest

    0
     
    I tried, but i had many problems with the packages dependences.

    I tried with dpkg -i . Is there any other way?
     
  6. tglawe

    tglawe Guest

    0
     
    Just for Info:

    The Autoinstaller Packages are still back online.
     
  7. tnats@

    tnats@ Guest

    0
     
    Ok, it works now, but I'm just trying to install Plesk8 inside my Debian VPS us this command: vzpkg install 142 plesk8. Any help on these apt errors? Thanks.

    The following packages have unmet dependencies:
    libapache2-mod-python: Depends: python-central (>= 0.5.8) but it is not going to be installed
    Depends: python (>= 2.4) but 2.3.5-2 is to be installed
    psa: Depends: libboost-filesystem1.32.0 but it is not installable
    Depends: libmysqlclient14 but it is not installable
    psa-courier-imap-add: Depends: libmysqlclient14 but it is not installable
    psa-migration-manager: Depends: libboost-filesystem1.32.0 but it is not installable
    Depends: libboost-program-options1.32.0 but it is not installable
    Depends: libboost-regex1.32.0 but it is not installable
    Depends: libmysqlclient14 but it is not installable
    psa-qmail: Depends: libmysqlclient14 but it is not installable
    psa-updates: Depends: psa-hotfix3 (= 8.1.1-debian3.1.build81070423.14) but it is not going to be installed
    E: Broken packages
    ERROR: package manager exited with 100 retcode
     
  8. alak

    alak Guest

    0
     
    I got rid of them, when i reinstalled my VPS, and then did a clean install for Plesk.
     
  9. josesanchez

    josesanchez Guest

    0
     
    I also have those problems of dependencies, and I tried to install plesk 8 just before installing debian on my VPS.

    I need help, thanks
     
  10. ariehallo

    ariehallo Guest

    0
     
    Hi, same problems over here. Debian 4.0 (Etch) has no installation candidates for: python2.3, libmysqlclient14 etc.

    Some packages depend on metapackage python, which is python2.4 by default on Etch, but some packages require python2.3. Both cannot be installed at the same time.

    I tried to install the packages manually, but got stuck after a couple of hours.
    Has anyone had any luck installing Plesk 8.1 on Debian 4.0?
     
  11. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
  12. josesanchez

    josesanchez Guest

    0
     
    And what about debian 3.1 ?

    I have those ploblem of dependencies. How can I resolv it?

    the autoinstaller works in other Linux like fedora 4 ?
     
  13. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    You said you tried to install Plesk just before installing Debian 3.1 on your server? I'm not sure how that would work...

    Do a clean minimal install of the OS of your choice (provided it's supported by Plesk of course) and get the autoinstaller for your OS at <http://www.swsoft.com/en/download/plesk8/> and that should take care of the Plesk installation. At least it always has for me on CentOS and Fedora.
     
  14. tglawe

    tglawe Guest

    0
     
    For a regular Debian Installation:

    Ensure, your "source.list" got the right configuration

    For example
    And use multiple "apt-get install" to configure several packages at same time and to force problems with package dependencies.

    For example
     
  15. josesanchez

    josesanchez Guest

    0
     
    you mean "apt-get -f install" , don´t you?

    so what i have to do is :

    execute de autoinstaller
    apt-get -f install
    repeat this until the installation sucess

    I will try
     
  16. tglawe

    tglawe Guest

    0
     
    IMHO: Don't use the force Installation.

    Just install several packages with only one "apt-get install" command.

    The apt installer got no problems with package dependencies if you install all packages with in a single step.

    You won't need -f.
     
  17. josesanchez

    josesanchez Guest

    0
     
    I´ve tried again doing apt-get install with some packeges that make dapendencies problems and I can continue from this point:


    the following packages have unmet dependencies:

    psa: Depends : libboost-filesystem1.32.0 but it is not installable
    depends : libmysqlclient14 but it is not installable

    psa-api : depends : python2.3 but it is not installable

    psa-courier-imap-add : depends : libmysqlclient14 but it is not installable

    psa-hotfix3 : depends : libmysqlclient14 but it is not installable

    psa-migration-manager : depends : libboost-filesystem1.32.0 but it is not installable
    deppnds : libboost-program-options1.32.0 but it is not installable
    depends : libboost-regex1.32.0 but it is not installable
    depends : libmysqlclient14 but it is not installable

    psa-mod-fcgid-configurator : depends : libfcgi0 but it is not installable

    psa-qmail : depends : libmysqlclient14 but it is not installable

    ERROR : Error while resolve packages by apt
    ERROR : installation failed


    I search with apt-cache search those packages and this is what I´ve found

    libmysqlclient14 -----> libmysqlclient15off
    libmysqlclient15-dev

    libboost-filesystem1.32.0 ---> libboost-filesystem1.33.1

    libbost-program-options1.32.0 --> libboost-program-option1.33.1
    libboost-program-option-dev

    libbost-regex1.32.0 ------> libboost-regex1.33.1
    libboost-regex-dev

    libfcgi0 -------> libfcgi0c2

    I installed the packages that have similar names but those dependencies problem continues.

    Have anyone the same problem? anyone got it?

    thank you
     
  18. danliker

    danliker Silver Pleskian Plesk Certified Professional

    33
    43%
    Joined:
    Feb 15, 2006
    Messages:
    575
    Likes Received:
    0
    Location:
    Switzerland
    please post the output of

    cat /etc/apt/sources.list
     
  19. josesanchez

    josesanchez Guest

    0
     
  20. danliker

    danliker Silver Pleskian Plesk Certified Professional

    33
    43%
    Joined:
    Feb 15, 2006
    Messages:
    575
    Likes Received:
    0
    Location:
    Switzerland
    ok, now i see, your problem is that you use debian 4.0 etch (stable) not debian 3.1 sarge.

    debian 4.0 etch is not supported for plesk ...
     
Loading...