1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Autowhitelist broken since update 8.1

Discussion in 'Plesk for Linux - 8.x and Older' started by mooiesite, Dec 3, 2006.

  1. mooiesite

    mooiesite Basic Pleskian

    24
    23%
    Joined:
    Jun 17, 2006
    Messages:
    66
    Likes Received:
    0
    here's some of my maillog:
    Code:
    Dec  3 13:16:35 mooi-01 qmail: 1165148195.581453 new msg 1920711
    Dec  3 13:16:35 mooi-01 qmail: 1165148195.581518 info msg 1920711: bytes 17031 from <sender@sender.com> qp 8734 uid 2020
    Dec  3 13:16:35 mooi-01 qmail: 1165148195.618764 starting delivery 61: msg 1920711 to local [email]12-info@domain.com[/email]
    Dec  3 13:16:35 mooi-01 qmail: 1165148195.618789 status: local 1/10 remote 0/20
    Dec  3 13:16:35 mooi-01 spamd[8270]: spamd: got connection over /tmp/spamd_full.sock
    Dec  3 13:16:35 mooi-01 spamd[8270]: spamd: using default config for info@: home/qmail/mailnames[COLOR=red]//[/COLOR]info/.spamassassin/user_prefs
    Dec  3 13:16:35 mooi-01 spamd[8270]: spamd: processing message <001c01c716dd$3bc70270$066500e4@LUKAS> for info@:110
    Dec  3 13:16:41 mooi-01 spamd[8270]: mkdir /home/qmail/mailnames[COLOR=red]//[/COLOR]info: Permission denied at /usr/lib/perl5/vendor_perl/5.8.5/Mail/SpamAssassin.pm line 1530
    Dec  3 13:16:41 mooi-01 spamd[8270]: locker: safe_lock: cannot create tmp lockfile /home/qmail/mailnames[COLOR=red]//[/COLOR]info/.spamassassin/auto-whitelist.lock.my_mailserver.com.8270 for /home/qmail/mailnames[COLOR=red]//[/COLOR]info/.spamassassin/auto-whitelist.lock: No such file or directory
    Dec  3 13:16:41 mooi-01 spamd[8270]: auto-whitelist: open of auto-whitelist file failed: locker: safe_lock: cannot create  tmp lockfile /home/qmail/mailnames[COLOR=red]//[/COLOR]info/.spamassassin/auto-whitelist.lock.my_mailserver.com.8270 for /home/qmail/mailnames[COLOR=red]//[/COLOR]info/.spamassassin/auto-whitelist.lock: No such file or directory
    Dec  3 13:16:41 mooi-01 spamd[8270]: spamd: identified spam (8.6/7.0) for info@:110 in 6.2 seconds, 17031 bytes.
    Dec  3 13:16:41 mooi-01 spamd[8270]: spamd: result: Y 8 - BAYES_99,EXTRA_MPART_TYPE,HTML_MESSAGE.......................
    Dec  3 13:16:42 mooi-01 spamd[8265]: prefork: child states: II
    Dec  3 13:16:42 mooi-01 qmail: 1165148202.121699 delivery 61: success: did_1+0+2/did_0+0+1/
    Dec  3 13:16:42 mooi-01 qmail: 1165148202.121854 status: local 0/10 remote 0/20
    Dec  3 13:16:42 mooi-01 qmail: 1165148202.121896 end msg 1920711
    
    As you can see, it is missing 'the domain' when trying to read the userprefs file.. it says /home/qmail/mailnames//info/.spamassassin.
    But it should be: /home/qmail/mailnames/domain.com/info/.spamassassin.

    Anyone knows how to fix this?
     
  2. mooiesite

    mooiesite Basic Pleskian

    24
    23%
    Joined:
    Jun 17, 2006
    Messages:
    66
    Likes Received:
    0
    it looks like new plesk doesn't create the correct .qmail files in each userdir from which it calls spamc...

    tried rebuilding qmail-files with
    mchk -v
    mchk --with-spam

    When i look at the psa-dbase, it looks like they changed some spamassassin tables, maybe mchk doesn't know how to use them!

    the .qmail files contains this:
    Code:
    | /usr/local/psa/bin/psa-spamc reject
    | true
    ./Maildir/
    
    it's missing the '-u' option for calling userprefs
    PLEASE FIX THIS ASAP!!!

    [edit]
    when running mchk, i see this in my processes:
    spammng <defunct> (looks like it's missing some arguments??)
    FIX THIS!
    [/edit]
     
  3. mooiesite

    mooiesite Basic Pleskian

    24
    23%
    Joined:
    Jun 17, 2006
    Messages:
    66
    Likes Received:
    0
    SWSoft fixed the issue! Thanks for the fast solution.

    The problem was i symlinked /var/qmail/mailnames to /home/qmail/mailnames. (/var had little space left and /home had enough, that's why we moved mailnames a few months ago, this was btw an idea from swsoft)

     
  4. panaman

    panaman Guest

    0
     
    I noticed that after the upgrade that I was getting a ton more spam.. i then looked at the header of a message and spamassassin was not checking the messages..

    so is the fix just to run the following?
    mchk -v
    mchk --with-spam
     
  5. Traged1

    Traged1 Guest

    0
     
    If you are using qmail-scanner and you get this error after upgrading then you forgot to run qmail-scanner-reconfigure
     
  6. albans

    albans Regular Pleskian

    26
     
    Joined:
    Nov 29, 2005
    Messages:
    173
    Likes Received:
    0
  7. jprovan

    jprovan Guest

    0
     
    I still have these errors. Is there a resolution. (I have no symlinks).

    The domain.com portion seems to be missing.

    Feb 4 09:49:17 serv01 spamd[7392]: spamd: got connection over /tmp/spamd_full.sock
    Feb 4 09:49:17 serv01 spamd[7392]: spamd: using default config for qscand: /var/qmail/mailnames///.spamassassin/user_prefs
    Feb 4 09:49:17 serv01 spamd[7392]: mkdir /var/qmail/mailnames///.spamassassin: Permission denied at /usr/lib/perl5/vendor_perl/5.8.6/Mail/SpamAssassin.pm line 1530
    Feb 4 09:49:17 serv01 spamd[7392]: spamd: checking message <779506c70702041205k2f9e4057l9ffd3bcaa0aa88cc@mail.gmail.com> for qscand:110
    Feb 4 09:49:19 serv01 spamd[7392]: mkdir /var/qmail/mailnames///.spamassassin: Permission denied at /usr/lib/perl5/vendor_perl/5.8.6/Mail/SpamAssassin.pm line 1530
    Feb 4 09:49:19 serv01 spamd[7392]: locker: safe_lock: cannot create tmp lockfile /var/qmail/mailnames///.spamassassin/auto-whitelist.lock.serv01.58thstdev.net.7392 for /var/qmail/mailnames///.spamassassin/auto-whitelist.lock: No such file or directory
    Feb 4 09:49:19 serv01 spamd[7392]: auto-whitelist: open of auto-whitelist file failed: locker: safe_lock: cannot create tmp lockfile /var/qmail/mailnames///.spamassassin/auto-whitelist.lock.serv01.58thstdev.net.7392 for /var/qmail/mailnames///.spamassassin/auto-whitelist.lock: No such file or directory
    Feb 4 09:49:19 serv01 spamd[7392]: bayes: locker: safe_lock: cannot create tmp lockfile /var/qmail/mailnames///.spamassassin/bayes.lock.serv01.58thstdev.net.7392 for /var/qmail/mailnames///.spamassassin/bayes.lock: No such file or directory
     
  8. tkalfaoglu

    tkalfaoglu Regular Pleskian

    30
    68%
    Joined:
    Oct 6, 2005
    Messages:
    290
    Likes Received:
    1
    refreshing reply from mchk

    After reading these and having lots of those "permission denied" with triple-backslashes, I tried the
    [root@panel psa]# /usr/local//psa/admin/sbin/mchk --spam-only
    command, only to be greeted (after about 15 minutes of runtime on a machine with LA 0.75):


    mchk: fork_execv_getouterr: pipe() failed
    System error 24: Too many open files
    mchk: fork_execv_getouterr: pipe() failed
    System error 24: Too many open files

    now what?
    or rather, now why?
    -t
     
Loading...