1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

awstats can't regenerate missing days

Discussion in 'Plesk for Windows - 8.x and Older' started by goyaweb, Sep 21, 2006.

  1. goyaweb

    goyaweb Guest

    0
     
    I'm missing 2 days in my stats of this months and want to regenerate all stats. Normally Plesk does this through a statistics.exe file but I don't know the command line commands for that so I used awstats.pl but have trouble getting it to work. This is what I get:

    Code:
    C:\Program Files\SWsoft\Plesk\Additional\Perl\bin>perl.exe D:\[url]\statistics\webstat\AWStats\cgi-bin\awstats.pl -config=[url] -LogFile="C:\Progr
    a~1\SWsoft\Plesk\Additional\AWStats\tools\logresolvemerge.pl D:\[url]\statistics\logs\W3SVC15133\ex*.log |"
    Update for config "D:\[url]\statistics\webstat\AWStats\cgi-bin/awstats.au
    totrust.nl.conf"
    With data in log file "C:\Progra~1\SWsoft\Plesk\Additional\AWStats\tools\logresolvemerge.pl D:\[url]\statistics\logs\W3SVC15133\ex*.log |"...
    Phase 1 : First bypass old records, searching new record...
    Direct access to last remembered record has fallen on another record.
    So searching new records from beginning of log file...
    AWStats did not find any valid log lines that match your LogFormat parameter, in
     the 50th first non commented lines read of your log.
    Your log file C:\Progra~1\SWsoft\Plesk\Additional\AWStats\tools\logresolvemerge.
    pl D:\[url]\statistics\logs\W3SVC15133\ex*.log | must have a bad format or LogFormat parameter setup does not match this format.
    Your AWStats LogFormat parameter is:
    date time s-sitename s-computername s-ip cs-method cs-uri-stem cs-uri-query s-po
    rt cs-username c-ip cs-version cs(User-Agent) cs(Cookie) cs(Referer) cs-host sc-status sc-substatus sc-win32-status sc-bytes cs-bytes time-taken
    This means each line in your web server log file need to have the following pers
    onalized log format:
    date time s-sitename s-computername s-ip cs-method cs-uri-stem cs-uri-query s-po
    rt cs-username c-ip cs-version cs(User-Agent) cs(Cookie) cs(Referer) cs-host sc-status sc-substatus sc-win32-status sc-bytes cs-bytes time-taken 
    And this is an example of records AWStats found in your log file (the record number 50 in your log):
    
    Setup ('D:\[url]\statistics\webstat\AWStats\cgi-bin/awstats.autotrust.nl.
    conf' file, web server or permissions) may be wrong.
    Check config file, permissions and AWStats documentation (in 'docs' directory).
    I don't see why the LogFormat could be wrong as the statistics that statistics.exe generates work correctly. Am I pointing to different LogFiles than Plesk uses or something?

    Also I can't change the config file for the awstats.pl file because newlines show up as squares which make it very hard to read...
     
  2. easwaran

    easwaran Guest

    0
     
    did you import the log files or are these log files that were created by the host that is managed by plesk?
     
Loading...