1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

AWStats & Forbidden Erros

Discussion in 'Plesk for Windows - 8.x and Older' started by itsecurityxprts, Nov 28, 2006.

  1. itsecurityxprts

    itsecurityxprts Guest

    0
     
    Hokey kokey,

    We've got an issue with our Plesk install....never been right from day one.....sounds like a common problem :-(

    I've got it installed and working, but the problem is when you open the plesk-stat directory, the stats display fine

    UNTIL....

    You decide you want the full list for referring Search Terms or anything else that requires Plesk to display a pop up with further information it.

    Then we get the good old 403 Forbidden error.

    Anyone else come across this, or fixed it ?

    Thanks
    Si
     
  2. ripdeath987

    ripdeath987 Guest

    0
     
    Hi,

    "you open the plesk-stat directory"

    On disk or browser?

    Also please make sure that you have perl enabled for the domain.
     
  3. itsecurityxprts

    itsecurityxprts Guest

    0
     
    Trying to open the stats from both the server and from a web browser.

    Perl is enabled for all of our domains, hence the stats work for the general stats page

    They don't work if you click on any of the links on the stats page for more information

    Cheers
    Si
     
  4. colinjack

    colinjack Guest

    0
     
    Hiya,

    Did you get a resolution for this? We have the same issue. I have looked at all the permissions etc. and it all looks fine!

    :(
     
  5. itsecurityxprts

    itsecurityxprts Guest

    0
     
    Hi all,

    Yes, I did find a solution, it's not the ideal solution, but it's as good as if you want the information just for yourself

    If you browse to the directory on the server that holds the stats, you can see that all the pages are created and you just need to open the pages created by double clicking on them.

    I raised this issue with Plesk Support and they weren't very helpful and just kept saying that they wouldn't help as I didn't have a support contract.

    I think that they should have fixed the problem as it never worked properly from the initial installation and this is a common problem, but apparently they only provide general stats, not the detailed stats that we want to see

    You could always remove the stats setup from plesk and install awstats on their own.

    Cheers
    Si
     
  6. colinjack

    colinjack Guest

    0
     
    Cheers ... the problem is that all our clients are complaining now ;(

    The SWSoft support is sometimes very poor!

    Thanks

    Colin
     
  7. colinjack

    colinjack Guest

    0
     
    Logically, the problem is that the scriipt that handles this stuff doesn't have the correct permissions. When I login into the stats I get a page with the summary on but if I try and view anything else (like the previous month's stats) then I get a 401.

    Hellooo SWSoft moderators. What is happening here?
     
  8. DanSolo

    DanSolo Guest

    0
     
    Hey,

    We're getting a similar problem. We can also view the files via explorer directly, but that sort of defeats the purpose of having them Web enabled! Our Web clients can't see them, we get the infamous 404 not found error.

    I'm pretty sure this has something to do with permissions. We've been having permission problems since the very begining.

    We can't even set permissions via Plesk ... it says I don't have sufficient permissions to do that !!! (i'm logged in as admin!)

    We tried the reset Plesk security tool but that just messed EVERYTHING up EVERYWHERE ...

    Any hints are wecome here !

    Thanks,
     
  9. colinjack

    colinjack Guest

    0
     
    Don't run the reconf***erator ... that will really mess it up!

    I found that the permissions for psacln on inetpub/vhosts were all messed up (set to deny!). Also for psaadm on the program files/swsoft folders.

    Goodness know why SWSoft don't fix this or provide a patch. Everybody has problems with Plesk breaking permissions but not a word from SWSoft support guys on these forums.

    Good luck.
     
Loading...