1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

AWStats: previous month stats access

Discussion in 'Plesk for Windows - 8.x and Older' started by twistoo, May 18, 2006.

  1. twistoo

    twistoo Guest

    0
     
    I am runing Plesk 7.5.6 on Windows 2003. When I go into AWStats reports, I get the current month report fine. But when I choose another month, I get a 404 error on the address http://www.DOMAINNAME/ plesk-stat/webstat/ AWStats/cgi-bin/ awstats.pl?month=05&year=2006& output=main&config=DOMAINENAME
    even if the path to awstats.pl is good. BTW, Perl is enabled in the config of the domain. I tried to enable CGI, but it did'nt change anything.

    Security problem?

    Anyone?
     
  2. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    You should enable Perl support for this domain
     
  3. twistoo

    twistoo Guest

    0
     
    As I said, Perl is enabled.
     
  4. twistoo

    twistoo Guest

    0
     
    Oups. Perl was enabled in the CP, but not in IIS / Web Service Extensions (if this can help someone)
     
  5. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Are you enable Perl as Web Service Extension? Is it working now?
     
  6. twistoo

    twistoo Guest

    0
     
    Yes it does work now. Seems like Plesk is unable to configure this IIS 6 setting.
     
  7. gedsta

    gedsta Guest

    0
     
    without sounding like a total noob

    how would i configure IIS6 to work with perl as i am having the exact same probles

    tia
     
  8. twistoo

    twistoo Guest

    0
     
    You need access to the server console in windows 2003. If you do, click on the Run... button in the start menu, enter %SystemRoot%\system32\inetsrv\iis.msc. From there, expand the tree on the left, click on Web Service Extensions, select Perl Extension and click Allow.

    Hope this helps.
     
  9. gedsta

    gedsta Guest

    0
     
    hi thx for your reply

    however i have tried that and in desperation deleted the values that were there

    can u poss tell me what value sohuld be in the file bit on the required files entry?

    there is only one at the monent and that is

    c:\Program Files\SWsoft\Plesk\Additional\Perl\bin\PerlIS.dll
     
  10. twistoo

    twistoo Guest

    0
     
    You also need: C:\Program Files\SWsoft\Plesk\Additional\Perl\bin\perl.exe "%s" %s
     
  11. gedsta

    gedsta Guest

    0
     
    I love u man!

    C:\Program Files\SWsoft\Plesk\Additional\Perl\bin\perl.exe "%s" %s

    did the trick

    just ran tester.pl

    and it reports

    MAY be a problem: perl not found on server PATH

    i am trying to install x-cart ecommerce software and it need the path to perl

    on the tester.pl it reports

    C:\PROGRA~1\SWsoft\Plesk\ADDITI~1\Perl\bin\;
    C:\PROGRA~1\SWsoft\Plesk\ADDITI~1\Perl\bin;

    which one would i tell it to use?

    and how would i enter it?

    ie
    C:\PROGRA~1\SWsoft\Plesk\ADDITI~1\Perl\bin\; or
    C:\PROGRA~1\SWsoft\Plesk\ADDITI~1\Perl\bin\ or
    'C:\PROGRA~1\SWsoft\Plesk\ADDITI~1\Perl\bin\;' or
    C:\PROGRA~1\SWsoft\Plesk\ADDITI~1\Perl\bin\perl.exe?

    thank you so far for your help

    Ged
     
  12. twistoo

    twistoo Guest

    0
     
    Sorry, can't help you there.
     
Loading...