1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

backup error

Discussion in 'Sitebuilder 4.0 for Linux' started by SilviaAmoros, Dec 27, 2007.

  1. SilviaAmoros

    SilviaAmoros Guest

    0
     
    Hello,

    I am trying to make a backup of Sitebuiler and gives me the following error. I have since tried panel administrator and from command line. What can I do?

    Thanks
     

    Attached Files:

  2. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    Try to increase 'memory_limit' value in php.ini file. By default Sitebuilder uses it's own PHP installation and php.ini file for it located here: /opt/php52/etc/php.ini.
    To make sure that appropriate php.ini will be used you can run following commands:

    # sb_config --help|grep php
    --phpcli_path PHP CLI executable [/opt/php52/bin/php5]
    --phpcgi_path PHP CGI executable [/opt/php52/cgi-bin/php5]

    # /opt/php52/bin/php5 -i|grep php.ini
    Configuration File (php.ini) Path => /opt/php52/etc/php.ini

    Try to increase value from 32M to, for example, 256M and try backup procedure one more time. It should help.
     
  3. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    sorry, correct path to php.ini file is /usr/local/sitebuilder/etc/php.ini. You can re-check correct path for php.ini file by running phpinfo.php file from Sitebuilder htdocs folder. For this, put phpinfo.php into /<sb_root>/htdocs/:
    <?php
    phpinfo();
    ?>

    and run it in browser like: http://sitebuilderhostname/phpinfo.php. There you could see following parameter: Configuration File (php.ini) Path /usr/local/sitebuilder/etc/php.ini
     
  4. ThomasKrueger

    ThomasKrueger Guest

    0
     
    I have the same problem with the backup.
    I tried to increase the memory limit to 256M, but i get a similar error message.

    Error message now:
    PHP Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 240 bytes) in /usr/local/sitebuilder/include/Zend/Zend/Db/Adapter/Abstract.php on line 156

    Before:
    PHP Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 48 bytes) in /usr/local/sitebuilder/include/Zend/Zend/Db/Adapter/Abstract.p hp on line 156

    Thanks for your help!
     
  5. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
    Which version of Sitebuilder do you have? If this is 4.0 I can suggest you to make an upgrade to 4.1 as in latest 4.1 release there were corrected some issue related to backup/restore functionality. It should help.
     
  6. ThomasKrueger

    ThomasKrueger Guest

    0
     
    I have version 4.1 installed. With version 4.0 I have not tried to make a backup.
     
  7. Dmitry Frantsev

    Dmitry Frantsev Golden Pleskian

    28
    57%
    Joined:
    Sep 19, 2005
    Messages:
    1,911
    Likes Received:
    0
  8. ThomasKrueger

    ThomasKrueger Guest

    0
     
Loading...