1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Big Problem: redirect to other mailbox

Discussion in 'Plesk for Linux - 8.x and Older' started by manarak, Nov 24, 2005.

  1. manarak

    manarak Guest

    0
     
    I tried to redirect mail from one mailbox A on my server to another mailbox B on a different domain on the same server.

    The result:
    No mail gets in mailbox A
    No mail gets in mailbox B

    Where is the mail?
    What should I do to get the redirect working?
     
  2. ShadowMan@

    ShadowMan@ Guest

    0
     
    1. Other than the redirect problem, are both email accounts working to send/rcv to external (yahoo, gmail, hotmail, etc) mail servers?

    2. When you specified the redirect addresses, you did specify the entire email address, not just the mail username, right? userB@otherdomain.com instead of just userB
     
  3. Whistler

    Whistler Guest

    0
     
    This might actually be related to a bug I found in Plesk a couple of days ago - check your maillog - Plesk seems to write the .qmail file wrong when redirection and "Delete spam" is enabled.

    Your maillog should write something about spamc being passed a wrong parameter.

    I have not had any time to investigate this yet, but please write if you can confirm my suspicion. Write your OS, version and Plesk build.
     
  4. manarak

    manarak Guest

    0
     
    Very strange - there are log entries for removed viruses (by clamd - for the exact mailbox that was to be redirected), but no mails reached either mailbox.

    I deactivated the redirect, and now everything seems normal.

    There were no errors in the maillog.

    I use Plesk 7.5.4 with Fedora Core 2


    Shadowman: yes and yes
     
  5. Paris@

    Paris@ Guest

    0
     
    I just started getting into dedicated servers and this problem has been bugging me forever. Im also using 7.5.4 on Fedora Core 2 and im having problems with redirects.

    If i setup an account with a mail box, it can be accessed, sent to, and sent out with and works perfectly. But if you set it up as a redirect nothing happens. You dont get a bounce back error nor does the email actually redirect to the email u set it to.

    I disabled the spam assassin service but that didn't seem to help much, and i would assume its and issue with qmail.

    Where can i find the qmail logs at? Somethin I should look for? Maybe I have the same problem as manarak
     
  6. ShadowMan@

    ShadowMan@ Guest

    0
     
    manarak - please post the .qmail file contents for both users.

    Paris - the mail logs are found at:

    /usr/local/psa/var/log/maillog
    /usr/local/psa/var/log/maillog.processed
     
  7. Paris@

    Paris@ Guest

    0
     
    im getting

    failure: Sorry._Although_I'm_listed_as_a_best-preference_MX_or_A_for_that_host,/it_isn't_in_my_control/locals_file,_so_I_don't_treat_it_as_local._
     
  8. ShadowMan@

    ShadowMan@ Guest

    0
     
    Paris - Usually that means that the domain is not listed in the /var/qmail/control/rcpthosts file, and possibly the /var/qmail/control/virtualdomains file.
     
  9. Paris@

    Paris@ Guest

    0
     
    it only has the main domains, and not like

    mail.domain.com

    should i added mail.domain.com to the list also? thats what the domains are pointing to
     
  10. ShadowMan@

    ShadowMan@ Guest

    0
     
    If the domains are created in a 'standard' fashion, then that should not be necessary, but without knowing more about your exact setup and what you did when creating domains and DNS entries, I can only 'imagine'.

    For now, go ahead and add mail.domain.com into the 'rcpthosts' file.

    Then in the 'virtualdomains' file, you will have to find the existing 'domain.com' and see what prefix number it has, then use the same number when adding the 'mail.domain.com'

    Example: If the 'domain.com' shows as:
    domain.com:14

    Then add:
    mail.domain.com:14

    After making these edits, save them and restart the Qmail process/service.

    If this does not solve your problem, you will have to post much more detail about your server, and exactly what you did when setting up the domain(s) since it appears that you may have done something not quite standard.

    Also please clarify what you mean by "thats what the domains are pointing to"
     
  11. Paris@

    Paris@ Guest

    0
     
    didn't seem to do anything..

    i meant domains mail server are point to like mail.domain.com..

    basicly i've just added the domain through plesk and it created all the dns's for me..

    i dunno how much I could explain on how everything was setup because it was "installed" on my server for me, perhaps u can take a look at it through ssh?
     
  12. manarak

    manarak Guest

    0
     
    both .qmail files are identical

    | true
    ./Maildir/

    when I activate redirection, box A .qmail reads:

    | true
    ./Maildir/
    &email of box B
     
  13. manarak

    manarak Guest

    0
     
    DOH

    now it works ???
    very very strange!

    so it seems my problem is solved.
    Anyone having this problem should try deactivating and reactivating the redirect several times.
     
  14. ShadowMan@

    ShadowMan@ Guest

    0
     
    manarak - glad yours is working now.

    Paris - please first check the mail user's .qmail file as manarak did, try disabling and then enabling the redirect several times to see if it is the same problem.

    If the problem persists, then I will have my boss contact you, while I am on the clock I cannot perform 'work' not authorized by him (jamesyeeoc).
     
  15. Paris@

    Paris@ Guest

    0
     
    where are the qmail files located?
     
  16. rvdmeer

    rvdmeer Guest

    0
     
    In the mailname home directory of that user.
    Example: /var/qmail/mailnames/domain.ltd/username/.qmail
     
  17. Paris@

    Paris@ Guest

    0
     
    | true
    &name@domain.com

    thats what it shows in the qmail..
     
  18. jamesyeeoc

    jamesyeeoc Guest

    0
     
    For mail messages to go into the recipient's mailbox as well as be redirected it should look like:

    | true
    ./Maildir/
    &name@domain.com
     
  19. Paris@

    Paris@ Guest

    0
     
    well i just want it to redirect, but its not redirecting at all, nor bouncing back..
     
  20. Knightofoldcode

    Knightofoldcode Guest

    0
     
    I have noticed the precise same problem. It appears that for some reason, the domain affected was disabled, then renenabled at some point. When this happened, Plesk removed the information from qmail, contained within the rcpthosts file. When it was later reenabled, plesk put back that information, however Plesk forgot to restart the service! When I manually restarted the qmail service, everything went back to normal! Mail redirects work, and my error's of "Sorry. Although I'm listed as a best-preference MX or A for that host,
    it isn't in my control/locals file, so I don't treat it as local. (#5.4.6)" has been fixed!

    Try restarting your qmail service if this occurs again.

    Knight.
     
Loading...