1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

BIND failed after update...will not run

Discussion in 'Plesk for Linux - 8.x and Older' started by jeffparis, Jul 24, 2006.

  1. jeffparis

    jeffparis Guest

    0
     
    Bind failed after upgrade to 8.0, cannot restart.

    I see this in Plesk when I restart BIND:


    ERROR: PleskFatalException


    Unable to make action: Unable to manage service by dnsmng: dnsmng: Service named failed to start

    --------------------------------------------------------------------------------

    0: /usr/local/psa/admin/plib/common_func.php3:174
    psaerror(string 'Unable to make action: Unable to manage service by dnsmng: dnsmng: Service named failed to start')
    1: /usr/local/psa/admin/htdocs/server/restart_services.php:30




    after update, plesk removed all installed domains from named.conf. I tried replacing, what did I do wrong?



    ------BEGIN-----



    // $Id: named.conf,v 1.1.1.1 2001/10/15 07:44:36 kap Exp $

    options {
    allow-recursion {
    localnets;
    };
    directory "/var";
    auth-nxdomain no;
    pid-file "/var/run/named/named.pid";
    };

    //Use with the following in named.conf, adjusting the allow list as needed:

    key "rndc-key" {
    algorithm hmac-md5;
    secret "CeMgS23y0oWE20nyv0x40Q==";
    };

    controls {
    inet 127.0.0.1 port 953
    allow { 127.0.0.1; } keys { "rndc-key"; };
    };

    // Setting up secondaries is way easier and the rough picture for this
    // is explained below.
    //
    // If you enable a local name server, don't forget to enter 127.0.0.1
    // into your /etc/resolv.conf so this server will be queried first.
    // Also, make sure to enable it in /etc/rc.conf.




    /*
    zone "domain.com" {
    type slave;
    file "s/domain.com.bak";
    masters {
    192.168.1.1;
    };
    };

    zone "0.168.192.in-addr.arpa" {
    type slave;
    file "s/0.168.192.in-addr.arpa.bak";
    masters {
    192.168.1.1;
    };
    };
    */

    zone "." {
    type hint;
    file "named.root";
    };

    zone "campingmemberships.com" {
    type master;
    file "campingmemberships.com";
    allow-transfer {
    66.90.73.197;
    common-allow-transfer;
    };
    };
    zone "fivestarcampground.com" {
    type master;
    file "fivestarcampground.com";
    allow-transfer {
    66.90.73.197;
    common-allow-transfer;
    };
    };
    zone "membercampgrounds.com" {
    type master;
    file "membercampgrounds.com";
    allow-transfer {
    66.90.73.197;
    common-allow-transfer;
    };
    };
    zone "netcheeze.com" {
    type master;
    file "netcheeze.com";
    allow-transfer {
    66.90.73.197;
    common-allow-transfer;
    };
    };
    zone "oneshuffle.net" {
    type master;
    file "oneshuffle.net";
    allow-transfer {
    66.90.73.197;
    common-allow-transfer;
    };
    };
    zone "yblegal.com" {
    type master;
    file "yblegal.com";
    allow-transfer {
    66.90.73.197;
    common-allow-transfer;
    };
    };





    -----------END --------------
     
  2. jeffparis

    jeffparis Guest

    0
     
    Hows about some support here, please?
     
  3. Who-m3

    Who-m3 Guest

    0
     
    Try again, this time, when it fails, tail /var/log/messages, and show us what it gives referencing "named" and/or named.conf.
     
  4. DCNet_James

    DCNet_James Guest

    0
     
    Check and make sure the RNDC key in your named.conf and rndc.conf match. Again, as stated above, dump the named errors from your /var/log/messages file.

    Also did you restore your named.conf over the blank one?

    Thx
    James
     
Loading...