1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Bug: Registering a new domain as existing customer

Discussion in 'Plesk Automation' started by GregorL, Oct 29, 2011.

Thread Status:
Not open for further replies.
  1. GregorL

    GregorL Basic Pleskian

    16
    60%
    Joined:
    Oct 24, 2011
    Messages:
    61
    Likes Received:
    0
    Settings:
    ------------
    OpenSRS in test mode.

    Reproduce:
    ---------------
    Login as enduser.
    Account Tab
    "Add Subscription"
    Click "Buy Now" Button under Domains section.
    Enter Domain under "Register a domain name"
    Checkmark the .com for example.
    Click Checkout
    Click Next
    Click Next
    "Agree to terms and conditions"
    Check Payment.
    Click confirm order.

    The process takes 6 minutes in my tests.
     
  2. Blake@Parallels

    Blake@Parallels Regular Pleskian

    24
    73%
    Joined:
    Jul 28, 2008
    Messages:
    168
    Likes Received:
    0
    Location:
    Seattle, WA
    Hi Gregor,

    Is the bug that it takes 6 minutes? The billing system has an events queue that kicks off every 5 minutes to run all billing related tasks (generating invoices, processing payments, provisioning orders, etc) - this probably accounts for your observed 6 minutes total time since submitting the order. Is 6 minutes too long?
     
  3. GregorL

    GregorL Basic Pleskian

    16
    60%
    Joined:
    Oct 24, 2011
    Messages:
    61
    Likes Received:
    0
    The problem is, the browser actually hangs for 6 minutes waiting for the system.
    The little ajax spinning circle is spinning during that time.
     
  4. Blake@Parallels

    Blake@Parallels Regular Pleskian

    24
    73%
    Joined:
    Jul 28, 2008
    Messages:
    168
    Likes Received:
    0
    Location:
    Seattle, WA
    Ah, so this happened immediately after confirming the checkout? In this case, the problem would be in a different area of the system (system processing queue previously discussed would not come into play here).

    What payment method did you choose during checkout? If something other than Invoice/Check, how are your payment gateways configured?
     
  5. GregorL

    GregorL Basic Pleskian

    16
    60%
    Joined:
    Oct 24, 2011
    Messages:
    61
    Likes Received:
    0
    Yes, it happens immediately after clicking "confirm order".
    I chose Check Payment, so there should be no delay in connection with a payment gateway.
     
  6. Andrew Andriatis

    Andrew Andriatis Regular Pleskian Plesk Team

    23
    57%
    Joined:
    Apr 16, 2009
    Messages:
    431
    Likes Received:
    1
    Thanks. We reproduced the problem. Will be fixed.
     
Thread Status:
Not open for further replies.
Loading...