1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Cannot Update 7.5.3 to 7.5.4

Discussion in 'Plesk for Linux - 8.x and Older' started by matteveryday, Nov 9, 2005.

  1. matteveryday

    matteveryday Guest

    0
     
    I've been trying to update to plesk 7.5.4 from 7.5.3 and keep having problems. I'm using the online control panel to update the software. I can start the update for the base package of 7.5.4, but it doesn't seem to finish. I checked the autoinstaller.log and found this error. I'm not sure what to do.



    Preparing for packages installation...
    ----- begin of output -----
    Installing /PSA_7.5.4/rpm_FedoraCore_2/base/Mambo-4.5.2-7505.noarch.rpm
    Installing /PSA_7.5.4/rpm_FedoraCore_2/base/psa-7.5.4-fc2.build75050824.12.i586.rpm
    Installing /PSA_7.5.4/rpm_FedoraCore_2/base/psa-hotfix-7.5.4-fc2.build75050926.17.i586.rpm
    Installing /PSA_7.5.4/rpm_FedoraCore_2/base/psa-hotfix2-7.5.4-fc2.build75051014.16.i586.rpm
    Installing /PSA_7.5.4/rpm_FedoraCore_2/base/psa-courier-imap-add-7.5.4-fc2.build75050902.17.i586.rpm
    Installing /PSA_7.5.4/rpm_FedoraCore_2/base/courier-imap-3.0.8-fc2.build75050824.12.i586.rpm
    Installing /PSA_7.5.4/rpm_FedoraCore_2/base/psa-api-common-7.5.4-fc2.build75051014.16.noarch.rpm
    Installing /PSA_7.5.4/rpm_FedoraCore_2/base/psa-api-cli-7.5.4-fc2.build75051014.16.noarch.rpm
    Installing /PSA_7.5.4/rpm_FedoraCore_2/opt/api/psa-api-rpc-7.5.4-fc2.build75050930.11.noarch.rpm
    Installing /PSA_7.5.4/rpm_FedoraCore_2/opt/api/psa-agent-1.3.5-75050930.11.noarch.rpm
    Installing /PSA_7.5.4/rpm_FedoraCore_2/base/psa-key-7.5-fc2.build75050824.12.noarch.rpm
    Installing /PSA_7.5.4/rpm_FedoraCore_2/base/psa-locale-base-en-US-7.5.4-fc2.build75050824.12.noarch.rpm
    Installing /PSA_7.5.4/rpm_FedoraCore_2/opt/bu/psa-bu-7.5.4-fc2.build75050926.17.i586.rpm
    Installing /PSA_7.5.4/rpm_FedoraCore_2/opt/docs/psa-manual-custom-skin-guide-7.5.4-fc2.build75050824.12.noarch.rpm
    error: Failed dependencies:
    perl(Mail::SpamAssassin) is needed by (installed) psa-spamassassin-7.5.4-fc2.build75050927.15
    perl(Mail::SpamAssassin::ArchiveIterator) is needed by (installed) psa-spamassassin-7.5.4-fc2.build75050927.15
    perl(Mail::SpamAssassin::Message) is needed by (installed) psa-spamassassin-7.5.4-fc2.build75050927.15
    perl(Mail::SpamAssassin::perMsgLearner) is needed by (installed) psa-spamassassin-7.5.4-fc2.build75050927.15
    spamassassin >= 2.60 is needed by (installed) psa-spamassassin-7.5.4-fc2.build75050927.15

    ----- end of output -----
     
  2. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
  3. matteveryday

    matteveryday Guest

    0
     
    But when I look in "Information on Plesk Components", it says I'm already running spamassasin 3.0.3-1.rhfc2.art
     
  4. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    Oops, sorry, I misread your post. Do this then try again.

    rpm -e psa-spamassassin
     
  5. matteveryday

    matteveryday Guest

    0
     
    I tried that and it gave me this error

    error: psa-spamassassin not installed
     
  6. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
  7. matteveryday

    matteveryday Guest

    0
     
    I did the following command, as you suggested above, and it worked this time. I then tried to upgrade from 7.5.3 to 7.5.4 (the base packages). Now I can't access the plesk control panel and I can't ftp my server. I'm not sure what to do now.

    rpm -e psa-spamassassin
     
  8. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    What errors are you getting?

    You may have to restart psa and/or mysql. On one server I had to do a reboot.
     
  9. matteveryday

    matteveryday Guest

    0
     
    Which error log should I look at?

    I can't access the online plesk control panel.
     
  10. matteveryday

    matteveryday Guest

    0
     
    I tried rebooting the server, but still can't get to the control panel.
     
  11. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    Are all other services working? Web server, email, etc?

    Take a look at /var/log/messages and the autoinstaller log for starters.
     
  12. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
  13. matteveryday

    matteveryday Guest

    0
     
    Yep everything seems to be working. The websites are fully fuctional and emails are working.

    I followed that thread and found this on my server. What exactly does this mean? Do I have two versions of plesk trying to run at the same time?

    [root@www root]# rpm -qa psa
    psa-7.5.3-fc2.build75050506.13
    psa-7.5.4-fc2.build75050824.12
     
  14. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    Exactly, that's what that post was aimed at. You need to apply the mysql fix that CiViX andCranky discuss in the thread I added the link to.
     
  15. matteveryday

    matteveryday Guest

    0
     
    Should I remove Tomcat4?
     
  16. matteveryday

    matteveryday Guest

    0
     
    I followed the steps in that thread (without removing tomcat4 because someone mentioned it might cause problems).

    I was able to uninstall the failed 7.5.4 upgrade.

    But when I forced the 7.5.4 upgrade again, I ended up getting this error:

    ===> Installing psa database
    Trying to check psa database... Trying to find psa database...

    ERROR while trying to mysql datadir not found
    Check the error reason(see log file: /tmp/psa_7.5.4_FedoraCore_2_build75050824.1 2_upgrade.log), fix and try again

    Aborting...

    error: %post(psa-7.5.4-fc2.build75050824.12) scriptlet failed, exit status 1
     
  17. matteveryday

    matteveryday Guest

    0
     
    In the log file I found this:


    ===> Installing rbash
    Checking that /bin/rbash registered as login shell...
    /bin/rbash
    /bin/rbash is already registered as login shell

    ===> Installing psa database
    Trying to check psa database... Trying to find psa database...

    ERROR while trying to mysql datadir not found

    Aborting...
     
Loading...