1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Can't connect to localhost:25

Discussion in 'Plesk for Linux - 8.x and Older' started by phoenixisp, Sep 2, 2005.

  1. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    OK, I really screwed the pooch somehow. Since upgrading to 7.5.4 on a RH 9 box, and updating Spamassassin, a lot of spam was getting through that wasn't prior to the updates. So - I started playing with rule sets, etc. I wound up uninstalling SA and ART's qmail-scanner, but now - even without them I can't connect to port 25. I've tried telnet, no good. I tried webmail and Outlook - no good.

    Where did I mess up? I tried the maillog, even tailed it, but there's no errors because no connection is being made. Also, I disabled the firewall.

    Help please!

    Thanks,

    Sonny
     
  2. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    Here's another little problem, it must be related. I figured maybe the database was affected, so I did:

    /usr/local/psa/admin/sbin/mchk -v

    And came up with:


    [root@host1 queue]# /usr/local/psa/admin/sbin/mchk -v
    mchk: db_connect: failed to connect to database: Error: Too many connections
    mchk: db_connect: failed to connect to database: Error: Too many connections
    mchk: Unable to connect to the Plesk database
    mchk: Unable to connect to the Plesk database

    And of course I stopped mysql and started it again - no good! I can though read the database using phpMyAdmin.

    Argghh!!!!!!!!!!!!!!!!!!!!
     
  3. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    here's what happens when I try to send from Horde:

    Warning: fsockopen(): unable to connect to 127.0.0.1:25 in /usr/share/psa-horde/pear/Net/Socket.php on line 108
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Check the contents of:

    /etc/hosts
    /etc/resolv.conf

    /var/qmail/control/me
    /var/qmail/control/locals
    /var/qmail/control/localiphost
    /var/qmail/control/helohost

    Make sure your domain's DNS is still resolving properly.

    See if anything is listening on port 25:

    netstat -an |grep ':25'

    And if qmail is running in memory:

    ps -ax |grep 'qmail'
     
  5. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    Thanks jamesyeeoc, but I just found the problem.
    Some how, the line that begins with -Rt0 .... in smtp_psa had a line break in it. Tightened it up and most of my problems went away.

    Still getting the error when trying to do mchk. Resetting these mailboxes individually would be a real waste of the weekend:cool:
     
  6. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Yes, random line breaks in that file do cause havoc, sorry I didn't think of that.

    Surprisingly, I have posted about that in my replies so often, I guess it finally slipped a brain cell :)
     
  7. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    That's the drag, I should know better. But I just don't know how it happened. I haven't edited that file lately.
     
  8. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Yes, with 7.5.4 there seems to be a lot of weirdness going on...
     
  9. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    How about this database thing

    [root@host1 queue]# /usr/local/psa/admin/sbin/mchk -v
    mchk: db_connect: failed to connect to database: Error: Too many connections
    mchk: db_connect: failed to connect to database: Error: Too many connections
    mchk: Unable to connect to the Plesk database
    mchk: Unable to connect to the Plesk database

    I sure don't feel like spending the holiday weekend setting up email account settings.
     
  10. jamesyeeoc

    jamesyeeoc Guest

    0
     
    There was an old post in 6.0 where the poster had to
    Also was you mysql updated recently, like when you were doing the SA and qmail-scanner?
     
  11. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    I saw another thread similar to that one, but it had the wrong syntax and I kept getting sock errors. I did this one and it worked!

    Only once I ran it there was no effect. All of the user's spamassassin settings were lost. I won't know what else until the phone starts ringing.

    Thanks Mr. jamesyeeoc
     
  12. Jamai2

    Jamai2 Guest

    0
     
    Sorry to bring up such an old thread, but when I run :
    /usr/local/psa/admin/sbin/mchk -v

    I get : Segmentation fault :(
     
  13. jamesyeeoc

    jamesyeeoc Guest

    0
     
    You are probably running Plesk 7.5.4 with at least the 2nd update. This is a known problem covered in at least one or two other threads. IIRC there still has been no fix or replacement mchk utility from Plesk.

    If you happen to have an old backup from before (like maybe the first release of 7.5.4) you could try restoring that one and trying it, I don't know if anyone else has tried it.
     
Loading...