1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

can't enable dedicated IIS Application Pool for specific web site

Discussion in 'Plesk for Windows - 8.x and Older' started by igoldman, Dec 23, 2005.

  1. igoldman

    igoldman Regular Pleskian

    26
    23%
    Joined:
    Sep 14, 2004
    Messages:
    212
    Likes Received:
    0
    Hello to all member in this forum.

    I have a specific web site which I would like it be use dedicated IIS Application Pool

    I try to enable it through Plesk CP but after clicking on Enable button which located under IIS Application Pool screen then nothing is happen and the status it still disable.
    also I have checked the box (to be enable) under setup which define that this web site can use dedicated IIS application pool.

    what to do ?
     
  2. swarm

    swarm Guest

    0
     
    It seems you should try to perform this actions in another order. First of all you need mark checkbox in domain hosting setup. Then you can take a look at IIS Application Pool in domain menu indicates that it's turned on.
    Also you can verify if dedicated pool set properly via IIS mmc.
    Possibly domain in IIS need to be reconfigured with websrvmng in some case.
     
  3. igoldman

    igoldman Regular Pleskian

    26
    23%
    Joined:
    Sep 14, 2004
    Messages:
    212
    Likes Received:
    0
    Hello ,
    I did exactly as you wrote me.
    first I have enable under setup
    and after that I have tried to enable it under IIS application pool but nothing is happen and the status is still disable.

    so you wrote me to try running the command : websrvmng

    may you please write me the full command with the arguments which I need to use

    for example the domain name is : goldman.com
     
  4. Skeeter

    Skeeter Guest

    0
     
    The commands that you should use are:
    cd %plesk_bin%
    websrvmng --remove-vhost --vhost-name=<domain-name>
    websrvmng --reconfigure-vhost --vhost-name=<domain-name>

    This will recreate the domain on IIS.

    Hope this will help you. %)
     
  5. igoldman

    igoldman Regular Pleskian

    26
    23%
    Joined:
    Sep 14, 2004
    Messages:
    212
    Likes Received:
    0
    Hello ,
    I found that the domain name goldman.com has subdomain which the domain user has deleted some folders like : httpdocs , httpsdocs ,cgi-bin ....

    so when I run :

    cd %plesk_bin%
    websrvmng --remove-vhost --vhost-name=goldman.com
    websrvmng --reconfigure-vhost --vhost-name=goldman.com

    I got error , so to resolve the rebulding in IIS , I have manually recreated the missed folders under subdomain folder.

    maybe it's a bug ?
    why domain user have the ability to deleted the automated folders ?
    how to resolve such issue in the future ? I don't want that my clients will have the ability to delete the automated folders which Plesk CP create.

    thanks to all members in this forum.
     
  6. swarm

    swarm Guest

    0
     
    I must say that can't be bug. In fact i'm not sure if you can restrict users from deleting their files and folders via ftp as that is their files and folders.
     
  7. igoldman

    igoldman Regular Pleskian

    26
    23%
    Joined:
    Sep 14, 2004
    Messages:
    212
    Likes Received:
    0
    but I am talking about the automated folders which Plesk CP create when a client create a new domain account.
    for example : httpdocs , httpsdocs and etc.

    so , I don't talking about what is inside those folders , just about the folders.

    what is inside those folders , it's the DATA of customer and he/she can do what ever they want.
     
  8. cybernova

    cybernova Guest

    0
     
    the possible solution is to recreate the hosting for the domain from the control panel and make sure the dedicated application pool option is set while you recreate it ....
     
  9. sysber

    sysber Basic Pleskian

    23
    57%
    Joined:
    Nov 8, 2005
    Messages:
    41
    Likes Received:
    0
    Hello Swarm

    Please I am a lot needing his help.

    My mistake is "similar" to this, the one that I don't get is to create the domain in IIS and in the application pool, remaining DNS, MAIL ENABLE... everything is created correctly, however in IIS he is not creating, in Event Viewer appears with the following message:

    Error in the DLL (WITH Error 800401F9) attn addAppPool(adriano.com(domain)(pool), IWPD_152(lara))
    attn (WebServerAdapter::addAppPool line 3238)
    attn addAppPool(adriano.com(domain)(pool), IWPD_152(lara)) (WebServerAdapter::addAppPool line 3252)
    attn addHosting(adriano.com)(WebServerManager::addHosting line 1913)
    attn it executes console command--reconfigure-vhost(vconsoleapp::start line 128)
    attn it executes websrvmng--reconfigure-vhost--vhost-name=adriano.com(vconsoleapp::run line 138)
    Execute cribs name: C:\Program Files\SWsoft\Plesk\admin\bin

    This domain doesn't exist in more IIS him already this servant in the control panel.

    Could great Swarm find out the one please what can do to try this to solve?

    Best, Best Regards,

    Sysber
     
  10. arazas

    arazas Guest

    0
     
    I need help please. Please help me because I am facing following problem:

    Error in the DLL (COM Error 800401F9) at addAppPool(abcd.com(domain)pool), IWPD_595(ABCD))

    I used this command:
    websrvmng.exe --reconfigure-vhost --vhost-name=abcd.com
     
Loading...