Can't write external URL in FORUMS!!! | Plesk Forum

Can't write external URL in FORUMS!!!

Discussion in 'Plesk for Windows - 8.x and Older' started by Dejin, Sep 21, 2006.

  1. Dejin

    Dejin Guest

    0
     
    Hello all,
    I have Windows 2003 server with Plesk 7.6.1
    I installed, IPB, VBulletin, SMF forums.. All of them when I or other members wants to change avatar and when they choose external URL... PHP says;
    CGI error!
    Then Service Unavialable.
    I have to restart the server to make PHP run again.
    Does anyone knows how to solve it?

    Thank you for your time!
     
  2. matija

    matija Guest

    0
     
    What does it have to do with Plesk Control Panel?!
     
  3. Dejin

    Dejin Guest

    0
     
    I believe it is plesk settings cousing this problem. I am running PHP as ISAPI having this problem, if I won't run it as ISAPI and I will choose CGI support, then I am having CGI ERROR. But at least it is just saying this. It is not crushing whole PHP in server that I need to restart to make PHP run again!
     
  4. renleon

    renleon Guest

    0
     
    Hi Dejin, I came accross a similar problem which may be related. In order for php to load an external URL it usually uses the function fopen.

    Plesk 7.6.1 comes with PHP 4.4.2 and there is a known issue with fopen and external URLs. It will give a CGI Error.

    See version 4.4.3 http://www.php.net/ChangeLog-4.php

    * Fixed bug #36017 (fopen() crashes PHP when opening a URL).

    If the forums are using fopen() for external urls (a differnt domain) then this is more than likely your problem.

    Ive not used any of the forums so I cant say for sure.
     
Loading...