1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice
  1. jovana

    jovana Regular Pleskian

    25
    57%
    Joined:
    May 31, 2006
    Messages:
    114
    Likes Received:
    0
    Location:
    Haarlem
    Well, we have found the limits of the DNScontroller witch is shiped by expand.

    After we start it up, we receive this error:

    Code:
    Starting dnscontroller:
    ERROR: operation error signal happened
    SIGXFSZ: File size limit exceeded
      Check logging files size...
                                                               [FAILED]
    
    Checking the logfile dir:

    Code:
    total 2.1G
    drwxr-xr-x  2 root root 4.0K Apr  8 10:47 .
    drwxr-xr-x  4 root root 4.0K Mar  5 08:24 ..
    -rw-r--r--  1 root root 2.0G May 11 22:43 dnscontroller.log
    -rw-r--r--  1 root root 866K Feb 12 04:02 dnscontroller.log.1.gz
    -rw-r--r--  1 root root 488K Feb 10 04:02 dnscontroller.log.2.gz
    -rw-r--r--  1 root root 906K Feb  7 04:02 dnscontroller.log.3.gz
    
    After a move of this file, all are running fine... How can we make sure the next time this will not happen?
     
  2. regx

    regx Guest

    0
     
    What's in your /usr/local/dnscontroller/etc/logrotate.d/dnscontroller file? There shall be something like

    /usr/local/dnscontroller/var/log/*.log {
    missingok
    copytruncate
    rotate 3
    size=10M
    compress
    }

    If logrotate service works, your file shall not grow to such extent. I think you shall check system logs to ensure if there were any errors from logrotate or cron service. Also it is critical that cron service is up and running all the time.

    Once I had a similar problem just because crond service wasn't configured for automatic start-up in default run-level and thus - logrotation did not work for a month after reboot. I've noticed the problem after there were no free disk space on the host.
     
  3. jovana

    jovana Regular Pleskian

    25
    57%
    Joined:
    May 31, 2006
    Messages:
    114
    Likes Received:
    0
    Location:
    Haarlem
    @regx:

    Thanks for your help on this. The file has the same info, also crond is running. But there are not cronjobs specify in the crontab -l
    What do I have to fill in to make sure it will logrotate?
     
  4. CryoGenID

    CryoGenID Regular Pleskian

    25
    90%
    Joined:
    Apr 14, 2004
    Messages:
    150
    Likes Received:
    0
    Is there any possibility to realize an auto-purge somehow?
    As I don't want to have logs from a long time ago it would be handy if I could say "delete all logs older than 6 months" or so...

    Thanks a lot for your help :)
     
  5. regx

    regx Guest

    0
     
    i think you won't see logrotate service in output 'crontab -l' command. Try checking /etc/cron.daily/logrotate file instead.
     
  6. regx

    regx Guest

    0
     
    I guess it will require some log analyzer. I do not know logrotate option that performs rotation basing on record age (6 month).
     
  7. CryoGenID

    CryoGenID Regular Pleskian

    25
    90%
    Joined:
    Apr 14, 2004
    Messages:
    150
    Likes Received:
    0
    @regx: Thanks for your reply... We'll try to find a way to delete those logs automatically ;-)
     
Loading...