1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Change into user psaadm

Discussion in 'Plesk for Linux - 8.x and Older' started by MaRiOs, Jul 8, 2005.

  1. MaRiOs

    MaRiOs Guest

    0
     
    If i login as root in the server
    how do I change to user "psaadm" ???
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    The user psaadm is normally created with no login privs.

    Why would you want to try to login as psaadm??
     
  3. MaRiOs

    MaRiOs Guest

    0
     
    cause we have a great problem between plesk and moderbill and the creation of the accounts on UTF8 encoding..

    and both sides work on it and in the end say "its moderbills issue or its plesks issue"

    .............
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    You still shouldn't have to login as psaadm to resolve the problem.

    You will have to change the user account info for psaadm to allow the user /bin/bash login, and I believe that user also is flagged for 'login disabled' under linux as well.

    Look at the 'info useradd' for more details on how to change the login privs. The useradd command will either create new users, or update existing user information.

    Caution is advised. Full backup before changing psaadm account is advised.
     
  5. MaRiOs

    MaRiOs Guest

    0
     
    i dont want to change the bin/false..
    what i wanted is to change the users's variable options (language etc)
    so I can put el_GR-UTF8
     
  6. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Ah, I forgot to interpret your original post, I forgot you're from Greece. I have to do that a lot when I'm talking to Momma Brasinikas...(my adoptive momma)

    how do I change to user "psaadm" - I thought you meant "how to login as"

    Have you tried changing the default charset in the httpd.conf? Or is the the user's language preference in the control panel you are trying to change???
     
  7. serve-you.net

    serve-you.net Guest

    0
     
    is this what you are looking for?
    /etc/sysconfig/i18n

    I can't think of anywhere else on the system level that lang is set.
     
  8. MaRiOs

    MaRiOs Guest

    0
     
    it's allready set there...
    I've email the support of plesk again,so lets see what they'll say
     
  9. jamesyeeoc

    jamesyeeoc Guest

    0
     
    That's probably what he is looking for, I assumed he already set his OS for it and that he was looking to change Apache and/or specific user settings (which I don't think there are user settings for default language/encoding)...
     
  10. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Re-reading his posts I noticed this.

    Marios - so is the problem that when a new account is created in Modernbill, that it is being given UTF8 but should be something else? Or am I still not understanding the problem (your posts have been vague).
     
  11. MaRiOs

    MaRiOs Guest

    0
     
    Read this and you will understand :
    (from Moderbill support)

    I've tried everything I can think of. The cURL post that is coming from ModernBill is being sent as UTF-8, the CGI class used by the Plesk wrapper is declared as UTF-8, and if I print the shell command to screen, it has UTF-8 characters. As far as I can see the problem is with Perl sending the command to get executed. If you have a Perl programmer on hand, you can look further into the plesk_wrapper.cgi file to see if it's possible. At this point, I don't see that it is possible. Plesk Expand works because it does not rely on the command-line creation utilities. It is an XML based API and I have tested it (with Greek characters incidentally) and know it works. You might want to contact Plesk again, but I doubt that they will do any more development on the wrapper file, though it was originally theirs. I'm sorry I can't give better news on this. I really wanted this to work with 7.5, but that does not appear possible.
     
Loading...