1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Changing Plesk database provider

Discussion in 'Plesk for Windows - 8.x and Older' started by shima, Oct 25, 2007.

  1. shima

    shima Guest

    0
     
    I installed plesk with MSSQL as a database provider, now I want to change the provider to MySql, I don't receive any error but plesk is still using MSSQL.
    What should I do ?
     
  2. Bender

    Bender Guest

    0
     
    Use Plesk reconfigurator to change database engine:
    Start -> Programs -> Swsoft -> Plesk -> Plesk reconfigurator
     
  3. shima

    shima Guest

    0
     
    Hi,
    I used plesk reconfiguration,but Plesk still uses MSSQL as Database provider, although I don't receive any error during Changing Database provider from MSSQL to MySQL.
     
  4. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Could you please find error messages in Event Viewer and put it here?
     
  5. shima

    shima Guest

    0
     
    Hi,
    First of all, I explain what I've entered in Plesk reconfigurator

    I want to switch from MSSql to MySql.
    Server type : MySql Port 8306
    administrator login : admin
    Password : Plesk admin Password

    Create DB:
    Database : psa
    database username : psa
    password : password
    password : passsword

    And there is no error in event viewer.
     
  6. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Why do you suppose Plesk still uses MSSQL ?
     
  7. JackL

    JackL Guest

    0
     
    Follow steps below:
    1. In services.mmc set PleskSQLServer to automatic
    2. In %plesk_dir%\mysql\data\my.ini
    add entry
    skip-grant-table
    and save my.ini
    3. Start PleskSQLServer
    4. cmd
    cd %plesk_dir%\mysql\bin
    mysql -P8306
    --------------
    below is mysql cli
    --------------
    use mysql
    update user set password=password('plesk-admin-password') where user="admin"
    quite
    ----------------------
    4. Remove entry skip-grant-table from my.ini
    5. Restart (start)PleskSQLServer
    6. Open Plesk REconfigurator and start database switching
    Note, that new admin user must be something like admin1 and password used must be the same as for admin
    7. STart switching

    John S.G.
     
  8. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Please download updated modules reconfigurator.exe and psaobsolete.dll and put it to %plesk_bin%.
    Next try to run switching again. If error will occur then please put text here.
     
  9. shima

    shima Guest

    0
     
    Hi,
    Before downloading updated modules of reconfigurator.exe, I want to explain the situation:

    1- I followed what JackL wrote and at end I just received these two lines in Even viewer ( As always) :
    ================================
    Event Type: Information
    Event Source: MySQL
    C:\Program Files\SWsoft\Plesk\MySQL\bin\mysqld-nt.exe: Normal shutdown

    Event Type: Information
    Event Source: MySQL
    C:\Program Files\SWsoft\Plesk\MySQL\bin\mysqld-nt.exe: Shutdown complete
    ================================

    2-I checked the status of 'Plesk SQL Server' servic in services.mmc, at the end of the "DB switching" , the service will be disabled. ( Even when I set it Automatic!)

    3- In services.mmc and for 'Plesk SQL Server' Service, I checked dependencies,in "The following system components depend on this service:" section, there was nothing!, although I thought there must be 'Plesk management Service'

    Any Idea?
    --Shima
     
  10. shima

    shima Guest

    0
     
    Hi,
    Downloading updated modules reconfigurator.exe and psaobsolete.dll didn't solve the problem. Event viewer :
    ================================
    Event Type: Information
    Event Source: MySQL
    C:\Program Files\SWsoft\Plesk\MySQL\bin\mysqld-nt.exe: Normal shutdown

    Event Type: Information
    Event Source: MySQL
    C:\Program Files\SWsoft\Plesk\MySQL\bin\mysqld-nt.exe: Shutdown complete
    ================================
    Is there any command line (instruction) for changing DB provider? I prefere to change db provider manually instead of using reconfigurator.exe.
     
  11. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    What error message Reconfigurator shown? Not in Event log but in message box.
     
  12. shima

    shima Guest

    0
     
    Hi
    The result :
    Swsoft found that the permissions on the admin user in MySQL wasn't setup correctly. They fixed this and changed the DB to MySQL.

    The question is : does it is really related to the Plesk 8.2 default setting problem?
     
  13. rackset

    rackset Guest

    0
     
    Please clarify how to fix this issue? We have the same problem, want to change engine from JET to MySQL.
     
  14. shall

    shall Regular Pleskian

    26
    57%
    Joined:
    Apr 2, 2007
    Messages:
    226
    Likes Received:
    0
Loading...