1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Cold Fusion

Discussion in 'Plesk for Linux - 8.x and Older' started by webteamHQ, Sep 27, 2005.

  1. webteamHQ

    webteamHQ Guest

    0
     
    I have been trying to get coldfusion working and enabled for one of the server domain accounts on 7.5 version

    but I am having trouble...

    the path /opt/coldfusion will not work in initialization,

    the service won't start it indicates that the configuration is incorrect, or ther license has not been entered,

    and I am unable to enable it for the account requiring it. I understand from my hsp it should be working,

    assuming this is correct, is there something I am doing wrong ? are there any docs you can refer to for more information, those I have seen so far have been vague.

    Thanks in Advance
     
  2. webteamHQ

    webteamHQ Guest

    0
     
    More Information

    Well I have followed other instructions given, and seemingly to no avail. Here is the state of things.

    In attempting the install through plesk cp gui a directory structure was in fact made for coldfusion...

    /opt/coldfusion
    /opt/coldfusion/runtime
    /opt/coldfusion/runtime/lib
    /opt/coldfusion/runtime/lib/wsconfig
    /opt/coldfusion/runtime/lib/wsconfig/psa
    /opt/coldfusion/runtime/lib/wsconfig/psa/mod_jrun20.so
    /opt/coldfusion/lib
    /opt/coldfusion/lib/wsconfig
    /opt/coldfusion/lib/wsconfig/psa
    /opt/coldfusion/lib/wsconfig/psa/mod_jrun20.so

    In doing a "coldfusion" search these were the only other instances I found.

    /usr/local/psa/admin/htdocs/server/config/coldfusion.php
    /usr/local/psa/admin/htdocs/locales/en-US/help/coldfusion.html
    /usr/local/psa/admin/plib/templates/coldfusion_conf.tpl

    when I go via cp gui to Server > License Management it says...

    Ability to use ColdFusion On

    Server > ColdFusion Settings offers the following...

    ColdFusion installation path * txt box

    when I put the path /opt/coldfusion or /opt/coldfusion/ I get a box pop that says:

    Unable to initialize CF Module: Can't manage CF Module: unzip failed see httpsd error log for details

    which say:

    [root@ logs]# vi httpsd_error_log
    [Mon Sep 26 22:11:13 2005] [notice] Apache/1.3.33 (Unix) mod_ssl/2.8.22 OpenSSL/0.9.7a PHP/4.3.10 configured -- resuming normal operations
    [Mon Sep 26 22:11:13 2005] [notice] Accept mutex: sysvsem (Default: sysvsem)
    I/O warning : failed to load external entity "/opt/coldfusion/runtime/servers/default/SERVER-INF/jrun.xml"
    Config not parsed successfully.

    System error 2: No such file or directory
    [Tue Sep 27 18:25:53 2005] [notice] caught SIGTERM, shutting down
    Processing config directory: /usr/local/psa/admin/conf/httpsd.*.include
    [Tue Sep 27 18:32:56 2005] [notice] Apache/1.3.33 (Unix) mod_ssl/2.8.22 OpenSSL/0.9.7a PHP/4.3.10 configured -- resuming normal operations
    [Tue Sep 27 18:32:56 2005] [notice] Accept mutex: sysvsem (Default: sysvsem)
    [Tue Sep 27 21:09:49 2005] [notice] caught SIGTERM, shutting down
    Processing config directory: /usr/local/psa/admin/conf/httpsd.*.include
    [Tue Sep 27 21:16:36 2005] [notice] Apache/1.3.33 (Unix) mod_ssl/2.8.22 OpenSSL/0.9.7e PHP/5.0.4 configured -- resuming normal operations
    [Tue Sep 27 21:16:36 2005] [notice] Accept mutex: sysvsem (Default: sysvsem)
    unzip failed; see httpsd error log for details
    unzip failed; see httpsd error log for details
    unzip failed; see httpsd error log for details
    unzip failed; see httpsd error log for details
    unzip failed; see httpsd error log for details

    Looking at cp gui Server > Service Management Coldfusion is greyed out and says the service won't start, because it isn't present, licensed or configured properly.

    Consequently, I still can't enable the service for a domain on this server that needs it.

    I keep asking our hsp who keeps insisting that it is installed They said...

    Dear Sir,

    You have license for support coldfusion only. You should install coldfusion yourself.

    -------------------------------------------------------
    rpm -qa | grep -i coldfusion
    [root@]# grep -i coldfusion /etc/psa/psa.key Ability to use ColdFusion: true
    ---------------------------------------------------------

    I am not a total newb, but I am way lost now. It still seems to me it isn't installed

    aren't there clear instructions anywhere ?

    HELP !!

    and Thanks in Advance
     
  3. webteamHQ

    webteamHQ Guest

    0
     
    Coldfusion not installed

    in Server> componants it says:

    coldfusion Component was not installed

    How do I install the coldfusion applications
     
Loading...