1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Coldfusion 8 and Plesk not working

Discussion in 'Plesk for Windows - 8.x and Older' started by jhankins, Aug 2, 2007.

  1. jhankins

    jhankins Guest

    0
     
    Greetings,

    I have upgraded my server to Coldfusion 8 and not surprisingly have run into a problem. Existing sites work but new sites do not see Coldfusion as being installed. If you go to the server modules area, it also does not appear that coldfusion is installed. Is there a hack I can use that will get around this? Such as setting a field somewhere manually or creating a file somewhere that it tests for?

    Also, when will CF8 be supported and in what product version?
     
  2. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    jhankins, thank you for the report.

    This feature is scheduled for Q1'08
     
  3. mattbmac

    mattbmac Guest

    0
     
    Does anyone have a hack for this? I'm not concerned about Plesk being able to manage a cf8 installation I just want to be able to add sites that will have cfm support using my installed cf8 server. I guess if it comes down to it I'll over ride configs in vhost.conf files.

    But does anyone have a more elegant solution?

    Or SWSoft folks ... could I beta test your CF8 functionality :)

    Thanks,

    -Matt
     
  4. mattbmac

    mattbmac Guest

    0
     
    trying to enable cf8 on the command line I get the following:

    /usr/local/psa/bin/cfsetting -s /opt/coldfusion8
    I/O warning : failed to load external entity "/opt/coldfusion8/runtime/servers/default/SERVER-INF/jrun.xml"
    Config not parsed successfully.

    the default location for the jrun.xml file for a cf8 standard install is /opt/coldfusion8/runtime/servers/coldfusion/SERVER-INF/jrun.xml

    cd /opt/coldfusion8/runtime/servers/ && ln -s coldfusion default

    That allows me to run the cfsetting command.

    This enables the checkbox for allowing coldfusion to be used in specific domains.

    I don't think the config dropped into the httpd.include file for the domain is going to work though:

    <IfModule mod_jrun20.c>
    JRunConfig Verbose false
    JRunConfig Apialloc false
    JRunConfig Ignoresuffixmap false
    JRunConfig Serverstore /opt/coldfusion8/runtime/lib/wsconfig/psa/jrunserver.store
    JRunConfig Bootstrap 127.0.0.1:51800
    AddHandler jrun-handler .jsp .jws .cfm .cfml .cfc
    </IfModule>

    Now I just need to figure out how to change the default config entry that's dropped in here. Hopefully it's in the psa database or in a config file somewhere. I hope it's not compiled into anything.

    If anyone has done this before or has a better idea, still please let me know.

    -Matt

    h
     
  5. jtrefet

    jtrefet Guest

    0
     
    any luck with this? I am having similar issues.
     
  6. mattbmac

    mattbmac Guest

    0
     
  7. jtrefet

    jtrefet Guest

    0
     
    Yep - found it!

    Pretty simple really - just a symbolic link is all I needed to get it working.

    You'd think sw-soft would be a bit quicker in resolving this since it is so simple...ah well.
     
  8. mattbmac

    mattbmac Guest

    0
     
    I also tried cf8 on a plesk 8.2 box running redhat 5. This poses a bit of a bigger problem. mod_jrun22 is used rather than plesk's mod_jrun20. Since the host config files look to serve cf pages only if mod_jrun20 is running, a bit more hacking is required. I haven't yet put together any instructions on this but basically, there are ways to trick this as well.

    -Matt
     
  9. jtrefet

    jtrefet Guest

    0
     
    I am wrestling with this very problem right now on another system...if you have any docs on how you got it to work - I'd be very interested.
     
  10. mikelegg

    mikelegg Guest

    0
     
    ========================================
    How to enable ColdFusion 8 on individual IIS websites.
    ========================================

    Step 1 - Enable CF Support
    --------------------------

    1. Click Start >> All Programs >> Adobe >> ColdFusion 8 >> Web Server Configuration Tool
    (I've pinned it to the start menu for convenience.)

    2. A pop up window will appear, Click the "Add" button.

    3. Select the domain from the "IIS Web Site" drop down list. (Leave all the other settings on their defaults) then click "OK"

    4. When prompted to restart the web server click "Yes"

    If you get an error saying that it can't stop the web server, just run iisreset from the command line.

    5. Click "Exit"

    Step 2 - Create Virtual Folder linking to the CFIDE folder
    ----------------------------------------------------------

    1. Open IIS, right click the required domain and select "New" >> "Virtual Directory".

    2. The Virtual Directory Creation Wizard will open. Click "Next".

    3. Enter "CFIDE" as the Alias name, click "Next".

    4. Select the master CFIDE folder (eg. C:\Inetpub\wwwroot\CFIDE) as the path, click "Next".

    5. Make sure that "Read" permissions are checked, click "Next".
     
  11. mattbmac

    mattbmac Guest

    0
     
  12. mikelegg

    mikelegg Guest

    0
     
    Re: mod_jrun22

    Thanks Matt. That's great if you're running a Linux server. But, since the post was in the "Plesk for Windows" forum I assumed the original poster needed to get CF8 working on Windows.
     
  13. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Gentlemen,

    This feature is re-scheduled for Q4'07 and will be supported since Plesk 8.3 for Windows.
     
Loading...