1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Conflicting i586 / x86_64 packages when updating

Discussion in 'Plesk for Linux - 8.x and Older' started by XelaRellum, Oct 22, 2007.

  1. XelaRellum

    XelaRellum Guest

    0
     
    I am trying to update our site that is running Plesk 8.2.0. After I update the suggested packages I receive a Plesk autoupdate failure report:

    Code:
    Downloading the file PSA_8.2.0/dist-rpm-SuSE-9.3-x86_64/build-8.2.0-suse9.3-x86_64.hdr.gz: 21%..53%..89%..100% done.
    Downloading the file PSA_8.2.0/update-rpm-SuSE-9.3-x86_64/update-8.2.0-suse9.3-x86_64.hdr.gz: 19%..48%..81%..100% done.
    Downloading the file PSA_8.2.0/thirdparty-rpm-SuSE-9.3-x86_64/thirdparty-8.2.0-suse9.3-x86_64.hdr.gz: 100% done.
    Determining the packages that need to be installed.
    
    Getting packages to installation list:
    Get packages to installation from selected component base
    Warning: packages conflict by files detected: package freetype2-2.1.9-4.4.i586
      conflict with package freetype2-32bit-9.3-7.3.x86_64
      both have file /usr/lib/libfreetype.so.6.3.7 with different md5 sum.
    Warning: packages conflict by files detected: package xorg-x11-libs-6.8.2-30.3.i586
      conflict with package xorg-x11-libs-32bit-9.3-7.3.x86_64
      both have file /usr/X11R6/lib/libX11.so.6.2 with different md5 sum.
    Warning: packages conflict by files detected: package freetype2-32bit-9.3-7.3.x86_64
      conflict with package freetype2-2.1.9-4.4.i586
      both have file /usr/lib/libfreetype.so.6.3.7 with different md5 sum.
    Warning: packages conflict by files detected: package xorg-x11-libs-32bit-9.3-7.3.x86_64
      conflict with package xorg-x11-libs-6.8.2-30.3.i586
      both have file /usr/X11R6/lib/libX11.so.6.2 with different md5 sum.
     :
     :
     :
    Starting installation of packages
    prepareInstallStep: resolve results for package(s):
     (s) system_installed_psa-8.2.0-suse9.3.build82070706.15.i586.rpm
     (s) system_installed_bash-3.0-15.i586.rpm
     (u) /root/psa/PSA_8.2.0/update-rpm-SuSE-9.3-x86_64/boost-1.32.0-3.x86_64.rpm
     (u) /root/psa/PSA_8.2.0/update-rpm-SuSE-9.3-x86_64/glibc-2.3.4-23.4.x86_64.rpm
     (u) /root/psa/PSA_8.2.0/update-rpm-SuSE-9.3-x86_64/openssl-0.9.7e-3.8.x86_64.rpm
     (u) /root/psa/PSA_8.2.0/update-rpm-SuSE-9.3-x86_64/libgcc-3.3.5-5.x86_64.rpm
     (u) /root/psa/PSA_8.2.0/update-rpm-SuSE-9.3-x86_64/libidn-0.5.9-3.x86_64.rpm
     (u) /root/psa/PSA_8.2.0/update-rpm-SuSE-9.3-x86_64/mysql-shared-4.1.10a-3.x86_64.rpm
     (u) /root/psa/PSA_8.2.0/update-rpm-SuSE-9.3-x86_64/libstdc++-3.3.5-5.x86_64.rpm
     (u) /root/psa/PSA_8.2.0/update-rpm-SuSE-9.3-x86_64/zlib-1.2.2-5.4.x86_64.rpm
    prepareInstallStep: resolve results for package(s):
     (s) system_installed_bash-3.0-15.i586.rpm
     (u) /root/psa/PSA_8.2.0/update-rpm-SuSE-9.3-x86_64/glibc-2.3.4-23.4.x86_64.rpm
     (u) /root/psa/PSA_8.2.0/update-rpm-SuSE-9.3-x86_64/libgcc-3.3.5-5.x86_64.rpm
     (u) /root/psa/PSA_8.2.0/update-rpm-SuSE-9.3-x86_64/libstdc++-3.3.5-5.x86_64.rpm
    prepareInstallStep: resolve results for package(s):
     (s) system_installed_filesystem-9.3-2.i586.rpm
    Installing the package glibc-2.3.4-23.4.x86_64
    error: Failed dependencies:
    libc.so.6 is needed by (installed) expat-1.95.8-4
    libc.so.6 is needed by (installed) libselinux-1.21.7-3
    libc.so.6 is needed by (installed) libxcrypt-2.2-3
    libc.so.6 is needed by (installed) logrotate-3.7-35.2
    libc.so.6 is needed by (installed) perl-Digest-SHA1-2.10-3
    libc.so.6 is needed by (installed) krb5-1.4-16.4
    libc.so.6 is needed by (installed) scpm-1.1-6
    libc.so.6 is needed by (installed) perl-Net_SSLeay-1.25-31
    libc.so.6 is needed by (installed) checkmedia-1.0-5
    libc.so.6 is needed by (installed) perl-TermReadKey-2.21-295
    libc.so.6 is needed by (installed) evms-2.3.3-5
    libc.so.6 is needed by (installed) iproute2-2.6.10-4
     :
     : 
    
    Any suggestions on how to resolve this?
    My "uname -a" output is:
    Code:
    Linux ###### 2.6.9-023stab044.11-smp #1 SMP Sat Sep 29 13:36:25 MSD 2007 i686 athlon i386 GNU/Linux
    
     
  2. XelaRellum

    XelaRellum Guest

    0
     
    Hello? Did anybody from support "hear" my question?

    Thanks in advance
    Alexander Mueller
    littleBLUE GmbH
     
  3. danliker

    danliker Silver Pleskian Plesk Certified Professional

    33
    43%
    Joined:
    Feb 15, 2006
    Messages:
    575
    Likes Received:
    0
    Location:
    Switzerland
    no, here is no swsoft support... read the message on top on the forum start site:

    http://forum.swsoft.com

    i do not know suse very well, but can it be that you have the plesk 64bit on a suse 32bit version?
     
  4. XelaRellum

    XelaRellum Guest

    0
     
    Ah I see, will request this.
    Well we have a vServer (hosted by 1&1) who preloaded it with Plesk as well. All the updates haven been performed by Plesk. So I dont know at which point it could have taken the wrong version (and how to resolve that).

    Alexander Mueller
    littleBLUE GmbH
     
Loading...