1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Connection to Remote Mail failing

Discussion in 'Plesk Expand 2.2 Troubleshooting Issues' started by Snowmon, Sep 3, 2007.

  1. Snowmon

    Snowmon New Pleskian

    23
     
    Joined:
    Feb 1, 2007
    Messages:
    20
    Likes Received:
    0
    On a (new) Linux 8.2 box, whenever I try log onto a domain's remote mail, it gives an error. Its set up (as far as I can tell) identical to our other Linux box which works fine. The error is rather vague: [Error #002] Unable to access the remote service: connecting to remote session failed. Contact your system administrator for support.

    Any ideas will be greatly appreciated.
     
  2. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    Try looking at your Plesk server web server logs. In Plesk for Linux they are in /usr/local/psa/admin/logs/httpsd_error_log
     
  3. Snowmon

    Snowmon New Pleskian

    23
     
    Joined:
    Feb 1, 2007
    Messages:
    20
    Likes Received:
    0
    Thank you for your response. Both servers are Linux. I examined the HTTPS log file on the Central Mail server and I can not find anything strange. There is a lot of data and I'm not sure what to look for, yet the result codes are definitely OK.

    I wanted to paste the log files but they are too large so I have attached it as a .TXT file. The first section contains a non-working log, and the second section contains the working log.
     
  4. Snowmon

    Snowmon New Pleskian

    23
     
    Joined:
    Feb 1, 2007
    Messages:
    20
    Likes Received:
    0
    forgot log file

    here is the log file now.
     
  5. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    Sorry, but I do not see anything attached.
    You can try locatning the problem if open log file with the following command
    Code:
    tail -f log-file-name
    After you click the button and get a error message, you will see only actual error messsages (relating to the time when error occured) on the log file. Interrupt the command with Ctrl+C then and send us output. We'll check what goes wrong.

    Alternatively you can post a ticket to our support service and share a ticket id (ID only) with us. If you put server access info (ip, login, password) for Plesk Expand, problem Plesk and Central Mail servers, our engineers can visit your servers and check what is going wrong. Ticket ID is required to identify which of incoming tickets is yours.
     
  6. eugenevdm

    eugenevdm Silver Pleskian

    30
    68%
    Joined:
    Nov 11, 2003
    Messages:
    611
    Likes Received:
    0
    Desperate to have this issue sorted!

    tail -f /usr/local/psa/admin/logs/httpsd_error_log

    Code:
    [Tue Apr 15 16:51:10 2008] [Plesk] ::init
    [Tue Apr 15 16:51:10 2008] [Plesk] sesion type is
    [Tue Apr 15 16:51:10 2008] [Plesk] Checking session type 4
    [Tue Apr 15 16:51:10 2008] [Plesk] [SSO] disabled
    * About to connect() to cm.snowballeffect.net port 8443
    *   Trying 196.25.207.7... * connected
    * Connected to cm.snowballeffect.net (196.25.207.7) port 8443
    * successfully set certificate verify locations:
    *   CAfile: /etc/pki/tls/certs/ca-bundle.crt
      CApath: none
    * SSL connection using DHE-RSA-AES256-SHA
    * Server certificate:
    *        subject: /C=US/ST=Virginia/L=Herndon/O=SWsoft, Inc./OU=Plesk/CN=plesk/emailAddress=info@plesk.com
    *        start date: 2007-12-02 04:10:10 GMT
    *        expire date: 2008-12-01 04:10:10 GMT
    *        issuer: /C=US/ST=Virginia/L=Herndon/O=SWsoft, Inc./OU=Plesk/CN=plesk/emailAddress=info@plesk.com
    * SSL certificate verify result: self signed certificate (18), continuing anyway.
    > POST /enterprise/control/agent.php HTTP/1.1
    Host: cm.snowballeffect.net:8443
    Accept: */*
    HTTP_AUTH_LOGIN: admin
    HTTP_AUTH_PASSWD: xxxxx
    HTTP_PRETTY_PRINT: TRUE
    Content-Type: text/xml
    Content-Length: 3752
    Expect: 100-continue
    
    < HTTP/1.1 100 Continue
    < HTTP/1.1 200 OK
    < Date: Tue, 15 Apr 2008 14:33:15 GMT
    < Server: Apache
    < X-Powered-By: PHP/5.0.5
    < Expires: Thu, 19 Nov 1981 08:52:00 GMT
    < Last-Modified: Tue, 15 Apr 2008 14:33:15 GMT
    < Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    < Pragma: no-cache
    < P3P: CP="NON COR CURa ADMa OUR NOR UNI COM NAV STA"
    < Set-Cookie: PHPSESSID=c78f2825f84e6abbfe4af97ecc8865ad; path=/
    < Set-Cookie: locale=en-US; expires=Wednesday, 15-Apr-09 14:33:15 GMT; path=/
    < Set-Cookie: locale=en-US; expires=Wednesday, 15-Apr-09 14:33:15 GMT; path=/
    < Set-Cookie: PHPSESSID=e2a59c7a19c67a6c31658fc5e497661f; path=/
    < Set-Cookie: psaContext=domains; path=/
    < Set-Cookie: locale=en-US; expires=Wednesday, 15-Apr-09 14:33:15 GMT; path=/
    < Transfer-Encoding: chunked
    < Content-Type: text/xml
    [Tue Apr 15 16:51:11 2008] [Plesk] Data received by cURL: <?xml version="1.0" encoding="UTF-8"?>
    <packet version="1.3.4.1">
      <server>
        <create_session>
          <result>
            <status>ok</status>
            <id>e2a59c7a19c67a6c31658fc5e497661f</id>
          </result>
        </create_session>
      </server>
    </packet>
    
    * Connection #0 to host cm.snowballeffect.net left intact
    [Tue Apr 15 16:51:11 2008] [Plesk] cURL info:
    array (
      'url' => 'https://cm.snowballeffect.net:8443/enterprise/control/agent.php',
      'content_type' => 'text/xml',
      'http_code' => 200,
      'header_size' => 809,
      'request_size' => 237,
      'filetime' => -1,
      'ssl_verify_result' => 18,
      'redirect_count' => 0,
      'total_time' => 0.211853,
      'namelookup_time' => 0.091049,
      'connect_time' => 0.092022,
      'pretransfer_time' => 0.12633,
      'size_upload' => 3752,
      'size_download' => 251,
      'speed_download' => 1184,
      'speed_upload' => 17710,
      'download_content_length' => 0,
      'upload_content_length' => 3752,
      'starttransfer_time' => 0.128079,
      'redirect_time' => 0,
    )
    * Closing connection #0
    [Tue Apr 15 16:51:11 2008] [Plesk] [RSession] Established the remote session (e2a59c7a19c67a6c31658fc5e497661f)
    [Tue Apr 15 16:51:11 2008] [Plesk] Session str is PHPSESSID=e2a59c7a19c67a6c31658fc5e497661f
    [Tue Apr 15 16:51:11 2008] [Plesk] Connecting to https://cm.snowballeffect.net:8443/enterprise/rsession_init.php?PHPSESSID=e2a59c7a19c67a6c31658fc5e497661f&failure_redirect_url=https%3A%2F%2Fcp3.snowballeffect.net%3A8443%2Fenterprise%2Frsession_error.php%3Ferror_code%3D002
    [Tue Apr 15 16:51:12 2008] [Plesk] ::init
    [Tue Apr 15 16:51:12 2008] [Plesk] sesion type is
    [Tue Apr 15 16:51:12 2008] [Plesk] Checking session type 4
    
     
  7. Magumo

    Magumo Guest

    0
     
    The ticket ID is 523970 as requested. Please help.
     
  8. eugenevdm

    eugenevdm Silver Pleskian

    30
    68%
    Joined:
    Nov 11, 2003
    Messages:
    611
    Likes Received:
    0
    To this day we still have the same problem.

    The ticket was never resolved.
     
  9. Zer0eXe

    Zer0eXe New Pleskian

    12
    80%
    Joined:
    Nov 2, 2011
    Messages:
    5
    Likes Received:
    0
    <b>If you still get this</b> ->> Unable to access the remote service: connecting to remote session failed. Contact your system administrator for support.
    1.Check in "Administrator information" - Allow multiple sessions under administrator's login - check this to allow.
    2.if you trying to redirect and get white screen and in address tab " rsession_error...." - uncheck in the same panel "Prevent users from working with the control panel until interface screens are completely loaded" and save it suppose to solve it.
     
  10. eugenevdm

    eugenevdm Silver Pleskian

    30
    68%
    Joined:
    Nov 11, 2003
    Messages:
    611
    Likes Received:
    0
    Interesting resolution

    Hi,

    I find your resolution quite interesting. In the end we never managed to solve this problem. However some clever Parallels engineer was able to point out the problem, but not fix it.

    It seems that on our external network we had 196.25.x.x as the external IP of the Plesk Expand server. The Plesk WWW server was something like 196.201.x.x.

    When internal network clients came from 192.168.x.x and NAT Masquerading was applied, the server failed "unable to connect to remote". But once we had both server on 196.201.x.x things improved. Unfortunately changing our entire server infrastructure to 196.201.x.x is very hard so we've just become used to the problem, to the irate of our clients.
     
Loading...