1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

debian mailman and plesk

Discussion in 'Plesk for Linux - 8.x and Older' started by tijn, May 15, 2005.

  1. tijn

    tijn Guest

    0
     
    I installed plesk 7.5.3 on a fresh new debian install. Plesk does see that mailman is installed, i can make new lists for my domains, but when going to the list admin page i get an error: object not found
    In the /var/log/apache2/error.log i see this:
    "script not found or unable to stat: /usr/lib/mailman/cgi-bin"
    This is right, it doesn't exist. There is a directory called scripts, but a ln-s scripts/ cgi-bin doesn't do the trick. Anybody knows the solutions for this?
     
  2. octotonic

    octotonic Guest

    0
     
    i also run debian + plesk and am running into the exact same problem.

    from /var/log/apache2/error.log :

    [Wed Jun 08 12:52:50 2005] [error] [client 82.171.xx.xx] File does not exist: /var/www/vhosts/default/htdocs/cgi-bin
    [Wed Jun 08 12:53:42 2005] [error] [client 82.171.xx.xx] script not found or unable to stat: /usr/lib/mailman/cgi-bin

    anyone have a suggestion on how to fix this?

    thx
    O
     
  3. n-other

    n-other Guest

    0
     
    in apache 1.3 there is an option called followsymlinks, it should be somethinf simillar in 2.0. you should check whatever it is set in properties of apache
     
  4. PSi_101

    PSi_101 Regular Pleskian

    27
    57%
    Joined:
    Oct 5, 2004
    Messages:
    161
    Likes Received:
    1
    After lots and lots of screwing around, I finally managed to fix this problem. Hopefully it will work for you too.
    Edit /etc/apache2/httpd.include and change the path to mailman. It should be /var/lib/mailman, and /var/lib/mailman/cgi-bin/ for /mailman/ scriptalias.
    After that, edit /usr/lib/mailman/Mailman/mm_cfg.py and edit the URL to be http://%s/mailman (note the removal of cgi-bin).
    After that restart mailman (which should recompile mm_cfg.pyc, if not, remove the pyc file then restart mailman).
    It should work after that!
    I'm not even sure if this is a Plesk bug or a Mailman-Debian interop bug, in which case it should be taken up with the debian mailman packaging guys.
    Give it a try and let us know if it works for you.
     
  5. Jan B

    Jan B Guest

    0
     
    I'm still getting errors becausepages are still pointing to cgi-bin (lists.LISTNAME.net/cgi-bin/mailman/admin/LISTNAME fails while lists.LISTNAME.net/mailman/admin/LISTNAME is ok). I changed all references to /usr/lib/mailman to /var/lib/mailman in httpd.include and changed the ScriptAlias entry like this:

    ScriptAlias /mailman/ /var/lib/mailman/cgi-bin/

    Here's the changed line in /usr/lib/mailman/Mailman/mm_cfg.py:

    DEFAULT_URL_PATTERN = 'http://%s/mailman'

    Isn't this last line supposed to remove the cgi-bin referers?
    Could you maybe point out what I'm missing here?
     
  6. jamesyeeoc

    jamesyeeoc Guest

    0
     
    When creating a symlink for a directory, you have to use the '-sd' options, not just '-s'
     
  7. saschahb

    saschahb Guest

    0
     
    The problem i have is that when i change the path within the httpd.include file all changes are lost after a certain amount of time...

    do you have any suggestions to make it permanent?
     
  8. jamesyeeoc

    jamesyeeoc Guest

    0
     
    It is well known that Plesk will overwrite the httpd.conf and httpd.include files (either the global or domain specific) on occasion.

    It is better to put the Directives and options into the domain's vhost.conf or vhost_ssl.conf files.
     
  9. PSi_101

    PSi_101 Regular Pleskian

    27
    57%
    Joined:
    Oct 5, 2004
    Messages:
    161
    Likes Received:
    1
    I've found the files where Plesk might pull the paths to mailman from. I'm not 100% sure if these are right or not but im testing them at the moment to see if they'll fix the problem of Plesk overwriting httpd.include with the wrong path to mailman.

    /opt/psa/admin/sbin/rblmng.sh
    and
    /opt/psa/bin/install_post.sh

    The default path in both these files is MAILMAN_ROOT_D=/usr/lib/mailman. Change it to /var/lib/mailman.

    I don't know how to make Plesk overwrite httpd.include on purpose so i'll be taking the wait and see approach.

    If someone else could assist me in giving this a try too that would be great. Many hands make light work :)
     
  10. saschahb

    saschahb Guest

    0
     
    I managed the problem and now everything works fine... i did the following steps:

    Edit /usr/lib/mailman/Mailman/mm_cfg.py and edit the URL to be http://%s/mailman (note the removal of cgi-bin).
    After that restart mailman (which should recompile mm_cfg.pyc, if not, remove the pyc file then restart mailman).

    Now it's time for a symlink because we can't change things within the httpd.include file.

    go to /var/lib/mailman and do a
    ln -ns /usr/lib/cgi-bin/mailman

    i "think" this is all... everything should work now.

    One personal thing:
    i find it really disappointing that the staff of sw-soft does not reply to any problems or even does fix the already solved problems by distributing new packages... (for example for debian users. i already fixed more than 4 bugs but sw-soft does not even reply and give them to other debian plesk users)

    greets
    sascha
     
  11. tijn

    tijn Guest

    0
     
    don't forget

    don't forget to reset your current lists.
    2 options:
    1. remove the lists and make them again or
    2. run fix-url (didn't work for me, but seems to be possible)
    run
    /usr/lib/mailman/bin/fix_url.py
    to see the syntax. Again, it didn't work for me, but maybe someone else finds out how to recover your current lists.
    In my case i had only 1 list, so installed it again.
     
  12. PSi_101

    PSi_101 Regular Pleskian

    27
    57%
    Joined:
    Oct 5, 2004
    Messages:
    161
    Likes Received:
    1
    I emailed Plesk support about this, and they sent me a replacement /opt/psa/admin/sbin/listmng file. Looks like they have a bugfix for this but you need to email them to get it.
     
Loading...