1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

default PSK Page & Not EU PG

Discussion in 'Plesk for Linux - 8.x and Older' started by thomaspr, Jul 22, 2005.

  1. thomaspr

    thomaspr Guest

    0
     
    Hello,

    I've done a completely new installation of plesk, FTP works fine. And users can remotely FTP into there account, just when you type in the WWW address of the users website you get the default plesk page telling you that either its improperly configured or no account exists for the user.

    Also I've uploaded about 2Mb worth of data into a user's account, and the diskspace usage statistics within the admin CP hasn't updated.

    I've checked, and rechecked the account details. What could be causing the default PSK appearing instead of the users homepage?

    Regards,
    thomas.
     
  2. k.satirli

    k.satirli Guest

    0
     
    check if the IPs assigned to domains are correct.

    for example if you have more IPs in a pool of a client, an IP might be assigned you didnt intend to be used for that site.

    you should also try to restart apache ( httpd -k restart via shell)
     
  3. poke

    poke Guest

    0
     
    did you remember to check the www box when setting up the domain?

    for the disk space usage, have you waited at least 24 hours b/f checking?
     
  4. thomaspr

    thomaspr Guest

    0
     
    WWW has been ticked.
    IP has been checked(its the IP of our Internet Conn, since this is a test bed)

    Waited 24hrs, and the stats have updated themselves.

    Also this plesk installation is running my Primary & Secondary DNS server do you think if this area in plesk was misconfigured it would cause the above errors?

    Anymore ideas?
     
  5. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Two additional things to check/try:

    1) Go to http://www.dnsreport.com and run a report on the domain. Resolve any Failed items.

    2) In the control panel, go to Server - IP Addresses, in the Hosting column for the IP address assigned to the domain, click on the zero number. Select the domain, then click on 'Set As Default'

    Stats are only updated once per day by a cron job. They are *not* realtime stats...
     
  6. thomaspr

    thomaspr Guest

    0
     
    Hello

    I've been checking dnsstuff and am not getting any DNS errors. It appears to resolve the DNS records fine.

    I am using one 'shared IP' accross currently 4x Plesk powered domains, one of those plesk domains(Primary & Secondary DNS server) is set to default for the 'shared ip'.

    Thanks very much for the info,
     
  7. jamesyeeoc

    jamesyeeoc Guest

    0
     
    What happens if you browse to the domain URL without the 'www.' ? does the domain come up properly?

    http://domain.com

    And it may seem silly, but you do have an index page uploaded to the domain's /httpdocs directory, right?

    You can also try manually updating the domain configs via SSH as root:

    /usr/local/psa/admin/bin/websrvmng -a -v
     
  8. thomaspr

    thomaspr Guest

    0
     
    Hello,

    Have tried with and without WWW.

    Have uploaded three pages index.html, index.htm and index.php just incase apache wonts tobe funny and look for a different starting page.

    Thanks.
    tom
     
  9. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Have you tried:

    /usr/local/psa/admin/bin/websrvmng -a -v and then restarting apache?

    And no indications in the access or error logs?

    /var/log/httpd/error_log
    /var/log/httpd/access_log

    /home/httpd/vhosts/domain.com/statistics/logs/access_log
    /home/httpd/vhosts/domain.com/statistics/logs/error_log

    (you didn't say, so I thought I'd just ask)
     
  10. thomaspr

    thomaspr Guest

    0
     
    xxx.xxx.xxx.xxx - - [25/Jul/2005:10:01:47 +0000] "GET /index.htm HTTP/1.1" 404 290 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)"
    xxx.xxx.xxx.xxx - - [25/Jul/2005:10:01:50 +0000] "GET /index.htm HTTP/1.1" 404 290 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)"
    xxx.xxx.xxx.xxx - - [25/Jul/2005:10:01:54 +0000] "GET /index.php HTTP/1.1" 404 290 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)"
    xxx.xxx.xxx.xxx - - [25/Jul/2005:10:01:55 +0000] "GET /index.php HTTP/1.1" 404 290 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)"


    [Mon Jul 25 09:58:15 2005] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
    [Mon Jul 25 09:58:15 2005] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
    [Mon Jul 25 09:58:15 2005] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
    [Mon Jul 25 09:58:15 2005] [notice] Apache/2.0.51 (Fedora) configured -- resuming normal operations
    [Mon Jul 25 10:01:47 2005] [error] [client xxx.xxx.xxx.xxx] File does not exist: /home/httpd/vhosts/default/htdocs/index.htm
    [Mon Jul 25 10:01:50 2005] [error] [client xxx.xxx.xxx.xxx] File does not exist: /home/httpd/vhosts/default/htdocs/index.htm
    [client xxx.xxx.xxx.xxx] script '/home/httpd/vhosts/default/htdocs/index.php' not found or unable to stat
    [client xxx.xxx.xxx.xxx] script '/home/httpd/vhosts/default/htdocs/index.php' not found or unable to stat
     
  11. jamesyeeoc

    jamesyeeoc Guest

    0
     
    After you uploaded the files, did you chown them to ftpdomainuser : psacln ?
     
  12. thomaspr

    thomaspr Guest

    0
     
    request's are coming in loud and clear, just for some reason its directing to the 'default' directory ... and not the username off the hosting account ?

    any ideas,

    thanks for you help on this one mate,
     
  13. thomaspr

    thomaspr Guest

    0
     
    tryed default chmod aswell as 777.
     
  14. jamesyeeoc

    jamesyeeoc Guest

    0
     
    The only other thing I can think of would be to:

    Try this:
    cp /usr/sbin/psa-suexec /usr/sbin/suexec

    The error in your logs about 'unable to stat' has until now only been posted in regards to /cgi-bin/ scripts, but hey, why not give it a shot?
     
  15. thomaspr

    thomaspr Guest

    0
     
    [root@xxxxxxxxxxx root]# cp /usr/sbin/psa-suexec /usr/sbin/suexec
    cp: `/usr/sbin/psa-suexec' and `/usr/sbin/suexec' are the same file
     
  16. jamesyeeoc

    jamesyeeoc Guest

    0
     
    You may as well check the domain conf file:

    /home/httpd/vhosts/domain.com/conf/httpd.include

    Make sure it has the appropriate entries, and especially the DocumentRoot variable
     
  17. thomaspr

    thomaspr Guest

    0
     
    Fixed.

    Thanks very much for all your help.
     
  18. jamesyeeoc

    jamesyeeoc Guest

    0
     
    What exactly was the fix? (for future readers)
     
  19. thomaspr

    thomaspr Guest

    0
     
    It was an invalid IP.

    At the start i was asked to check the IP which i did. I thought this IP was correct, The plesk software is installed on a dev-machine in our office which is connected via our network into a router ... to the internet, i had been setting plesk to my static-ip, which was incorrect i should of been setting plesk to my network ip ... 192.168.0.6.

    Silly customer error!!
     
Loading...