1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Dependency error on 7.5.1 -> 7.5.2 upgrade.

Discussion in 'Plesk for Linux - 8.x and Older' started by nige, Feb 2, 2005.

  1. nige

    nige Guest

    0
     
    Hi

    Just ran the updater to move from 7.5.1 to 7.5.2 and have got a dependency error. I'm running a clean FC2 release with only plesk updates from 7.1.

    I've already got the "non-devel" versions of libjpeg, libmng, libpng and libselinux installed. It looks like the new version of qt-devel and fam-devel needs the devel versions of these libraries whereas before they didn't.

    Should I trawl the internet to find and install manually rpms for these libraries or is this just a glitch in the updater?

    Thanks
    Nige.
     
  2. SacAutos

    SacAutos Regular Pleskian

    29
    40%
    Joined:
    Aug 23, 2002
    Messages:
    182
    Likes Received:
    0
    Me Too

    Receiving virtually the same error.

    I'm getting really sick of nothing working properly. I have a server that I'd like to retire but I can't migrate because the migrator is broken. I can't update because the updater is broken. And over the weekend I received an invoice for another year's worth of support. Support?!? For this kind of support they should be paying me...
     
  3. nige

    nige Guest

    0
     
    Dave

    I just did the obvious on this one and manually installed the rpm's it said it needed. I agree I shouldn't have to do this but SW-Soft support is too slow to deal with live-environment issues.

    I first checked what I had installed as the libraries come in devel/non-devel versions. So, for example I had libjpgeg-6b-31.1 so I installed libjpg-devel-6b-31.1.

    After that, it all ran fine.... except for MySQL via PhP and Horde. Horde was in arabic and I was getting query errors from MySQL on my PhP-based apps. The fix for this was simple, and turned out to be a new version of the Ioncube library needs installing. Search for "horde+arabic" in the forums for the fix.

    Cheers
    Nige.
     
  4. SacAutos

    SacAutos Regular Pleskian

    29
    40%
    Joined:
    Aug 23, 2002
    Messages:
    182
    Likes Received:
    0
    Okay, that worked :)

    Thanks Nige, that was particularly useful information. Fortunately I've been learning how to deal with command-line things with Linux over time and was able to apply the RPMs and the horde fix myself. (That was a laugher, wasn't it?) Your quick response was very appreciated. Now if only swsoft could improve their software quality I could go back to developing websites and not being a Linux expert.
     
  5. thundercon787

    thundercon787 Guest

    0
     
    If you do an up2date -i (rpm/dependancy) you can easily get it back up and running easily..

    -Mike
     
Loading...