1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

dependency problem: 9.2.2 => 9.2.3

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by BrunoV, Dec 28, 2009.

  1. BrunoV

    BrunoV Guest

    0
     
    Hello

    I am running PLESK 9.2.2 under Centos 5.3 32 bits
    I am trying to upgrade this server to 9.2.3 (It worked fine onto another servers)

    Below the logs:

    Starting installation of packages
    Installing the package psa-migration-manager-9.2.3-cos5.build92091016.19.i586, psa-backup-manager-9.2.3-cos5.build92091016.19.i586, psa-api-rpc-9.2.3-cos5.build92091016.19.noarch, psa-9.2.3-cos5.build92091016.19.i586, psa-api-9.2.3-cos5.build92091016.19.noarch, plesk-skins-9.2.3-0.285063.noarch, psa-updates-9.2.3-cos5.build92091210.17.noarch, psa-appvault-updates-9.2.3-cos5.build92091016.19.noarch, psa-hotfix3-9.2.3-9.2.3-cos5.build92091210.17.i586
    Préparation des paquetages pour l'installation...
    paquetage psa-api-9.2.3-cos5.build92091016.19.noarch déjà installé
    paquetage plesk-skins-9.2.3-0.285063.noarch déjà installé
    paquetage psa-9.2.3-cos5.build92091016.19.i586 déjà installé
    paquetage psa-api-rpc-9.2.3-cos5.build92091016.19.noarch déjà installé
    ERROR: Unable to install the requested packages because either there is
    not enough free disk space left, or there are package dependency problems.
    Warning! Not all packages were installed.
    Please check if your system services are operable.
    Please, contact product technical support.

    Free disk space is enough (about 10 GB) so it is a dependency problem but the packages are not provided, so I don't know how to fix this.

    I tried with the GUI, the autoinstaller tool, with the base packages, and so on. But I still have this error.
    Many packages are now installed, but the base package is still 9.2.2

    With autoinstaller there is the following option: --debug
    Where this log is wrote ?

    Some help will be appreciated ;-)
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    All autoinstaller logs you can find in /tmp
     
  3. BrunoV

    BrunoV Guest

    0
     
    Thanks for your help Igor

    However I can't find any relevant information in the autoinstaller3.log file
    There are about 10000 lines.

    In section 'Resolve requires dependencies in repository.', I can see:
    - Hardwired package detected: dependency 'plesk-skins-9.2.2' of package psa-9.2.2-cos5.build92090714.19.i586 is resolved by old plesk-skins-9.2.2-0.284681.noarch but not resolved by necessary plesk-skins-9.2.3-0.285063.noarch
    - some warning: Warning: packages conflict by files detected: package openssl-0.9.8e-7.el5.i686
    conflict with package openssl-0.9.8e-12.el5.i386

    An idea on what I need to look for ?

    How can I fix this problem ?

    Thanks
     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Try to find all installed packages plesk-skins, openssl and others with conflicts and remove it with 'rpm -e --justdb --nodeps' options. After that remove all from /tmp and run autoinstaller again. After that investigate fresh logs again.
     
Loading...