1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Distb. DNS server not getting zone data

Discussion in 'Plesk Expand Distributed Services Topics (Mail, DNS, Databases)' started by JohnnyHeavens, Mar 2, 2007.

  1. JohnnyHeavens

    JohnnyHeavens Guest

    0
     
    I am pretty new to plesk/expand so I be looking in the wrong place for things so please just let me know if none of this information helps.

    The DNS server seems to have added to Expand just fine (I actualy opened a ticket for this to get working) but when I check a zone the server does not answer authoritatively or have any records that have been entered on the plesk server.

    However I don't see anything that looks like it is not working in the dnscontroller.log

    Thanks for any help!
     
  2. bandurao

    bandurao Guest

    0
     
    Issues like this cant be helped out without seeing the server actually. But you can try the switch DNS option in Plesk.This option refreshes the DNS zone of that domain.
     
  3. JohnnyHeavens

    JohnnyHeavens Guest

    0
     
    Common now, there isn't anything that can't be fixed over a forum. :)
    Thanks for the reply and switch DNS trick. I gave that a try but still seem to have the same issue.

    Any other ideas? Everything looks ok except when I look up the domain on www.dnsreports.com I get a "lame name server" error. In other words, the distributed dns server does not return any records.
    i.e. from the above report...
    "ERROR: You have one or more lame nameservers. These are nameservers that do NOT answer authoritatively for your domain. This is bad; for example, these nameservers may never get updated. The following nameservers are lame:
    x.x.x.1"
    and
    "WARNING: At least one of your nameservers did not return your NS records (it reported 0 answers). This could be because of a referral, if you have a lame nameserver (which would need to be fixed)".

    x.x.x.1 returns 0 answers (may be a referral)"
     
  4. regx

    regx Guest

    0
     
    Well, that's not easy to give an advice without seeing the server, but lets try. :)

    Is your DNS server in slave or master mode?

    Did you try restarting your named? It helped in some problems discussed in this forum.

    Are there any zone files on your DNS servers?

    Look at your dnscontroller.log - are there any messages about adding zones, records, etc... Are there any ERR/WARN messages?

    In Expand action log you can filter out periodicla tasks having "DNS" word in title and check if there were any failures.
     
  5. JohnnyHeavens

    JohnnyHeavens Guest

    0
     
    It's not an easy remote one regx but thanks for the ideas. I have restarted named a few times so I'll look at the logs.

    Thanks again!
     
  6. JohnnyHeavens

    JohnnyHeavens Guest

    0
     
    OK-Well I think it is better now. The zone for the domain I am testing seems to ahve transfered the zone data now.
    What I did was change the mode in expand from "master master" to "slave slave" and then back to master master. I then restarted named again. At some point, the data moved transfered.

    I do have one new issue. The serials are not the same. The Plesk (master) server is using rfc1912 format of YYMMDDnn and the CDNS server (slave/secondary) seems to be using unix_timestamp. Any ideas where to change this? I suppose my preferance would be to use the rfc compliant format.

    Thanks!
     
  7. regx

    regx Guest

    0
     
    That's strange because for me it is quite opposite - Plesk has timestamp serial (Plesk for Linux 8.1.0) and central DNS has rfc-compliant serial.

    Actually I see an option to rule dns serial format in dnscontroller.conf:
    Code:
    serial_type = rfc1912
    As I've not changed this option in the config, I conclude it is the default value.
     
  8. VIB-host

    VIB-host Guest

    0
     
    I'm having the exact same problem, anyone who found a solution to this issue?

    The plesk server use the serial_type = unix_timestamp

    and the CDNS use serial_type = rfc1912

    even when I set the CNDS to serial_type = unix_timestamp it keeps using the rfc1912 standart

    Anybody who know how to fix this?
     
  9. Sergey L

    Sergey L Golden Pleskian Staff Member

    32
    43%
    Joined:
    Aug 10, 2006
    Messages:
    1,195
    Likes Received:
    30
    Did you restart /etc/init.d/dncontroller after changing the configuration file?
     
  10. VIB-host

    VIB-host Guest

    0
     
    yes I did, however, I've got a new problem with the CDNS, after it changed the records to UNIX style I don't use the same serial at both the machines ns have one seril and ns2 have a different serial?
     
Loading...