1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

DrWeb and SmarterMail

Discussion in 'Plesk for Windows - 8.x and Older' started by GARMTECH, Nov 1, 2008.

  1. GARMTECH

    GARMTECH Guest

    0
     
    Dear forum users and staff,

    Here's our situation. We run Plesk 8.6.0.1 with ClamWin and SmarterMail 4 on Windows 2003 Std R2. Recently we decided move to DrWeb. It wasn't installed, so we run Plesk 8.6.0 setup executable and as "update" option installed DrWeb from there. After rescan of components Plesk found DrWeb and we choose it as antivirus. Then we purchased and installed DrWeb license (DrWeb log shows that correct license key is successfully attached). DrWeb Update executes fine, Plesk see updated virus database. But it seems that DrWeb isn't connected to SmarterMail in any way (so doesn't scan email). I state that because: there's no antivirus configured in smartermail admin web interface, on email arrival drweb process doesn't grow in CPU usage and System>Mail>Statistics>Virus statistics show all zeros. How to enable DrWeb antivirus for SmarterMail4? Please help!

    PS: Also we use SmarterMail SpamAssassin. System>Mail>Statistics>Spam Statistics also show all zeros. Is it okay?
     
  2. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Hello GARMTECH,

    Please be sure the server-wide and/or personal mail protection settings are enabled: Plesk > Server > Mail > Spam Filtering and Plesk > Server > Mail > Antivirus
     
  3. GARMTECH

    GARMTECH Guest

    0
     
    Mail>Antivirus: Scan both incoming and outgoing mail.
    Mail>Spam Filtering: This feature is not supported by license key. But we use SmarterMail SpamAssassin and not PSA SpamAssassin that requires key.

    Please help!
     
  4. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Hello GARMTECH,

    We cannot reproduce the issue in our lab. Could you provide more detailed scenario?
     
  5. GARMTECH

    GARMTECH Guest

    0
     
    It's a usual Windows 2003 Server Standard R2 (latest windows updates), Plesk 8.6.001, SmarterMail 4.3.3048 and DrwebCom 4.44.0.1017. I've tested antivirus by sending eicar.com file and it wasn't blocked. Server-wide settings set to Scan both incoming and outgoing mail. How can I debug email checking? How DrwebCom is connected with SmarterMail? Your help badly needed!

    PS: Looks like SmarterMail doesn't know anything about DrWeb presence at all.
     
  6. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Hello GARMTECH,

    Could you share SmarterMail > Settings > General Settings > Spool options here?
    Please be sure Command-Line file to run on new mail oprtion is Enabled and equals %plesk_bin%smmailfilter.exe %filepath.
     
  7. GARMTECH

    GARMTECH Guest

    0
     
    Dear sergius,

    There was a problem. "Command-line file to run on new mail" wasn't enabled, but even after I clicked "Enable" and "Save", eicar.com file to local mailbox wasn't blocked. Nothing new in DrWeb log file in Plesk directory and Mail>Virus statistics all zeros. :( So here's config:

    Spool directory: c:\SmarterMail\Spool\
    SubSpools: 10
    Sending delay: 120 sec
    Time Between Retries: 15, 30, 60, 90 minutes
    Command-line file to run on new mail: %plesk_bin%\smmailfilter.exe %filepath [x] Enabled
    Command-line timeout: 60 sec

    Btw, "Security>Antivirus>ClamAV", "Security>Antivirus>Real-time AV" and "Security>Antivirus>Command Line AV" are disabled (nothing there).

    Any possibility to debug drweb functional? Does DrwebCom writes checks or infected found to log file?
     
  8. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Please try to do followings:

    1. replace %plesk_bin% with actual path.
    1. restart Plesk Management Service and watch some time Plesk > Server > Mail > Statistics.

    [HKLM\SOFTWARE\PLESK\PSA Config\Config]
    "Debug"=dword:0x00000001


    Next watch Plesk Application log via Windows Event Viewer.
     
  9. GARMTECH

    GARMTECH Guest

    0
     
    Dear sergius,

    Thanks for help! Changing path to actual one (so it was before I changed to %plesk_bin%) and Plesk Management Service restart solved problem. Looks like it's all about service restart. :)

    Could you please also explain me how to disable DrWeb notifications for sender and recipient on virus found? It's a real spam generator. :)

     
  10. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Please try to

    INSERT INTO psa.misc VALUES ('AntivirusNotifyAdmin', '0');
    INSERT INTO psa.misc VALUES ('AntivirusNotifySender', '0');
    INSERT INTO psa.misc VALUES ('AntivirusNotifyRecipients', '0');
     
    Last edited: Feb 21, 2009
Loading...