1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Error creating new domain

Discussion in 'Plesk for Windows - 8.x and Older' started by astech, Jan 31, 2005.

  1. astech

    astech Guest

    0
     
    I have tried to create a new domain name on my Plesk 7.0.2 Server which has never failed once. It now for some reason keeps failing to allow me to add domains.

    I have only 13 domains running, and i have provision for 35.

    Everytime i try to add a domain to any account wether i have tried to add it before or not, i get different errors popping up and failing to work.

    "Failed domain creation: Unable to update domain data: Unable to create dumps directory: domainmng failed: Run-Time error: Execute websrvmng --add-domain "--domain-name=test.com" failed: COM Error 80070003( The system cannot find the path specified.) at reload 1

    HELP?! nothing has changed on the server and i added a domain last week...now it just wont work :S
     
  2. zaques

    zaques Guest

    0
     
    I get this error too without any changes. :(
    My server is Win 2003 with Plesk 7.0.2

    What is the problem ? Where is the fix ?
     
  3. hgtech@

    hgtech@ New Pleskian

    22
    57%
    Joined:
    Jan 31, 2005
    Messages:
    21
    Likes Received:
    0
  4. zaques

    zaques Guest

    0
     
    hgtech,

    I upgraded my plesk for SP2 (now it's an 7.0.3) and the error continues.
    The strange thing is because we don't change anything.

    I need create new domains and i'm getting this strange error.... :( :confused: :confused: :confused:
     
  5. hgtech@

    hgtech@ New Pleskian

    22
    57%
    Joined:
    Jan 31, 2005
    Messages:
    21
    Likes Received:
    0
    Make a backup first, then try running the following from c:\program files\swsoft\plesk\admin\bin:

    websrvmng --reconfigure-all

    This has fixed a number of IIS domain related issues I have had over the past couple of weeks.

    - Matt
     
  6. zaques

    zaques Guest

    0
     
    I try to backup using Plesk Backup and I still get this error.

    We suspend all control painel services (option in Backup program)

    :( :( :( :( :confused: :confused:
     
  7. hgtech@

    hgtech@ New Pleskian

    22
    57%
    Joined:
    Jan 31, 2005
    Messages:
    21
    Likes Received:
    0
    So, you're getting the error you first posted about when you try to backup Plesk? Just to make sure we are on the same page, you are using the backup utility on the server that Plesk provides - not trying to backup through the control panel - correct?

    The "Suspend control panel services during backup" disables the Plesk control panel to keep changes from being to made to the server while you are backing up.

    If you are unable to get the backup to work, you should be able to run
    Code:
    [COLOR=green]websrvmng --reconfigure-all[/COLOR]
    without causing any further problems. I just always try to do a backup when possible.

    - Matt
     
  8. zaques

    zaques Guest

    0
     
    Yes, I try to backup all sites from the backup utility on the server Plesk provides and get the same first error.

    So... running "websrvmng --reconfigure-all" I do not will lose my sites/clients information, right ?

    Regards.
     
  9. hgtech@

    hgtech@ New Pleskian

    22
    57%
    Joined:
    Jan 31, 2005
    Messages:
    21
    Likes Received:
    0
    No, you won't lose your sites/clients. websrvmng --reconfigure-all reconfigures IIS according to the settings stored in the Plesk configuration database. If you've made any changes through IIS instead of the Plesk control panel, I woudn't guarantee it won't reset them though.

    Also, after looking at your error message again - check the following. Make sure websrvmng.exe exists in the c:\program files\swsoft\plesk\admin\bin directory. Also, it should have the following permissions.

    Administrators, SYSTEM: full control
    psaadm, psacln, psaserv: read & execute

    Let me know how it goes.

    - Matt
     
  10. zaques

    zaques Guest

    0
     
    Hummm... nopes!
    There is no websrvmng.exe in the c:\program files\swsoft\plesk\admin\bin directory!!! :(

    Why ? In this directory I have:

    - interop.windowsinstaller.dll
    - psa.ip.device.dll
    - psa.scheduler.device.dll
    - psaobsolete.dll

    Is anything wrong here ? :eek:
     
  11. astech

    astech Guest

    0
     
    Can't even do a backup, wont find some folder for some reason, gives the same error as when i run the reconfigure ?!

    Code:
    C:\Program Files\SWsoft\Plesk>websrvmng --reconfigure-all
    COM Error 80070003( The system cannot find the path specified.) at reload
    1
    C:\Program Files\SWsoft\Plesk>
    
     
  12. hgtech@

    hgtech@ New Pleskian

    22
    57%
    Joined:
    Jan 31, 2005
    Messages:
    21
    Likes Received:
    0
    Hummm is right. Looks like we found the problem if those are the only files you have in that directory. I'm amazed anything is working for you. Compare your file listing to the one below. A file listing of the bin directory running on Windows Server 2003 w/ Plesk 7.0.3 should be something more like:

    Directory of C:\Program Files\SWsoft\Plesk\admin\bin

    02/02/2005 01:25 PM <DIR> .
    02/02/2005 01:25 PM <DIR> ..
    09/23/2004 04:18 PM 65,601 ab.exe
    09/23/2004 04:17 PM 20,541 Apache.exe
    09/23/2004 04:18 PM 41,042 ApacheMonitor.exe
    12/16/2004 09:13 AM 196,608 backup.exe
    10/26/2004 12:44 AM 16,384 bftest.exe
    10/26/2004 12:44 AM 24,576 bntest.exe
    10/26/2004 12:44 AM 16,384 casttest.exe
    01/31/2005 10:35 PM 1,503 cert.cer
    12/16/2004 08:53 AM 94,208 certmng.exe
    12/16/2004 03:28 AM 151,552 CFMng.exe
    12/16/2004 03:27 AM 131,072 CheckDns.exe
    12/16/2004 03:26 AM 106,496 CheckPw.exe
    12/16/2004 03:27 AM 102,400 ch_admin_email.exe
    12/16/2004 08:53 AM 61,440 ch_mode.exe
    12/16/2004 03:26 AM 90,112 Ch_MySQL_Charset.exe
    12/16/2004 03:19 AM 122,880 ch_owner.exe
    12/16/2004 03:30 AM 20,480 ClamAV.exe
    01/16/2005 10:42 AM 623 clamav.InstallLog
    01/16/2005 10:42 AM 5,015 clamav.InstallState
    12/16/2004 03:21 AM 90,112 clamavmng.exe
    12/16/2004 03:22 AM 159,744 clamavpackage.dll
    12/16/2004 03:28 AM 61,440 client.exe
    12/16/2004 08:53 AM 77,824 client_mailer.exe
    12/16/2004 03:28 AM 61,440 client_pref.exe
    12/16/2004 03:18 AM 118,784 copy_file.exe
    12/16/2004 09:11 AM 16,384 crontabmng.exe
    02/25/2002 10:16 AM 769,352 cygwin1.dll
    09/23/2004 04:19 PM 8,960 dbmmanage.pl
    12/16/2004 08:54 AM 94,208 defpackagemng.exe
    10/26/2004 12:44 AM 24,576 destest.exe
    10/26/2004 12:44 AM 16,384 dhtest.exe
    12/16/2004 03:26 AM 163,840 DNSMng.exe
    12/16/2004 03:28 AM 61,440 domain.exe
    12/16/2004 08:52 AM 212,992 domainmng.exe
    12/16/2004 09:15 AM 40,960 domain_bu.exe
    12/16/2004 03:28 AM 61,440 domain_pref.exe
    12/16/2004 03:20 AM 90,112 drwebmng.exe
    12/16/2004 03:22 AM 110,592 drwebpackage.dll
    10/26/2004 12:44 AM 16,384 dsatest.exe
    10/26/2004 12:44 AM 36,864 ectest.exe
    10/26/2004 12:44 AM 16,384 enginetest.exe
    12/16/2004 03:27 AM 135,168 Enterprise_Query.exe
    12/16/2004 03:13 AM 98,304 event_handler.exe
    10/26/2004 12:44 AM 20,480 evp_test.exe
    10/26/2004 12:44 AM 16,384 exptest.exe
    12/16/2004 03:18 AM 233,472 filemng.exe
    12/16/2004 08:54 AM 282,624 ftpmng.exe
    12/16/2004 03:20 AM 90,112 get_dir_size.exe
    12/16/2004 03:20 AM 12,800 get_ip.exe
    12/16/2004 03:21 AM 49,152 get_mac.exe
    10/26/2004 12:44 AM 16,384 hmactest.exe
    09/23/2004 04:18 PM 77,892 htdbm.exe
    09/23/2004 04:18 PM 69,703 htdigest.exe
    09/23/2004 04:18 PM 77,895 htpasswd.exe
    01/31/2005 10:36 PM 2,090 httpsd.pem
    01/16/2005 10:31 AM <DIR> iconv
    12/16/2004 09:15 AM 98,304 ICSharpCode.SharpZipLib.dll
    10/26/2004 12:44 AM 16,384 ideatest.exe
    12/16/2004 03:17 AM 159,744 ifmng.exe
    03/25/2003 06:00 PM 32,768 Interop.Scripting.dll
    03/25/2003 06:00 PM 32,768 interop.windowsinstaller.dll
    12/16/2004 03:13 AM 81,920 key-writer.exe
    09/23/2004 04:16 PM 122,952 libapr.dll
    09/23/2004 04:16 PM 36,947 libapriconv.dll
    09/23/2004 04:17 PM 168,017 libaprutil.dll
    06/11/2003 04:49 PM 114,688 libcurl.dll
    10/26/2004 12:44 AM 843,776 libeay32.dll
    10/26/2004 12:44 AM 372,862 libeay32.exp
    10/26/2004 12:44 AM 550,398 libeay32.lib
    09/23/2004 04:17 PM 254,015 libhttpd.dll
    02/02/2005 01:25 PM 0 list.txt
    12/16/2004 08:52 AM 77,824 listmng.exe
    12/16/2004 03:17 AM 98,304 list_files.exe
    09/23/2004 04:18 PM 20,553 logresolve.exe
    12/16/2004 08:52 AM 86,016 logrot_mng.exe
    12/16/2004 03:28 AM 61,440 mail.exe
    12/16/2004 08:52 AM 684,032 mailenableproviderw.dll
    12/16/2004 08:52 AM 131,072 mailmng.exe
    12/16/2004 08:52 AM 98,304 mchk.exe
    10/26/2004 12:44 AM 16,384 md2test.exe
    10/26/2004 12:44 AM 16,384 Md4test.exe
    10/26/2004 12:44 AM 16,384 md5test.exe
    10/26/2004 12:44 AM 16,384 mdc2test.exe
    12/16/2004 08:54 AM 118,784 memailfilter.exe
    12/16/2004 08:53 AM 143,360 merakmailfilter.dll
    12/16/2004 03:02 AM 618,496 merakproviderw.dll
    12/16/2004 08:53 AM 106,496 mssqlmng.exe
    12/16/2004 09:17 AM 16,384 netmng.exe
    12/16/2004 03:02 AM 43,520 nt2ux.dll
    12/16/2004 03:28 AM 122,880 odbcmng.exe
    10/26/2004 12:44 AM 278,528 openssl.exe
    12/16/2004 08:53 AM 86,016 packagemng.exe
    12/16/2004 08:54 AM 106,496 pdmng.exe
    12/07/2004 11:50 PM 12,070 pfwmng.js
    11/12/2003 08:23 AM 45,056 php.exe
    02/19/2004 05:28 AM 1,269,760 php4ts.dll
    12/16/2004 09:18 AM 24,576 pleskcore.dll
    12/16/2004 09:18 AM 20,480 PleskService.dll
    12/16/2004 08:52 AM 266,240 plesksrv.exe
    12/16/2004 08:52 AM 53,248 plesksrvclient.exe
    12/16/2004 03:28 AM 106,496 PopPassD.exe
    12/16/2004 09:07 AM 242,688 psa-serv.exe
    12/16/2004 09:18 AM 28,672 psa.firewall.config.dll
    12/16/2004 03:29 AM 25,088 psa.firewall.device.dll
    12/16/2004 09:18 AM 24,576 psa.firewall.service.exe
    12/16/2004 04:19 AM 110,592 psa.ip.device.dll
    12/16/2004 09:11 AM 57,344 psa.scheduler.device.dll
    12/16/2004 09:11 AM 40,960 psa.scheduler.service.exe
    07/16/2004 12:54 PM 547 psa.scheduler.service.exe.config
    12/16/2004 09:15 AM 212,992 psabackup.dll
    12/16/2004 09:15 AM 20,480 psabackupfile.dll
    12/16/2004 09:18 AM 20,480 psacommon.dll
    12/16/2004 09:18 AM 20,480 psainterfaces.dll
    12/16/2004 09:14 AM 16,384 psamaillist.dll
    12/16/2004 09:15 AM 16,384 psamailprovider.dll
    12/16/2004 09:15 AM 1,519,616 psaobsolete.dll
    10/26/2004 12:44 AM 16,384 randtest.exe
    10/26/2004 12:44 AM 16,384 rc2test.exe
    10/26/2004 12:44 AM 16,384 rc4test.exe
    10/26/2004 12:44 AM 16,384 rc5test.exe
    12/16/2004 03:27 AM 102,400 Reconfig.exe
    12/16/2004 09:09 AM 299,008 reconfigurator.exe
    12/16/2004 03:18 AM 143,360 remove_files.exe
    12/16/2004 09:14 AM 430,080 restore.exe
    10/26/2004 12:44 AM 16,384 rmdtest.exe
    09/23/2004 04:18 PM 41,033 rotatelogs.exe
    10/26/2004 12:44 AM 16,384 rsa_test.exe
    12/16/2004 08:54 AM 143,360 sappmng.exe
    09/13/1999 02:02 AM 90,624 sed.exe
    10/26/2004 12:44 AM 16,384 sha1test.exe
    10/26/2004 12:44 AM 16,384 shatest.exe
    12/16/2004 03:19 AM 65,536 shutdown.exe
    12/16/2004 03:26 AM 155,648 SkelMng.exe
    12/16/2004 09:18 AM 28,672 SpamAssassin.dll
    12/16/2004 09:18 AM 16,384 SpamAssassinService.exe
    12/16/2004 09:18 AM 20,480 spamfilter.dll
    12/16/2004 09:18 AM 24,576 spammng.exe
    01/26/2004 08:06 PM 318 spammng.exe.config
    10/26/2004 12:44 AM 159,744 SSLeay32.dll
    10/26/2004 12:44 AM 31,481 SSLeay32.exp
    10/26/2004 12:44 AM 46,846 SSLeay32.lib
    10/26/2004 12:44 AM 28,672 ssltest.exe
    12/16/2004 08:52 AM 372,736 statistics.exe
    12/16/2004 08:53 AM 69,632 stunnelmng.exe
    12/16/2004 03:28 AM 61,440 subdomain.exe
    12/16/2004 08:54 AM 102,400 subdomainmng.exe
    12/16/2004 08:53 AM 77,824 sysinfo.exe
    12/16/2004 09:09 AM 102,400 timemng.exe
    12/16/2004 08:53 AM 212,992 tomcatmng.exe
    12/16/2004 08:53 AM 110,592 traymonitor.exe
    09/14/2004 10:33 AM 2,487 ttsmailparse.php
    05/19/2003 10:50 PM 194,560 UnRAR.exe
    02/17/1997 08:50 AM 57,344 UNTGZ32.EXE
    02/18/2002 07:56 AM 159,744 unzip.exe
    12/16/2004 03:18 AM 208,896 usermng.exe
    12/16/2004 03:21 AM 18,432 utils-lib.dll
    12/16/2004 08:54 AM 258,048 vhostmng.exe
    12/16/2004 08:54 AM 524,288 websrvmng.exe
    09/23/2004 04:18 PM 20,555 wintty.exe
    02/01/2005 12:00 AM 2,090 www_hgtech_net.crt
    10/12/2003 02:47 PM 73,728 zlib.dll
    11/18/2003 12:29 AM 55,808 zlib1.dll
    161 File(s) 19,411,676 bytes
    3 Dir(s) 75,792,891,904 bytes free


    Is everything else working? Ie. The control panel, mysql, mailenable, etc? If the files you listed were the only ones in the directory, my question to you is - Did you keep good backups and do you have the stuff to reinstall Plesk? Or an even better question might be - Why did they suddenly disappear? Let me know whats missing and we'll se what we can do.

    - Matt
     
  13. astech

    astech Guest

    0
     
    Dats wierd,

    All my files are in the \admin\bin directory so they are fine, i just can't create domains, do backups or --reconfigure-all :S

    I would have to get the datacenter my server is in to do the plesk reinstall as it is there software, but how can I do that if i can't do a backup of my current system???

    This is the error i get when I attempt a backup:

    [​IMG]

    :(
     
  14. hgtech@

    hgtech@ New Pleskian

    22
    57%
    Joined:
    Jan 31, 2005
    Messages:
    21
    Likes Received:
    0
    I'm not sure if this would work for you astech, but you could open a plesk support ticket. They charge $75 per incident and have been very helpful each time I have delt with them. The site to open a ticket is:

    https://register.sw-soft.com/support/form.php

    You are getting a slightly different error than zaques - it looks like he actually has files missing.

    Let us know how things turn out.

    - Matt
     
  15. zaques

    zaques Guest

    0
     
    Is exactly the same error in my server...
    I don't know why they disappear.. I get this errors recently... one or two days ago

    I think all works fine, but not sure. I know that add new domains, backup, webmngr, backups - etc really don't work... :(
     
  16. hgtech@

    hgtech@ New Pleskian

    22
    57%
    Joined:
    Jan 31, 2005
    Messages:
    21
    Likes Received:
    0
    So zaques - to clarify. Are the proper files in you /bin directory?
     
  17. astech

    astech Guest

    0
     
    :D YAY...I FIXED IT !!! :D

    After much buggerising around, I have managed to source the problem that was causing that error.

    It turns out that one of my subdomains was still existent in the database but not in the vhosts/ directory anymore.

    It brought up an error in IIS with one of the subdomains when you go into the IIS console, thus giving the "cannot find folder" error for any lookup that you try to do on IIS...

    The solution was to log into the control panel and remove the subdomain, however, failing that, I had to manually open the database and remove the line for the subdomain from the "subdomains" table and delete the line out of the IIS management console.

    Once I deleted these two things, I was able to do a complete backup of the system with no problems and creating domains now works fine.

    If you have tried to create domains and then had the error when you have created it, you will need to do the following to be able to create the domain in the system again:

    - delete the mailbox for the account in MailEnable
    - delete the plesk\backup\domainname.com directory
    - delete the DNS settings from the database related to the account.

    Once I did these, i was able to create domains in the system with no worries.
     
  18. zaques

    zaques Guest

    0
     
    I don't think so....

    C:\Program Files\SWsoft\Plesk\admin\bin>dir
    Volume in drive C has no label.
    Volume Serial Number is 8C6B-C720

    Directory of C:\Program Files\SWsoft\Plesk\admin\bin

    08-10-2004 20:16 <DIR> .
    08-10-2004 20:16 <DIR> ..
    03-04-2003 18:00 32.768 interop.windowsinstaller.dll
    25-08-2004 13:26 110.592 psa.ip.device.dll
    21-09-2004 10:08 57.344 psa.scheduler.device.dll
    21-09-2004 10:06 1.204.224 psaobsolete.dll
    4 File(s) 1.404.928 bytes
    2 Dir(s) 70.941.134.848 bytes free

    I really don't understand why.

    astech, yes. I do that too and still get error. Damn...
     
  19. zaques

    zaques Guest

    0
     
    and

    C:\Program Files\SWsoft\Plesk\admin\bin>websrvmng --reconfigure-all
    COM Error 80070003( The system cannot find the path specified.) at reload
    1
    C:\Program Files\SWsoft\Plesk\admin\bin>

    :(
     
  20. astech

    astech Guest

    0
     
    you obviosuly have the file websrvmng.exe somewhere or it wouldn't execute, maybe try from the C:\> prompt "dir websrvmng.exe /s" and that way you will know what folder it is in?

    I do wonder what your environment setting is for the PLESK_BIN as your EXE files arent in the /admin/bin directory tho...

    if u type SET PLESK_BIN at the command prompt it will tell you what folder plesk looks for the executables...

    once again tho, it is obviously running the file to give you that error so i can't see that as being important...

    However, i do think that that error has something to do with IIS not being able to find a directory or virtual directory that it has mapped in the console...because even tho i had one subdomain, i got the error for any domain i tried to backup...
     
Loading...