1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Error during update from 8.4 to 8.6: dependency problems

Discussion in 'Plesk for Linux - 8.x and Older' started by kbechtold, Sep 11, 2008.

  1. kbechtold

    kbechtold Guest

    0
     
    Yesterday I upgraded from Plesk 8.3 to 8.4 (Suse 10.2) without any errors. Today I started to upgrade from 8.4 to 8.6 and the upgrade broke down with dependency problems. The Plesk server is not starting anymore.

    Any ideas? "Format c:" ;-) ? Is it possible to roll back to version 8.4?

    Thank you very much!

    Best regards from Berlin, Germany

    Klaus

    #################################################################

    Here is the error log:

    START psa-8.6.0-suse10.2.build86080722.01 upgrading AT Thu Sep 11 07:04:26 CEST 2008
    Trying to register service xinetd... using /sbin/insserv
    done
    Setting the default locale
    The default locale is set to en-US (ENGLISH, UNITED STATES)


    ===> Installing rbash
    Checking that /bin/rbash registered as login shell...
    /bin/rbash
    /bin/rbash is already registered as login shell

    Trying to restart service mysql... Checking for service MySQL: ..running
    done
    ===> Installing psa database
    Trying to start MySQL server... Checking for service MySQL: ..running
    Trying to define valid mysql credentials... Trying to establish test connection... ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
    Trying to establish test connection... ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
    Trying to establish test connection... ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
    Trying to establish test connection... ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
    Trying to establish test connection... ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
    Trying to establish test connection... ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
    Trying to establish test connection... ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
    Trying to establish test connection... Could not open required defaults file: /root/.my.cnf
    Fatal error in defaults handling. Program aborted

    ERROR while trying to establish test connection

    Aborting...

    STOP psa-8.6.0-suse10.2.build86080722.01 upgrading AT Thu Sep 11 07:04:34 CEST 2008

    #################################################################

    Here is my log (this was the second try):

    Autoinstaller 3.3.2 (build at 2008-07-10 09:31 svn rev. 0) started at (timezone CET) Thu Sep 11 09:01:42 2008
    Command line args: /usr/local/psa/admin/bin/autoinstaller --enable-xml-output --source-type=plesk --target=/root/psa --select-release-id=PLESK_8_6_0 --notify-email=my@mail.com --install-component=base --install-component=docs --install-component=api --install-component=pmm --install-component=java --install-component=psa-firewall --install-component=psa-vpn --install-component=psa-fileserver --install-component=watchdog --install-component=cs-gs --install-component=spamassassin --install-component=backup-ded

    SourceUrl: original source url is http://autoinstall.plesk.com/
    SourceUrl: fixed url is http://autoinstall.plesk.com/
    Try to find rcfile...
    Autoinstaller rcfile not found.
    Return success to caller; do packages installation in background.
    Server for reporting status run OK: pid=13406
    Checking hostname is sucessfull.
    Opsys detected as: os_name=Linux os_vendor=SuSE version=10.2 arch=i686 environment=~empty
    Final opsys (with overriding) is: os_name=Linux os_vendor=SuSE version=10.2 arch=i686 environment=~empty
    SourceUrl: original source url is http://autoinstall.plesk.com/
    SourceUrl: fixed url is http://autoinstall.plesk.com/
    FileFetcher new object: target_dir=/root/psa/, main_source_url=http://autoinstall.plesk.com/

    ...

    (b) /root/psa/PSA_8.6.0/dist-rpm-SuSE-10.2-i386/base/psa-8.6.0-suse10.2.build86080722.01.i586.rpm
    (s) system_installed_psa-manual-custom-skin-guide-8.6.0-suse10.2.build86080722.01.noarch.rpm
    Installing the package psa-8.6.0-suse10.2.build86080722.01.i586
    Execute command rpm -U --test /root/psa/PSA_8.6.0/dist-rpm-SuSE-10.2-i386/base/psa-8.6.0-suse10.2.build86080722.01.i586.rpm
    package psa-8.6.0-suse10.2.build86080722.01 is already installed
    -- Check for new version of PSA_8.6.0/plesk-8.6.0-suse10.2-i386.inf3
    Filefetcher: get file (~empty)/PSA_8.6.0/plesk-8.6.0-suse10.2-i386.inf3
    ERROR: Unable to install the requested packages because of package dependency problems.
    Warning! Not all packages were installed.
    Please check if your system services are operable.
    Please, contact product technical support.
    Message sent to my@mail.com
     
Loading...