1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Error Fetching Domain information from Plesk Server

Discussion in 'Plesk Expand 2.3 Troubleshooting Issues' started by darkscreamz, Feb 19, 2009.

  1. darkscreamz

    darkscreamz Guest

    0
     
    Plesk Expand Server: Debian 4.0/Expand 2.3.2
    Plesk Server #1: RHEL 3/Plesk 8.2.0 927 clients/925 domains
    Plesk Server #2: RHEL 3/Plesk 8.2.0 1064 clients/1060 domains

    We've recently setup a new Plesk Expand server and are in the process of Adding our two Plesk servers into Expand.

    The #1 server has been added successfully and all clients/domains are appearing as expected.

    The #2 server however is initially adding into Plesk Expand OK, and importing the clients correctly, however is failing upon then importing the domains information and outputting the following error:
    <status>error</status>
    <errcode>2108</errcode>
    <errtext>[Transport] PleskAgent answer validation failed. Invalid reply from Plesk server #2 (203.10.110.244). The message does not conform to protocol 1.5.1.0 version. Make sure your Plesk and Plesk Expand servers have all available patches and hotfixes applied, if that does not help, then report a problem to Parallels. XML validation error: Error at file 'xmlPacket', line 2, column 302332: Datatype error: Type:InvalidDatatypeValueException, Message:Value '' does not match regular expression facet '([01]?\p{Nd}{1,2}|2([0-4]\p{Nd}|5[0-5]))(\.([01]?\p{Nd}{1,2}|2([0-4]\p{Nd}|5[0-5]))){3}'..</errtext>

    I found the following KB article: http://kb.odin.com/en/6002 however after adjusting the timeouts as suggested on both the Expand and #2 Plesk servers the issue still occurs when I attempt to re-add the server or perform a reload of the domains for the server.

    The two Plesk servers have a near identical setup so I don't see the cause potentially being hotfixes etc as suggested by the error message. In addition both of these servers were previously communicating with our old Plesk Expand server (2.1.3) without issue, and as the clients are importing fine from the #2 server but not the domains I'm thinking it may be something else?

    Anyone have any suggestions of where I might start to look?
     
  2. gold

    gold Regular Pleskian

    25
    57%
    Joined:
    Jan 8, 2008
    Messages:
    307
    Likes Received:
    0
    You have domain with empty IP address on the Plesk server #2 that gives such error. Please find this domain and set true IP address. To find domain you can look XML packet returned by Plesk server #2 (line 2, column 302332).
     
  3. darkscreamz

    darkscreamz Guest

    0
     
    Hrmm sorry to sound so naive, but could you advise on how I can get this further information, I'm not sure where to look to get the info it references (line 2, column 302332) as the issue?
    I've tried running from the CLI but end up with the same info as before?

    Any help would be appreciated :)




    pexpand1:/usr/local/expand/share/pleskagent/protocol/1.5.1.0# /usr/local/expand/sbin/exp_plesk_domain refresh filter [ server_id=2 ] dataset all-
    <?xml version="1.0" encoding="UTF-8" standalone="no" ?><packet action_id="7535" version="2.3.2.17"><refresh><result><status>error</status><errcode>2108</errcode><errtext>[Transport] PleskAgent answer validation failed. Invalid reply from Plesk server #2 (203.10.110.244). The message does not conform to protocol 1.5.1.0 version. Make sure your Plesk and Plesk Expand servers have all available patches and hotfixes applied, if that does not help, then report a problem to Parallels. XML validation error: Error at file 'xmlPacket', line 2, column 300193: Datatype error: Type:InvalidDatatypeValueException, Message:Value '' does not match regular expression facet '([01]?\p{Nd}{1,2}|2([0-4]\p{Nd}|5[0-5]))(\.([01]?\p{Nd}{1,2}|2([0-4]\p{Nd}|5[0-5]))){3}'..</errtext><server_id>2</server_id></result></refresh></packet>pexpand1:/usr/local/expand/share/pleskagent/protocol/1.5.1.0
     
  4. gold

    gold Regular Pleskian

    25
    57%
    Joined:
    Jan 8, 2008
    Messages:
    307
    Likes Received:
    0
    Please post the full problem report for failed action to this thread or to me by private message.
     
  5. darkscreamz

    darkscreamz Guest

    0
     
    Cheers, I've emailed the problem report to you as it could not fix in a private message.
     
  6. gold

    gold Regular Pleskian

    25
    57%
    Joined:
    Jan 8, 2008
    Messages:
    307
    Likes Received:
    0
    As workaround you can replace the type of 'dns_ip_address' element from 'ip_address' to 'string' in '/usr/local/expand/share/pleskagent/protocol/1.5.1.0/plesk_domain.xsd' file then restart Expand then try to reload domains.
     
Loading...